summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJimi Huotari <chiitoo@gentoo.org>2025-01-30 19:10:51 +0200
committerJimi Huotari <chiitoo@gentoo.org>2025-01-30 19:10:51 +0200
commit059673dae0b5bb33f28461ba56e02b5389f3319b (patch)
treecd3c9c5eaf1279fcd3c9631bf2162b21b4602f79 /media-gfx
parentx11-drivers/nvidia-drivers: add 570.86.16 (beta) (diff)
downloadgentoo-059673dae0b5bb33f28461ba56e02b5389f3319b.tar.gz
gentoo-059673dae0b5bb33f28461ba56e02b5389f3319b.tar.bz2
gentoo-059673dae0b5bb33f28461ba56e02b5389f3319b.zip
media-gfx/lximage-qt: add 2.1.1
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Diffstat (limited to 'media-gfx')
-rw-r--r--media-gfx/lximage-qt/Manifest1
-rw-r--r--media-gfx/lximage-qt/lximage-qt-2.1.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/media-gfx/lximage-qt/Manifest b/media-gfx/lximage-qt/Manifest
index eca46bfea59f..f94f12318640 100644
--- a/media-gfx/lximage-qt/Manifest
+++ b/media-gfx/lximage-qt/Manifest
@@ -1,2 +1,3 @@
DIST lximage-qt-2.0.1.tar.xz 848348 BLAKE2B d2484baffaae220436ae157dccda86e126b416101f047133f494cb44d9c3bba007ce797c1aa88d21ba4b242abdf8cacf73706831570943e4d7a36eb02591fc7b SHA512 594e86a4bedf3f9689107d79d852ba1ef4db83f06572b8c077ed5850dc10cc05a33fe79a0c05632f7e7541a6f895919b72c264635306f7a468eac6ecde531ba4
DIST lximage-qt-2.1.0.tar.xz 852988 BLAKE2B 76b9e5b87ed216474c28b8f9f5ceddb012b83c5239c506ebd51e306c53ffdbe84da44f6c752c17dc26be0705ce6a23d7dcd25d93b608089dfe580b069e37c40c SHA512 f94f6ee07e83524ac37f2377d5e5fec4926e2fdd33af67213cbe91ce1e40215774c2a79b81f16ac9d88e44e8bb55750a48cc4d68266d03d9c8973e1319f393c5
+DIST lximage-qt-2.1.1.tar.xz 857380 BLAKE2B a4e78e66b569533d1259463f5e3ec60a1b281076f7270576c6bf8406cc4adb416522b7ed4c5aac073ca7e48fcee448c4610b4ecaf0259f8afaf44c721235e19c SHA512 c0f070dbee821fc86bdebb09c09a5a1cac5d23033c73bdefe8d2ff62deee4d4ecdec18319f9d9badba1808f2cf94c7e87660d6193caed85900b68d7b59ccaa6f
diff --git a/media-gfx/lximage-qt/lximage-qt-2.1.1.ebuild b/media-gfx/lximage-qt/lximage-qt-2.1.1.ebuild
new file mode 100644
index 000000000000..3a53ce9cb021
--- /dev/null
+++ b/media-gfx/lximage-qt/lximage-qt-2.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg
+
+DESCRIPTION="Qt Image Viewer"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.1.0
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-libs/glib:2
+ >=dev-qt/qtbase-6.6:6[dbus,gui,network,widgets]
+ >=dev-qt/qtsvg-6.6:6
+ media-libs/libexif
+ =x11-libs/libfm-qt-${MY_PV}*:=
+ x11-libs/libX11
+ x11-libs/libXfixes
+"
+RDEPEND="${DEPEND}"