summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-17 20:28:56 +0100
committerSam James <sam@gentoo.org>2022-06-17 20:32:52 +0100
commit17e14c65fd5716aef842ca25b63a7c4c43e3f0dc (patch)
tree019c57b9a55d91cc8337478814b7c76d07d463a9 /media-libs/alsa-lib
parentapp-shells/bash: add 5.2_rc1 (diff)
downloadgentoo-17e14c65fd5716aef842ca25b63a7c4c43e3f0dc.tar.gz
gentoo-17e14c65fd5716aef842ca25b63a7c4c43e3f0dc.tar.bz2
gentoo-17e14c65fd5716aef842ca25b63a7c4c43e3f0dc.zip
media-libs/alsa-lib: add 1.2.7.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/alsa-lib')
-rw-r--r--media-libs/alsa-lib/Manifest1
-rw-r--r--media-libs/alsa-lib/alsa-lib-1.2.7.1.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/media-libs/alsa-lib/Manifest b/media-libs/alsa-lib/Manifest
index cf75cd21ef5a..a48b1fed6157 100644
--- a/media-libs/alsa-lib/Manifest
+++ b/media-libs/alsa-lib/Manifest
@@ -1,2 +1,3 @@
DIST alsa-lib-1.2.6.1.tar.bz2 1079670 BLAKE2B 4f3d1d078678773b4f6a569d0eea95d0cf89a846605c3a95e11b92f1fe0bd9fb164b8f710906f0de9675ade7ef2123375eb1221945bec511708d6fdd85c051b9 SHA512 70e539cf092b5d43e00e4134d8a3e184f0dc34312823e4b58a574320cbf06cb7369bc3251ecb1858033756a7a8c35d36faa8da48d49f6efe0cec905784adbd45
+DIST alsa-lib-1.2.7.1.tar.bz2 1084711 BLAKE2B b7be12a51453a82d0eb2e57fb8f9391c8778e8c63b78b6e6f46437bca39e3efb13394ba0e060547781ccde75fcdc19da532d5aed24fe0d5cfb885c1604e4e8ce SHA512 2a0b4205e8bf602b56a6f5007ba219799e5443827393058e439adf5b391bb6c4815a48bb994b5d108b9f31a90db0eb43a96a0d7741216e2d710dc63d372de27e
DIST alsa-lib-1.2.7.tar.bz2 1084924 BLAKE2B a3bfbbfcf31625be0749218b3c02b307da9077d4bd82e9f980b8e3d6f9275f3a3f3c8158bb28fb1c61724a35e794eb3f6cc8872202ff42fb847725058109087e SHA512 6bd48b07d659fddad792876326a93b2a549ce94bc191131670365599c31f81f737bfd8e94dec6fe296bc5d86df2e3e381bbb7a694d24fe7e8e501f1c994ed084
diff --git a/media-libs/alsa-lib/alsa-lib-1.2.7.1.ebuild b/media-libs/alsa-lib/alsa-lib-1.2.7.1.ebuild
new file mode 100644
index 000000000000..94d96f7b806b
--- /dev/null
+++ b/media-libs/alsa-lib/alsa-lib-1.2.7.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit autotools multilib-minimal python-single-r1
+
+DESCRIPTION="Advanced Linux Sound Architecture Library"
+HOMEPAGE="https://alsa-project.org/wiki/Main_Page"
+if [[ ${PV} == *_p* ]] ; then
+ # Please set correct commit ID for a snapshot release!!!
+ COMMIT="abe805ed6c7f38e48002e575535afd1f673b9bcd"
+ SRC_URI="https://git.alsa-project.org/?p=${PN}.git;a=snapshot;h=${COMMIT};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}"/${PN}-${COMMIT:0:7}
+else
+ # TODO: Upstream does publish .sig files, so someone could implement verify-sig ;)
+ SRC_URI="https://www.alsa-project.org/files/pub/lib/${P}.tar.bz2"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alisp debug doc python +thread-safety"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="media-libs/alsa-topology-conf
+ media-libs/alsa-ucm-conf
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( >=app-doc/doxygen-1.2.6 )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.1.6-missing_files.patch" # bug #652422
+)
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ find . -name Makefile.am -exec sed -i -e '/CFLAGS/s:-g -O2::' {} + || die
+ # bug #545950
+ sed -i -e '5s:^$:\nAM_CPPFLAGS = -I$(top_srcdir)/include:' test/lsb/Makefile.am || die
+
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --disable-maintainer-mode
+ --disable-resmgr
+ --enable-aload
+ --enable-rawmidi
+ --enable-seq
+ --enable-shared
+
+ # enable Python only on final ABI
+ $(multilib_native_use_enable python)
+ $(use_enable alisp)
+ $(use_enable thread-safety)
+ $(use_with debug)
+ )
+
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ emake doc
+ grep -FZrl "${S}" doc/doxygen/html | \
+ xargs -0 sed -i -e "s:${S}::" || die
+ fi
+}
+
+multilib_src_install() {
+ multilib_is_native_abi && use doc && local HTML_DOCS=( doc/doxygen/html/. )
+
+ default
+}
+
+multilib_src_install_all() {
+ find "${ED}" -type f \( -name '*.a' -o -name '*.la' \) -delete || die
+
+ dodoc ChangeLog doc/asoundrc.txt NOTES TODO
+}