summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-09 04:36:57 +0100
committerSam James <sam@gentoo.org>2022-07-09 04:36:57 +0100
commita36c2fe708bf8a34efc626cca0cf81beae22c74a (patch)
tree84204032a704b768786b17bb188fdedce80da3a8 /media-libs/codec2
parentdev-libs/libcdada: add 0.4.0 (diff)
downloadgentoo-a36c2fe708bf8a34efc626cca0cf81beae22c74a.tar.gz
gentoo-a36c2fe708bf8a34efc626cca0cf81beae22c74a.tar.bz2
gentoo-a36c2fe708bf8a34efc626cca0cf81beae22c74a.zip
media-libs/codec2: add 1.0.4
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/codec2')
-rw-r--r--media-libs/codec2/Manifest1
-rw-r--r--media-libs/codec2/codec2-1.0.4.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/media-libs/codec2/Manifest b/media-libs/codec2/Manifest
index 6318858cee0d..f946705a426f 100644
--- a/media-libs/codec2/Manifest
+++ b/media-libs/codec2/Manifest
@@ -1 +1,2 @@
DIST codec2-1.0.3.tar.gz 15000670 BLAKE2B 784f3f522ff6de0f5d6622ca379e5b61081c999b1310e0f45891758c818005d12418907bc9627c1a177cb961f54d20e330e646426b4eb885a548af70014ab521 SHA512 1b59a0520d55b0f92b72a51dde0f58a0cd845056195734d23bf59bf44e7b5c7431bdc3cebe7c60aef7dadf3ec02f9edd62f041b4b283c05a4b50a0380f3ed67c
+DIST codec2-1.0.4.tar.gz 14787297 BLAKE2B 21d7ec1d88cd27846e853c4c812efaf354bbd229a42635b4de8cb248880e37ef083660131083d011cb98d4ad37ef5597fea93ccc2499e760ac671345e892c760 SHA512 af279528876f7fdbca853ce4840683e07ca2124a5fd2aada4f4484501eac64f06fb1e8ba0bb1d588f9460968a029ea7c3d71c969e7ac2b7024916efd2dacc207
diff --git a/media-libs/codec2/codec2-1.0.4.ebuild b/media-libs/codec2/codec2-1.0.4.ebuild
new file mode 100644
index 000000000000..fdd5f6ec18cf
--- /dev/null
+++ b/media-libs/codec2/codec2-1.0.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Low bit rate speech codec"
+HOMEPAGE="https://freedv.org/ https://www.rowetel.com/?page_id=452 https://github.com/drowe67/codec2"
+SRC_URI="https://github.com/drowe67/codec2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="examples test"
+
+# Not yet passing, but infrastructure added to run
+# Needs Octave dependencies like "signal"?
+# https://github.com/drowe67/codec2/commit/9a129f1b3ad12ecbf3df7f4460f496ee11e49c08#diff-b335630551682c19a781afebcf4d07bf978fb1f8ac04c6bf87428ed5106870f5R155
+RESTRICT="test"
+
+#BDEPEND="test? ( sci-mathematics/octave )"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUNITTEST=$(usex test)
+ -DINSTALL_EXAMPLES=$(usex examples)
+ )
+
+ cmake_src_configure
+}