summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gavl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gavl')
-rw-r--r--media-libs/gavl/Manifest2
-rw-r--r--media-libs/gavl/gavl-1.2.0.ebuild45
-rw-r--r--media-libs/gavl/gavl-1.4.0-r1.ebuild49
-rw-r--r--media-libs/gavl/gavl-1.4.0.ebuild49
-rw-r--r--media-libs/gavl/metadata.xml11
5 files changed, 156 insertions, 0 deletions
diff --git a/media-libs/gavl/Manifest b/media-libs/gavl/Manifest
new file mode 100644
index 000000000000..9493b62162d7
--- /dev/null
+++ b/media-libs/gavl/Manifest
@@ -0,0 +1,2 @@
+DIST gavl-1.2.0.tar.gz 4589139 SHA256 814120339f7a99d35c36e0eb61ba6cf60bd939ee4a47d73a17f3ba1438c5f88e
+DIST gavl-1.4.0.tar.gz 4592701 SHA256 51aaac41391a915bd9bad07710957424b046410a276e7deaff24a870929d33ce SHA512 beda0073cab865fdb3a55de5d5c800fabcd40b21c5bb5b5f9d43046db3602d8967fb8b893325fcdaca3fa66d978aa3cae79a4a797d43d40ad50ea5af752a650a WHIRLPOOL 59a35edfaeafc311f1c4537eb03fc747c3c2807152543e3d7f721e525a67f14553e9903a7c9704ea36c77354e5f3958160368c58a43ab3f48388ef9de2d4f2e2
diff --git a/media-libs/gavl/gavl-1.2.0.ebuild b/media-libs/gavl/gavl-1.2.0.ebuild
new file mode 100644
index 000000000000..c52cf0a4670e
--- /dev/null
+++ b/media-libs/gavl/gavl-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit autotools-utils
+
+DESCRIPTION="library for handling uncompressed audio and video data"
+HOMEPAGE="http://gmerlin.sourceforge.net"
+SRC_URI="mirror://sourceforge/gmerlin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~ppc64 x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+# pkg-config is only here to satisfy autotools-utils.eclass wrt #432796
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ sed -i \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e 's:-mfpmath=387::g' \
+ -e 's:-O3 -funroll-all-loops -fomit-frame-pointer -ffast-math::g' \
+ -e '/LDFLAGS=/d' \
+ configure.ac || die
+
+ AT_M4DIR="m4" eautoreconf
+}
+
+src_configure() {
+ # --disable-libpng because it's only used for tests
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}/html
+ --disable-libpng
+ $(use_with doc doxygen)
+ --without-cpuflags
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/media-libs/gavl/gavl-1.4.0-r1.ebuild b/media-libs/gavl/gavl-1.4.0-r1.ebuild
new file mode 100644
index 000000000000..a6674fa770b6
--- /dev/null
+++ b/media-libs/gavl/gavl-1.4.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-multilib
+
+DESCRIPTION="library for handling uncompressed audio and video data"
+HOMEPAGE="http://gmerlin.sourceforge.net"
+SRC_URI="mirror://sourceforge/gmerlin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ~ppc64 x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # AC_CONFIG_HEADERS, bug #467736
+ sed -i \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e 's:-mfpmath=387::g' \
+ -e 's:-O3 -funroll-all-loops -fomit-frame-pointer -ffast-math::g' \
+ -e '/LDFLAGS=/d' \
+ configure.ac || die
+
+ export AT_M4DIR="m4"
+
+ autotools-multilib_src_prepare
+}
+
+src_configure() {
+ # --disable-libpng because it's only used for tests
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}/html
+ --disable-libpng
+ $(use_with doc doxygen)
+ --without-cpuflags
+ )
+
+ autotools-multilib_src_configure
+}
diff --git a/media-libs/gavl/gavl-1.4.0.ebuild b/media-libs/gavl/gavl-1.4.0.ebuild
new file mode 100644
index 000000000000..a421951bffa8
--- /dev/null
+++ b/media-libs/gavl/gavl-1.4.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="library for handling uncompressed audio and video data"
+HOMEPAGE="http://gmerlin.sourceforge.net"
+SRC_URI="mirror://sourceforge/gmerlin/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( app-doc/doxygen )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS README TODO )
+
+src_prepare() {
+ # AC_CONFIG_HEADERS, bug #467736
+ sed -i \
+ -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' \
+ -e 's:-mfpmath=387::g' \
+ -e 's:-O3 -funroll-all-loops -fomit-frame-pointer -ffast-math::g' \
+ -e '/LDFLAGS=/d' \
+ configure.ac || die
+
+ export AT_M4DIR="m4"
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ # --disable-libpng because it's only used for tests
+ local myeconfargs=(
+ --docdir=/usr/share/doc/${PF}/html
+ --disable-libpng
+ $(use_with doc doxygen)
+ --without-cpuflags
+ )
+
+ autotools-utils_src_configure
+}
diff --git a/media-libs/gavl/metadata.xml b/media-libs/gavl/metadata.xml
new file mode 100644
index 000000000000..79a37f98e4af
--- /dev/null
+++ b/media-libs/gavl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>media-video@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">gmerlin</remote-id>
+ </upstream>
+</pkgmetadata>