summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/gstreamer-editing-services/gstreamer-editing-services-1.2.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/gstreamer-editing-services/gstreamer-editing-services-1.2.1.ebuild')
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.2.1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.2.1.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.2.1.ebuild
new file mode 100644
index 000000000000..fb635903c8f2
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64"
+IUSE="+introspection"
+
+# FIXME: There is something odd with pygobject check for >=4.22,
+# check with upstream
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-1.2:1.0[introspection?]
+ >=media-libs/gst-plugins-base-1.2:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gnonlin:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.3
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # FIXME: disable failing check
+ sed -e 's|\(tcase_add_test (.* test_project_load_xges);\)|/*\1*/|' \
+ -i "${S}"/tests/check/ges/project.c || die
+}
+
+src_configure() {
+ # gtk is only used for examples
+ # GST_INSPECT true due bug #508096
+ econf \
+ GST_INSPECT=$(type -P true) \
+ $(use_enable introspection) \
+ --disable-examples \
+ --disable-gtk-doc \
+ --without-gtk \
+ --with-package-name="GStreamer editing services ebuild for Gentoo" \
+ --with-package-origin="http://packages.gentoo.org/package/media-libs/gstreamer-editing-services"
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}