summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-libs/libgpod
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-libs/libgpod')
-rw-r--r--media-libs/libgpod/Manifest1
-rw-r--r--media-libs/libgpod/libgpod-0.8.3.ebuild73
-rw-r--r--media-libs/libgpod/metadata.xml15
3 files changed, 89 insertions, 0 deletions
diff --git a/media-libs/libgpod/Manifest b/media-libs/libgpod/Manifest
new file mode 100644
index 000000000000..7fb0c403e905
--- /dev/null
+++ b/media-libs/libgpod/Manifest
@@ -0,0 +1 @@
+DIST libgpod-0.8.3.tar.bz2 801903 SHA256 638a7959d04e95f1e62abad02bd33702e4e8dfef98485ac7d9d50395c37e955d SHA512 e39f22054c2d2bdf5fc764aa1f692de17a1a06c7c7e9c60883d126b216dacca7840bf818e7e7e039218fe2a64c0920ba96d8cbbe310e11c1c4e68b82e7cbbd8e WHIRLPOOL a82d5d5c095d3240dbc0c5dd0f857c836591fa0d29347463a66c2811dc6dce0263c220835eb9e12cb54e82d7570c898dfdf69513f5134ea2d8ad18ccee7f3a5f
diff --git a/media-libs/libgpod/libgpod-0.8.3.ebuild b/media-libs/libgpod/libgpod-0.8.3.ebuild
new file mode 100644
index 000000000000..5b2a7f138263
--- /dev/null
+++ b/media-libs/libgpod/libgpod-0.8.3.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# TODO: Use python-r1 instead and support Python 3.x?
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils mono-env python-single-r1 udev
+
+DESCRIPTION="Shared library to access the contents of an iPod"
+HOMEPAGE="http://www.gtkpod.org/libgpod/"
+SRC_URI="mirror://sourceforge/gtkpod/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="+gtk python +udev ios mono static-libs"
+
+RDEPEND=">=app-pda/libplist-1.0:=
+ >=dev-db/sqlite-3
+ >=dev-libs/glib-2.16:2
+ dev-libs/libxml2
+ sys-apps/sg3_utils
+ gtk? ( x11-libs/gdk-pixbuf:2 )
+ ios? ( app-pda/libimobiledevice:= )
+ python? (
+ ${PYTHON_DEPS}
+ >=media-libs/mutagen-1.8[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-2.8:2[${PYTHON_USEDEP}]
+ )
+ udev? ( virtual/udev )
+ mono? (
+ >=dev-lang/mono-1.9.1
+ >=dev-dotnet/gtk-sharp-2.12
+ )"
+DEPEND="${RDEPEND}
+ python? ( >=dev-lang/swig-1.3.24 )
+ dev-libs/libxslt
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DOCS="AUTHORS NEWS README* TROUBLESHOOTING"
+
+pkg_setup() {
+ use mono && mono-env_pkg_setup
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable udev) \
+ $(use_enable gtk gdk-pixbuf) \
+ $(use_enable python pygobject) \
+ --without-hal \
+ $(use_with ios libimobiledevice) \
+ --with-udev-dir="$(get_udevdir)"
+ --with-html-dir=/usr/share/doc/${PF}/html \
+ $(use_with python) \
+ $(use_with mono)
+}
+
+src_install() {
+ default
+ rmdir "${ED}"/tmp
+ prune_libtool_files --all
+}
diff --git a/media-libs/libgpod/metadata.xml b/media-libs/libgpod/metadata.xml
new file mode 100644
index 000000000000..0ec33c7f18ed
--- /dev/null
+++ b/media-libs/libgpod/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>pda</herd>
+ <longdescription lang="en">
+ libgpod is a shared library to access the contents of an iPod. This
+ library is based on code used in the gtkpod project.
+ </longdescription>
+ <use>
+ <flag name="gtk">Enable ArtworkDB support</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">gtkpod</remote-id>
+ </upstream>
+</pkgmetadata>