summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-09-27 04:31:56 +0100
committerSam James <sam@gentoo.org>2023-09-27 04:31:56 +0100
commit7a5988d6db2b42243501826054f7b86c087050b4 (patch)
tree00ce8bba06b1497a7d130acbf1c2ee77bee72fc8 /media-libs/libsdl
parentmedia-video/pipewire: Stabilize 0.3.80 arm64, #914776 (diff)
downloadgentoo-7a5988d6db2b42243501826054f7b86c087050b4.tar.gz
gentoo-7a5988d6db2b42243501826054f7b86c087050b4.tar.bz2
gentoo-7a5988d6db2b42243501826054f7b86c087050b4.zip
media-libs/libsdl: add 1.2.68
The release notes mention sdl-perl works now, so maybe it fixes our problems (or perhaps the hang I've seen even if not the assert). See https://github.com/libsdl-org/sdl12-compat/releases/tag/release-1.2.68. Bug: https://bugs.gentoo.org/907609 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/libsdl')
-rw-r--r--media-libs/libsdl/Manifest1
-rw-r--r--media-libs/libsdl/libsdl-1.2.68.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/media-libs/libsdl/Manifest b/media-libs/libsdl/Manifest
index 13446d55f6f5..e60a4ed8bb39 100644
--- a/media-libs/libsdl/Manifest
+++ b/media-libs/libsdl/Manifest
@@ -1,3 +1,4 @@
DIST SDL-1.2.15_p20221201.tar.gz 4002787 BLAKE2B 87b729cb16cfb36efa2b66166ef21d4c5c8bc99f8c8b4683885f04699122945a60512c5875d0c8425ddfe33b2eb901d11f27afbd9e3656cde3f30de5a5f1537c SHA512 5e70977cf5beaffebb28ae84f778e08d3cf56b2badda125ec1f08ac26c6b4e60a148d9ca9b2d7efee8a5fbc0b1a343d1d27a05be1c08e5d9251da67aea209659
DIST libsdl-1.2.64.tar.gz 459020 BLAKE2B 72e13e14c134116edc73a9127a854700f0c878b3a56ae0ed5c70a3e227fcd46411ebb25bdf0ebfe76c1c648ac6052161e3eae11ebdee8ffbddb5cf70e9b01da3 SHA512 cd551666d2e6a2de273ee29b9a68a5472933a5f5a6340616510051e78f0a96af68a2f13f4473431d6b58ad89a379d672b3a3e82bc86ded01943b6bc3ca7947d2
DIST libsdl-1.2.64_p20230726.tar.gz 459365 BLAKE2B d669e46cb6f1f2ac4869d438d0a045019f8b5132c9e4a34b0945a83514fadb4e7c52954657ff3d9a149c3e052b88c77b740920171654add31d65806a361debfa SHA512 4cb41fb455ea7bfe7768f88715064fa5e092e6e24cdc7e0786f91693f21425a53fb3ba355100db5984d5ca969916f22738b7abd5cb58b87b43a154098979ee2d
+DIST libsdl-1.2.68.tar.gz 460180 BLAKE2B c821772d5c43a9406e06f89d7f0248e051b2cfb0aff33e025dc645d6ba17277ca6db44a586e65fda48155dfb6c48a9d0459d59319ea6750562caa96194ff232b SHA512 d0e71e75f312402bf075f6553d9fd6493a3db9dd42719bb753287a35e6c40ee37c6092b157ff2384f3055400a3113645595d1269590cd50ea1e0c8f247240858
diff --git a/media-libs/libsdl/libsdl-1.2.68.ebuild b/media-libs/libsdl/libsdl-1.2.68.ebuild
new file mode 100644
index 000000000000..20bb9b03f3f6
--- /dev/null
+++ b/media-libs/libsdl/libsdl-1.2.68.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake-multilib
+
+DESCRIPTION="Simple Direct Media Layer 1.2 compatibility wrapper around SDL2"
+HOMEPAGE="https://github.com/libsdl-org/sdl12-compat"
+if [[ ${PV} == *_p* ]] ; then
+ MY_COMMIT="f94a1ec0069266e40843138d0c5dd2fc6d43734c"
+ SRC_URI="https://github.com/libsdl-org/sdl12-compat/archive/${MY_COMMIT}.tar.gz -> libsdl-${PV}.tar.gz"
+ S="${WORKDIR}"/sdl12-compat-${MY_COMMIT}
+else
+ SRC_URI="https://github.com/libsdl-org/sdl12-compat/archive/refs/tags/release-${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/sdl12-compat-release-${PV}"
+fi
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv"
+
+# IUSE dropped from real SDL1: aalib custom-cflags dga fbcon libcaca nas oss pulseaudio static-libs tslib xinerama xv
+IUSE="alsa +joystick opengl +sound test +video X"
+REQUIRED_USE="test? ( joystick opengl sound video )"
+
+# The tests are more like example programs.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/libsdl2[${MULTILIB_USEDEP},alsa=,joystick=,opengl=,sound=,video=,X=]
+"
+
+DEPEND="
+ ${RDEPEND}
+ test? ( virtual/opengl[${MULTILIB_USEDEP}] )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSDL12TESTS=$(usex test)
+ )
+
+ cmake-multilib_src_configure
+}