summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-04 04:31:51 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-04 04:45:25 +0200
commit3dd53feb148804bc130a581b2b771dc86d3de70c (patch)
treeb5ac6ddb16ccf574528c614556d90077fc243e0e /media-libs/mutagen
parentdev-python/hypothesis: Bump to 6.83.1 (diff)
downloadgentoo-3dd53feb148804bc130a581b2b771dc86d3de70c.tar.gz
gentoo-3dd53feb148804bc130a581b2b771dc86d3de70c.tar.bz2
gentoo-3dd53feb148804bc130a581b2b771dc86d3de70c.zip
media-libs/mutagen: Bump to 1.47.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-libs/mutagen')
-rw-r--r--media-libs/mutagen/Manifest1
-rw-r--r--media-libs/mutagen/mutagen-1.47.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/media-libs/mutagen/Manifest b/media-libs/mutagen/Manifest
index d7d6e81658f1..50cd58516751 100644
--- a/media-libs/mutagen/Manifest
+++ b/media-libs/mutagen/Manifest
@@ -1 +1,2 @@
DIST mutagen-1.46.0.tar.gz 1268561 BLAKE2B 44e0dbbc1c102521569a91386a9d807f3ad82ffb96a5e3f76958551d173d00c7095fa6a2668a0a418bfdda31be5c3bb175856b2278719007bf7af866c732dc40 SHA512 52ab7408af46e54e79f1d157a3f6114e2606c6a55eb46fdd314dff82d6d586c2c22294b181a432581230dee566c79554456a9435a8e1188a91f4ae000644ae71
+DIST mutagen-1.47.0.tar.gz 1274186 BLAKE2B 220d8e136e8f41d2f3953ce61b4784a24b1e450b6cfe0d0e0c610aeccb9ff3248493b8a0ea78f801e62b2f6ac87cd219a05cff535e04586a5ce9b03aa3540278 SHA512 40f9a8a898c9fdae00fd0bdd38eb91a6fb813cf8319f888590bdfd4b5efcb614aa5322c0b9e017f49c3f5155ccf82d5cae80aad79df285c50b5ef270c09f4c9d
diff --git a/media-libs/mutagen/mutagen-1.47.0.ebuild b/media-libs/mutagen/mutagen-1.47.0.ebuild
new file mode 100644
index 000000000000..33a02e6d827a
--- /dev/null
+++ b/media-libs/mutagen/mutagen-1.47.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Audio metadata tag reader and writer implemented in pure Python"
+HOMEPAGE="
+ https://github.com/quodlibet/mutagen/
+ https://pypi.org/project/mutagen/
+"
+SRC_URI="
+ https://github.com/quodlibet/mutagen/releases/download/release-${PV}/${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ test? (
+ dev-python/eyeD3[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ media-libs/flac[ogg]
+ )
+"
+
+DOCS=( NEWS README.rst )
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme