summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMazunki Hoksaas <rolferen@gmail.com>2022-12-21 05:09:39 +0100
committerSam James <sam@gentoo.org>2022-12-21 04:56:18 +0000
commitff384958e020642fbacee5ee234b7894d5c09057 (patch)
treebec50a6a8d96615faa40610df104202487588911 /media-libs/rubberband
parentsys-fs/xfsdump: add 3.1.12 (diff)
downloadgentoo-ff384958e020642fbacee5ee234b7894d5c09057.tar.gz
gentoo-ff384958e020642fbacee5ee234b7894d5c09057.tar.bz2
gentoo-ff384958e020642fbacee5ee234b7894d5c09057.zip
media-libs/rubberband: add -latomic for clang
Closes: https://bugs.gentoo.org/860078 Signed-off-by: Mazunki Hoksaas <rolferen@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/28726 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'media-libs/rubberband')
-rw-r--r--media-libs/rubberband/rubberband-3.1.1-r1.ebuild (renamed from media-libs/rubberband/rubberband-3.1.1.ebuild)11
1 files changed, 9 insertions, 2 deletions
diff --git a/media-libs/rubberband/rubberband-3.1.1.ebuild b/media-libs/rubberband/rubberband-3.1.1-r1.ebuild
index 77bbfa735bbe..3488f7ac50cd 100644
--- a/media-libs/rubberband/rubberband-3.1.1.ebuild
+++ b/media-libs/rubberband/rubberband-3.1.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit meson-multilib flag-o-matic
+inherit meson-multilib flag-o-matic toolchain-funcs
DESCRIPTION="An audio time-stretching and pitch-shifting library and utility program"
HOMEPAGE="https://www.breakfastquay.com/rubberband/"
@@ -25,7 +25,10 @@ CDEPEND="
programs? ( media-libs/libsndfile )
vamp? ( media-libs/vamp-plugin-sdk[${MULTILIB_USEDEP}] )
"
-RDEPEND="${CDEPEND}"
+RDEPEND="
+ ${CDEPEND}
+ sys-devel/gcc:*
+"
DEPEND="${CDEPEND}"
PATCHES=(
@@ -38,6 +41,10 @@ multilib_src_configure() {
# meson doesn't respect/use LIBS but mangles LDFLAGS with libs
# correctly. Use this until we get a Meson test for libatomic.
append-ldflags -latomic
+ elif tc-is-clang && [[ $(tc-get-cxx-stdlib) == libstdc++ ]] ; then
+ # bug #860078
+ # undefined reference to `__atomic_is_lock_free'
+ append-ldflags -latomic
fi
local emesonargs=(