summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-07-10 22:58:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-07-10 23:23:44 +0200
commit0e85e56bbbf6cb26305aa96a8df7650dc85530f9 (patch)
treeb474d2290a9bf3a588b4f23f7f5f036537012766 /media-libs/vigra
parentmedia-libs/vigra: Fix build with GCC-10 (diff)
downloadgentoo-0e85e56bbbf6cb26305aa96a8df7650dc85530f9.tar.gz
gentoo-0e85e56bbbf6cb26305aa96a8df7650dc85530f9.tar.bz2
gentoo-0e85e56bbbf6cb26305aa96a8df7650dc85530f9.zip
media-libs/vigra: Switch to cmake.eclass
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-libs/vigra')
-rw-r--r--media-libs/vigra/vigra-1.11.1-r3.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/media-libs/vigra/vigra-1.11.1-r3.ebuild b/media-libs/vigra/vigra-1.11.1-r3.ebuild
index 05721485aa86..c9dfc49eed8e 100644
--- a/media-libs/vigra/vigra-1.11.1-r3.ebuild
+++ b/media-libs/vigra/vigra-1.11.1-r3.ebuild
@@ -5,7 +5,7 @@ EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
PYTHON_REQ_USE="threads(+),xml"
-inherit cmake-utils python-r1
+inherit cmake python-r1
DESCRIPTION="C++ computer vision library emphasizing customizable algorithms and structures"
HOMEPAGE="https://ukoethe.github.io/vigra/"
@@ -81,7 +81,7 @@ src_prepare() {
fi
}
- cmake-utils_src_prepare
+ cmake_src_prepare
vigra_disable fftw fftw3
vigra_disable fftw fftw3f
@@ -111,7 +111,7 @@ src_configure() {
-DWITH_VALGRIND=$(usex valgrind)
-DWITH_VIGRANUMPY=$(usex python)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
if use python; then
@@ -124,7 +124,7 @@ src_configure() {
src_compile() {
local VIGRA_BUILD_DIR
vigra_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
VIGRA_BUILD_DIR="${BUILD_DIR}"
}
if use python; then
@@ -136,17 +136,17 @@ src_compile() {
src_install() {
if use python; then
- python_foreach_impl cmake-utils_src_install
+ python_foreach_impl cmake_src_install
python_optimize
else
- cmake-utils_src_install
+ cmake_src_install
fi
}
src_test() {
# perhaps disable tests (see #390447)
vigra_test() {
- PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake-utils_src_test
+ PYTHONPATH="${BUILD_DIR}/vigranumpy/vigra" cmake_src_test
}
if use python; then
python_foreach_impl vigra_test