summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-05-05 22:38:24 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-05-05 22:38:24 +0100
commit9bf8349737ac565e18b7f3c71d27fed460d9bc6e (patch)
tree8d951a00a7c010d8220a39ca93ba3e1276a8c6da /media-libs/vkroots
parentsci-visualization/gwyddion: properly enable openexr support (diff)
downloadgentoo-9bf8349737ac565e18b7f3c71d27fed460d9bc6e.tar.gz
gentoo-9bf8349737ac565e18b7f3c71d27fed460d9bc6e.tar.bz2
gentoo-9bf8349737ac565e18b7f3c71d27fed460d9bc6e.zip
media-libs/vkroots: Don't regenerate vkroots.h with system vk.xml
At least for now. It may be necessary in future, but it breaks with vulkan-headers 1.3.243 right now. Closes: https://github.com/ValveSoftware/gamescope/issues/858 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'media-libs/vkroots')
-rw-r--r--media-libs/vkroots/vkroots-0_p20221205-r1.ebuild (renamed from media-libs/vkroots/vkroots-0_p20221205.ebuild)13
-rw-r--r--media-libs/vkroots/vkroots-0_p20230103-r1.ebuild38
-rw-r--r--media-libs/vkroots/vkroots-0_p20230103.ebuild27
3 files changed, 40 insertions, 38 deletions
diff --git a/media-libs/vkroots/vkroots-0_p20221205.ebuild b/media-libs/vkroots/vkroots-0_p20221205-r1.ebuild
index 639396330c56..d41f02b5ac64 100644
--- a/media-libs/vkroots/vkroots-0_p20221205.ebuild
+++ b/media-libs/vkroots/vkroots-0_p20221205-r1.ebuild
@@ -1,12 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit python-any-r1
-
COMMIT="e6b89494142eec0ac6061f82a947d2f1246d3d7a"
DESCRIPTION="Simple framework for writing Vulkan layers"
HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
@@ -15,17 +11,12 @@ KEYWORDS="~amd64"
LICENSE="Apache-2.0 MIT LGPL-2.1"
SLOT="0"
-BDEPEND="
- ${PYTHON_DEPS}
+RDEPEND="
dev-util/vulkan-headers
"
S="${WORKDIR}/${PN}-${COMMIT}"
-src_compile() {
- "${PYTHON}" ./gen/make_vkroots --xml "${BROOT}"/usr/share/vulkan/registry/vk.xml || die
-}
-
src_install() {
default
insinto /usr/include/${PN}
diff --git a/media-libs/vkroots/vkroots-0_p20230103-r1.ebuild b/media-libs/vkroots/vkroots-0_p20230103-r1.ebuild
new file mode 100644
index 000000000000..2e58b57ee174
--- /dev/null
+++ b/media-libs/vkroots/vkroots-0_p20230103-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Regenerating vkroots.h from the system vk.xml may seem like a good idea,
+# especially given that vkroots.h includes some Vulkan headers, but this has led
+# to issues such as https://github.com/ValveSoftware/gamescope/issues/858.
+# Leaving the code commented in case we need to revert to the earlier approach.
+
+# PYTHON_COMPAT=( python3_{10..11} )
+
+# inherit meson python-any-r1
+
+inherit meson
+
+COMMIT="26757103dde8133bab432d172b8841df6bb48155"
+DESCRIPTION="Simple framework for writing Vulkan layers"
+HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
+SRC_URI="https://github.com/Joshua-Ashton/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0 MIT LGPL-2.1"
+SLOT="0"
+
+# BDEPEND="
+# ${PYTHON_DEPS}
+# dev-util/vulkan-headers
+# "
+
+RDEPEND="
+ dev-util/vulkan-headers
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+# src_compile() {
+# "${PYTHON}" ./gen/make_vkroots --xml "${BROOT}"/usr/share/vulkan/registry/vk.xml || die
+# }
diff --git a/media-libs/vkroots/vkroots-0_p20230103.ebuild b/media-libs/vkroots/vkroots-0_p20230103.ebuild
deleted file mode 100644
index 335b8e66be27..000000000000
--- a/media-libs/vkroots/vkroots-0_p20230103.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit meson python-any-r1
-
-COMMIT="26757103dde8133bab432d172b8841df6bb48155"
-DESCRIPTION="Simple framework for writing Vulkan layers"
-HOMEPAGE="https://github.com/Joshua-Ashton/vkroots"
-SRC_URI="https://github.com/Joshua-Ashton/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64"
-LICENSE="Apache-2.0 MIT LGPL-2.1"
-SLOT="0"
-
-BDEPEND="
- ${PYTHON_DEPS}
- dev-util/vulkan-headers
-"
-
-S="${WORKDIR}/${PN}-${COMMIT}"
-
-src_compile() {
- "${PYTHON}" ./gen/make_vkroots --xml "${BROOT}"/usr/share/vulkan/registry/vk.xml || die
-}