summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2015-11-08 20:26:35 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2015-11-08 20:26:35 +0100
commit7aceded30dbaa7c3fef2061e7744dd2bd3e73c99 (patch)
tree91482bb57b966cc80de9d33c928c9af85412c7c1 /media-libs
parentdev-util/cmake: Add ~ia64 keyword wrt bug #539126 (diff)
parentmedia-plugins/gst-plugins-meta: version bump to 1.6.1 (diff)
downloadgentoo-7aceded30dbaa7c3fef2061e7744dd2bd3e73c99.tar.gz
gentoo-7aceded30dbaa7c3fef2061e7744dd2bd3e73c99.tar.bz2
gentoo-7aceded30dbaa7c3fef2061e7744dd2bd3e73c99.zip
media-libs/gstreamer: version bump to 1.6.1
Merge branch 'gstreamer-1.6'
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/gst-plugins-bad/Manifest1
-rw-r--r--media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild87
-rw-r--r--media-libs/gst-plugins-base/Manifest1
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r2.ebuild2
-rw-r--r--media-libs/gst-plugins-base/gst-plugins-base-1.6.1.ebuild87
-rw-r--r--media-libs/gst-plugins-good/Manifest1
-rw-r--r--media-libs/gst-plugins-good/gst-plugins-good-1.6.1.ebuild61
-rw-r--r--media-libs/gst-plugins-ugly/Manifest1
-rw-r--r--media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild40
-rw-r--r--media-libs/gstreamer-editing-services/Manifest1
-rw-r--r--media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild56
-rw-r--r--media-libs/gstreamer/Manifest1
-rw-r--r--media-libs/gstreamer/gstreamer-1.6.1.ebuild104
13 files changed, 442 insertions, 1 deletions
diff --git a/media-libs/gst-plugins-bad/Manifest b/media-libs/gst-plugins-bad/Manifest
index 9163b39faad3..26c972d6cbb4 100644
--- a/media-libs/gst-plugins-bad/Manifest
+++ b/media-libs/gst-plugins-bad/Manifest
@@ -3,3 +3,4 @@ DIST gst-plugins-bad-0.10.23.tar.xz 3155044 SHA256 03cf0786391c64625569072e90408
DIST gst-plugins-bad-1.2.4.tar.xz 3272824 SHA256 984c133ec9d5d705e313d9e2bbd1472b93c6567460602a9a316578925ffe2eca SHA512 4344dedb899cdc0e3bf36a3b5dd36c6091e2e2f2a7440e3831cebbd9b4463f89cc4bc2d589b0c2c806bcaeb1864a49b3c9e0e3bedc051f1f46e09a8f131f0aa9 WHIRLPOOL 98bce50e7018d7c8d442bf8c7f26f14bd719a8af5af0fde39841c4282a9e4edfeefe06ab10797826cf9b876e173dafcf2e2df86408c373e6c4d8902072cf393c
DIST gst-plugins-bad-1.4.5.tar.xz 3824936 SHA256 152fad7250683d72f9deb36c5685428338365fe4a4c87ffe15e38783b14f983c SHA512 65d6be58957b1329420611b8e6f1eb9869420745d9165047631cdf9e45083605f37dcfaf68a288fe4252f1b3543f7f70ded9c12eab2e0ac4ac9f4c4ce9eaac7a WHIRLPOOL f5ade3f101ca82b52e7145e5ac16f5c1ab5d042415ee7753586dc6ad0942467c4c5b5b4aa6b0bc44e1ebd9c40de1964df265aa41599cb692fd32aab2b6a7acf7
DIST gst-plugins-bad-1.6.0.tar.xz 4209172 SHA256 d8ff26128d4ecd2ffeb28e14843808d2d971b09056b7cee6f08afcae01fc0f49 SHA512 1b646b9dbbb18bd37a9141ba5983f3d8448d60af80144759120f580c2f65e97f78b148e7b7494c46163942274444f4191bed1be43539551c4278c9056230efe2 WHIRLPOOL 8ef0303f15153cb460009bf962e9d0c70d0f73ce4dda0f7d6579509df26104e3c16a1a6710bae16d13c4d3dd9f5d4c1846caa9164fef5fd49c21657269a6b0c9
+DIST gst-plugins-bad-1.6.1.tar.xz 4215876 SHA256 e176a9af125f6874b3d6724aa7566a198fa225d3ece0a7ac2f2b51c57e525466 SHA512 336a449a23cc11c31fc744828746946de1107e31bd60bf1ba7e3b74d906bda691e917093d04a03249aabcdfc5af0a26ea2a04e343b2b744b1d404b0a5071bdd6 WHIRLPOOL 5cfaeef59b43c9c4fb70acb01f6cd31861e95904a618b02bcfa37afc81919239e1727f9e7da2bf2ee415c0525f3b7955289adbbf9099c9696f83128f7ffdf844
diff --git a/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild b/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild
new file mode 100644
index 000000000000..547dd00abd3a
--- /dev/null
+++ b/media-libs/gst-plugins-bad/gst-plugins-bad-1.6.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-bad"
+
+inherit eutils flag-o-matic gstreamer virtualx
+
+DESCRIPTION="Less plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"
+
+IUSE="X egl gles2 +introspection opengl +orc vnc wayland"
+REQUIRED_USE="
+ egl? ( !gles2 )
+ gles2? ( !egl !opengl )
+ opengl? ( X )
+ wayland? ( egl )
+"
+
+# dtmf plugin moved from bad to good in 1.2
+# X11 is automagic for now, upstream #709530
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+
+ egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
+ gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
+ opengl? (
+ >=media-libs/mesa-9.1.6[${MULTILIB_USEDEP}]
+ virtual/glu[${MULTILIB_USEDEP}] )
+ X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
+ wayland? ( dev-libs/wayland[${MULTILIB_USEDEP}] )
+
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-good-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ # FIXME: tests are slower than upstream expects
+ sed -e 's:/\* tcase_set_timeout.*:tcase_set_timeout (tc_chain, 5 * 60);:' \
+ -i tests/check/elements/audiomixer.c || die
+}
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable egl) \
+ $(use_enable gles2) \
+ $(use_enable opengl) \
+ $(use_enable opengl glx) \
+ $(use_enable orc) \
+ $(use_enable vnc librfb) \
+ $(use_enable X x11) \
+ $(use_enable wayland) \
+ --disable-examples \
+ --disable-debug \
+ --disable-cocoa \
+ --disable-wgl
+
+ if multilib_is_native_abi; then
+ local x
+ for x in libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ unset DISPLAY
+ Xemake check
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/gst-plugins-base/Manifest b/media-libs/gst-plugins-base/Manifest
index b7dbc525abb2..9a7f0429cba0 100644
--- a/media-libs/gst-plugins-base/Manifest
+++ b/media-libs/gst-plugins-base/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-base-0.10.36.tar.xz 2364108 SHA256 1fe45c3894903001d4d008b0713d
DIST gst-plugins-base-1.2.4.tar.xz 2538012 SHA256 4d6273dc3f5a94bcc53ccfe0711cfddd49e31371d1136bf62fa1ecc604fc6550 SHA512 8e7e7fd494ee2335e917dae3fef93a2103db37c8cc645ccf1f63b7e6676a6cc6fee78bb90e43f8ccacab367788a416600577cb3d9630e9d64258ecb3dbe63338 WHIRLPOOL 173b2c71b2be05db75ef0d7c344b64ec5d74ba291cc8058546a2963257a1af8e7699737214e11c2d811e6349a008386f822a82f5fe5f5491f5faca64e9d8f20d
DIST gst-plugins-base-1.4.5.tar.xz 2637680 SHA256 77bd8199e7a312d3d71de9b7ddf761a3b78560a2c2a80829d0815ca39cbd551d SHA512 63d3c531de736ad8a64d6962c0af75857d3b016d7f8e85d1884e8de50e64576902bb1161161b74130ab5dfb1d453eb995e374d8a958eac6e44ae5272eeaaf8b6 WHIRLPOOL cf6ef1c9589ed7a39be74e7663b0821c81b1b4cffdd612ccd7fd5b7929508af21d68817530a4b0fb2517f3a7044ee068afba7602816fdd0ada31444f0bcf8383
DIST gst-plugins-base-1.6.0.tar.xz 2833380 SHA256 314fd1b707f65caf8eb6164d9422fc51e2b220a890ccd2de6ec03a2883d77231 SHA512 fea97754117f7a923e6622211a218ab1d1d4cbb30f8025777462df5c622061710236477af42df6ea6b817e155d2165af353d6f44b5609b87187ab2fb63aaf406 WHIRLPOOL 97696f2d44bbfd08ccf004493948b890fb28527a6fac2c2a04fe06e395a36a66a945e2153659e9324c5e22adf8af27c8426632379e0f734dddfc7b6661c1d3fa
+DIST gst-plugins-base-1.6.1.tar.xz 2833356 SHA256 9533dcfaa4ee32d435483d9fa88c06b1eba6e9bb234aacd7583f207199f44ba3 SHA512 2887c8acb235f46c7102a572465995bcd4a8dd48a98adccb868225eb87db19e19c36b7c65495b0e0644fdf41e53e8e421f21479b1e80b65a3433a47c7da0eb5f WHIRLPOOL 8939c489eedc2098e93d2340a6ba91d8457225e581331f44c41e27d3f6b1f6c3ffcc4cfeae4695d88314d003a928b575e220e13b227ca44ce3f34dd55abb1549
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r2.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r2.ebuild
index 5157ce8f6c22..dd66de016a70 100644
--- a/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r2.ebuild
+++ b/media-libs/gst-plugins-base/gst-plugins-base-0.10.36-r2.ebuild
@@ -11,7 +11,7 @@ DESCRIPTION="Basepack of plugins for gstreamer"
HOMEPAGE="http://gstreamer.freedesktop.org/"
LICENSE="GPL-2+ LGPL-2+"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
IUSE="+introspection nls +orc"
RDEPEND=">=media-libs/gstreamer-${PV}:0.10[introspection?,${MULTILIB_USEDEP}]
diff --git a/media-libs/gst-plugins-base/gst-plugins-base-1.6.1.ebuild b/media-libs/gst-plugins-base/gst-plugins-base-1.6.1.ebuild
new file mode 100644
index 000000000000..6f796d5e8208
--- /dev/null
+++ b/media-libs/gst-plugins-base/gst-plugins-base-1.6.1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-base"
+
+inherit gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2+ LGPL-2+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="alsa +introspection ivorbis +ogg +orc +pango theora +vorbis X"
+REQUIRED_USE="
+ ivorbis? ( ogg )
+ theora? ( ogg )
+ vorbis? ( ogg )
+"
+
+RDEPEND="
+ app-text/iso-codes
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:1.0[introspection?,${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ alsa? ( >=media-libs/alsa-lib-1.0.27.2[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+ ivorbis? ( >=media-libs/tremor-0_pre20130223[${MULTILIB_USEDEP}] )
+ ogg? ( >=media-libs/libogg-1.3.0[${MULTILIB_USEDEP}] )
+ orc? ( >=dev-lang/orc-0.4.23[${MULTILIB_USEDEP}] )
+ pango? ( >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}] )
+ theora? ( >=media-libs/libtheora-1.1.1[encode,${MULTILIB_USEDEP}] )
+ vorbis? ( >=media-libs/libvorbis-1.3.3-r1[${MULTILIB_USEDEP}] )
+ X? (
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXv-1.0.10[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ X? (
+ >=x11-proto/videoproto-2.3.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.2.1-r1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}] )
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure \
+ $(use_enable alsa) \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable ivorbis) \
+ $(use_enable ogg) \
+ $(use_enable orc) \
+ $(use_enable pango) \
+ $(use_enable theora) \
+ $(use_enable vorbis) \
+ $(use_enable X x) \
+ $(use_enable X xshm) \
+ $(use_enable X xvideo) \
+ --disable-debug \
+ --disable-examples \
+ --disable-freetypetest \
+ --disable-static
+ # cdparanoia and libvisual are split out, per leio's request
+
+ # bug #366931, flag-o-matic for the whole thing is overkill
+ if [[ ${CHOST} == *86-*-darwin* ]] ; then
+ sed -i \
+ -e '/FLAGS = /s|-O[23]|-O1|g' \
+ gst/audioconvert/Makefile \
+ gst/volume/Makefile || die
+ fi
+
+ if multilib_is_native_abi; then
+ local x
+ for x in libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/gst-plugins-good/Manifest b/media-libs/gst-plugins-good/Manifest
index 7861d05551db..b1ad1c9cdc44 100644
--- a/media-libs/gst-plugins-good/Manifest
+++ b/media-libs/gst-plugins-good/Manifest
@@ -3,3 +3,4 @@ DIST gst-plugins-good-1.2.3.tar.xz 2878780 SHA256 bfb33536a515bdcc34482f64b8d9cc
DIST gst-plugins-good-1.2.4.tar.xz 2882188 SHA256 c9c90368393c2e5e78387e95c02ce7b19f48e793bba6d8547f2c4b51c6f420d3 SHA512 2c057062e10b5ff4cc63d54ffd2a8fb013f264584a175fdadc2fa0b02a7bc390bde0747e7888c6bed45713ce62cd0b6da7d255c99ce5171e9e5c41d6aac90086 WHIRLPOOL 43b4fefa94cfe85e3082fcaaa70fc159381a3d43c43bc15e8bc92b9fe0412bfdba56107c1b2334c632fecdf9b78c8334d962a49efb29a4e82a487a9121bbea33
DIST gst-plugins-good-1.4.5.tar.xz 3031588 SHA256 79b1b5f3f7bcaa8a615202eb5e176121eeb8336960f70687e536ad78dbc7e641 SHA512 0cf880af21956138e127508f6020fdc10f6ed01b765b0d3364d038c8e104947486c83c157c7b957193b82d59f724e342a6d12900b6a97abe6e2f3dac65d71be0 WHIRLPOOL a56ca2c2f2b73f299cb3c3605eb70ddbd97d9513d26ee11d91608c08589149df97f23490a6513d991c6b552a7b8a71f75463fd6dbf7579943ac859254eb0af3c
DIST gst-plugins-good-1.6.0.tar.xz 3176568 SHA256 a0915639595305e48884656e22b16fda7c6892aa02cdb3eb43e23dab6e6b81fa SHA512 100b1f47d1c575e1f21fa4796153464cb65b75dd930be707a75c602dd90745a7b0742f64bba2f8210a7f3561774e4f9f81ce04f42a31e0e1def18292ca9d6706 WHIRLPOOL b1ce02c26b80dee2835fa06ac4ce1c506055a149906931eba8a228017217fef3f450c6a59aa05e9c1dc3287382ac4a67118921ed0f08e31da1d565b86fe0f7c9
+DIST gst-plugins-good-1.6.1.tar.xz 3188188 SHA256 86d4b814099f7b7b16be19d4b94fa41002ac01fdf1525b07c5764d54c0605935 SHA512 6b326d908a6df3af059ee23ff41b10a07ad21a1c88f542eff5223a6e8acc75ae97ddead6adcf455cafc9e93f27f7829f6b7476d1a5d3f1ff123f477f00b4f41f WHIRLPOOL 78bf3a445ec03fde8f6bd8d0c3f774d4b41deedff1d4d45b650d45f25c648ad17d3ab9256a049416594e0d5f2b1e0904e7118af6d1805fb2072d1b461cac0ced
diff --git a/media-libs/gst-plugins-good/gst-plugins-good-1.6.1.ebuild b/media-libs/gst-plugins-good/gst-plugins-good-1.6.1.ebuild
new file mode 100644
index 000000000000..019abe41499f
--- /dev/null
+++ b/media-libs/gst-plugins-good/gst-plugins-good-1.6.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-good"
+
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for GStreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="LGPL-2.1+"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+# dtmf plugin moved from bad to good in 1.2
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}]
+ >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+
+ !<media-libs/gst-plugins-bad-1.1:${SLOT}
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+src_prepare() {
+ # Disable test due to missing files
+ # https://bugzilla.gnome.org/show_bug.cgi?id=757087
+ sed -e 's:\(tcase_add_test.*test_splitmuxsrc\):// \1:' \
+ -i tests/check/elements/splitmux.c || die
+}
+
+multilib_src_configure() {
+ # Always enable optional bz2 support for matroska
+ # Always enable optional zlib support for qtdemux and matroska
+ # Many media files require these to work, as some container headers are often
+ # compressed, bug #291154
+ gstreamer_multilib_src_configure \
+ --enable-bz2 \
+ --enable-zlib \
+ --disable-examples \
+ --with-default-audiosink=autoaudiosink \
+ --with-default-visualizer=goom
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/gst-plugins-ugly/Manifest b/media-libs/gst-plugins-ugly/Manifest
index ba8aa210d826..fe6a50e8439d 100644
--- a/media-libs/gst-plugins-ugly/Manifest
+++ b/media-libs/gst-plugins-ugly/Manifest
@@ -2,3 +2,4 @@ DIST gst-plugins-ugly-0.10.19.tar.xz 882452 SHA256 4934f65ff892637e7efaf1cfe6357
DIST gst-plugins-ugly-1.2.4.tar.xz 844968 SHA256 4ef6f76a47d57b8385d457c7b620b4c28fc041ab1d7c2e3e2f5f05b12b988ea8 SHA512 91a9d950e73a8d6c8bb4c559ba8f4a4dffc163be714d93c0d0d6421f2c9932a4b1af665f76417e79b50b31c83d8a766df9cf6c337b8371371708efc8683e24e1 WHIRLPOOL c1c3885cf2e041c4427f30ca13cda2948b8a35273d3e6417bfe83566f03230208ce1e019e655ae2c98725e94cce6c7fb37b450307312f682bdbd7c948190e7c0
DIST gst-plugins-ugly-1.4.5.tar.xz 846828 SHA256 5cd5e81cf618944f4dc935f1669b2125e8bb2fe9cc7dc8dc15b72237aca49067 SHA512 9353a5b9492758d8255fcab23c0eb170ec31e884774c22915b57cc4a2ed56bad61643d7bd44fcdb919e7ad9b2023d1d0fab23f9c9fda1cb2b9883c92ec6b6fc0 WHIRLPOOL b212a4dcba654dac7866ad75551b26818349780b0d7905e63c45b75e21ffbb86ae0f4e9e79ef8bfb317149c2d4f01cbda2c6e2cf2cbcf58991bc09ba9aa85f4e
DIST gst-plugins-ugly-1.6.0.tar.xz 859996 SHA256 91178dc0d687a83c083190a905681d3a66901374b1004fc52cd300b7802e5f06 SHA512 72fadf593d3307b04757763ea7cec00c8c4f1d1aa7ab68a0876e7888f63b995b81b2d5efe6ac45a4dd068c0cfa9ea23b7a6b4435666bcd36b42e174b068874f0 WHIRLPOOL 3ad574a2d74591de9ecb0167bdea29478f48b7fe2cf4a1fec83ece5d0189d66826f1793e84215d7f412245b5b290310c500fea6a67cfcde94358da3884edeb57
+DIST gst-plugins-ugly-1.6.1.tar.xz 859200 SHA256 0cc3f90e4322efe1f774272e8fe5c185be37cf7999cd5ca7e0e0607e03d56a57 SHA512 f62eb68779b6bbcc555f43c7c9f4a034f0fabe9244161d9c5ffd410c64a56c915637f5d4ec974810acd67fc744b9a143ba46b6ace96daa2ab56703b1e954c2a0 WHIRLPOOL 8bf8d4295054b8346c08794bddf081da668cd6d9e0e3320381fd2f3a52eb8ffbfa12e0a847137a7cde94de51ebf3bcecee17a098581d63ce444d52a42af76264
diff --git a/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild
new file mode 100644
index 000000000000..fa707c40f566
--- /dev/null
+++ b/media-libs/gst-plugins-ugly/gst-plugins-ugly-1.6.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GST_ORG_MODULE="gst-plugins-ugly"
+
+inherit eutils flag-o-matic gstreamer
+
+DESCRIPTION="Basepack of plugins for gstreamer"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="+orc"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ >=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP}]
+ orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+"
+
+multilib_src_configure() {
+ gstreamer_multilib_src_configure
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/docs/plugins/html docs/plugins/html || die
+ fi
+
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+}
diff --git a/media-libs/gstreamer-editing-services/Manifest b/media-libs/gstreamer-editing-services/Manifest
index 4833b010d5bc..62a6cc17dfae 100644
--- a/media-libs/gstreamer-editing-services/Manifest
+++ b/media-libs/gstreamer-editing-services/Manifest
@@ -1,3 +1,4 @@
DIST gstreamer-editing-services-1.2.1.tar.xz 900316 SHA256 fe768b21af5c644093a06a0e573b6e2fa9b467bec18de408c7ff7171c4fb40b0 SHA512 245d3f8934e36f5c58112a820375c90f775af928f5a32e5f6c5793a6ad0709b1d29f4e60e572778d1b3fca308d5eb7c55f89a04b38de67a0ba254f85d43d42fa WHIRLPOOL d354c6cfb1c8226b6a5f3b7d175187dfa1a099dbe5d292f1d6b691e51638f72534ac1b412e7851b5c05073e731ecefd0dfbc7ee1106459906498d8d6b61b7080
DIST gstreamer-editing-services-1.4.0.tar.xz 915420 SHA256 cc20b90fb7bcec257b2afda7474664d493b1acece66da675d7df584588808bb3 SHA512 4a3e39089810aa15f2e2e802b1f2a0fcf6f3508a86a5aa8323078334a3f3b427a53e0d3bbb62d42140dc43cbcd9d4985faf0b28edefbcb9814fa76cbb638119b WHIRLPOOL 913149756f5a3dc19e2549014b66484e6390c33d7bfd204899d5d3e9d1f86fe73570ed04548d8ad6700cf9b917344917ae647b0b1d8fb06655dc446e42653e56
DIST gstreamer-editing-services-1.6.0.tar.xz 1013632 SHA256 4a780cc27029d25271cf4f8bc17531aa9a1d435e4f807202fd3790f53b964dbe SHA512 25435a9db98ed9d973a2414047f466b0fb865b869b29a7792c690e11e872933018d7fe8f998a4ddd1b452b21aa4021187f76ab8124366cde9a016292ad27646e WHIRLPOOL 67c88e89e9dd8aa26eac649bb8b4ea09048bcd538149b0c1380220094fe39e2be5966c19c69329a7582f2409aa66272f0ee2c0724d5fc5a468a4f2bcfb4319fd
+DIST gstreamer-editing-services-1.6.1.tar.xz 1004808 SHA256 f5f7e97db04faeaf6ec941652e75221e244b88e570720e031965d81b759e7bd2 SHA512 d40494a76b411303679b68d69946ff10710f3328b3165175db494b905082598a2df75d89dc3ca21da5cf228c8b53efe9fc498012da937b84710a5177782b0342 WHIRLPOOL 3ccc0aa4c1b4a07baefde351f10f1422148ea4b1029561269e432890793c57e3fcf9b572d07f8b8df5ad77ca93a7f405a1ab4ade883d27009e043ad2cfdcb0f8
diff --git a/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild
new file mode 100644
index 000000000000..3ffda41adfa6
--- /dev/null
+++ b/media-libs/gstreamer-editing-services/gstreamer-editing-services-1.6.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit bash-completion-r1 gnome2
+
+DESCRIPTION="SDK for making video editors and more"
+HOMEPAGE="http://wiki.pitivi.org/wiki/GES"
+SRC_URI="http://gstreamer.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+# FIXME: There is something odd with pygobject check for >=4.22,
+# check with upstream
+COMMON_DEPEND="
+ >=dev-libs/glib-2.34:2
+ dev-libs/libxml2:2
+ >=media-libs/gstreamer-${PV}:1.0[introspection?]
+ >=media-libs/gst-plugins-base-${PV}:1.0[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+"
+RDEPEND="${COMMON_DEPEND}
+ media-libs/gnonlin:1.0
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/gtk-doc-am-1.3
+ virtual/pkgconfig
+"
+# XXX: tests do pass but need g-e-s to be installed due to missing
+# AM_TEST_ENVIRONMENT setup.
+RESTRICT="test"
+
+src_configure() {
+ # gtk is only used for examples
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ --disable-examples \
+ --without-gtk \
+ --with-bash-completion-dir="$(get_bashcompdir)" \
+ --with-package-name="GStreamer editing services ebuild for Gentoo" \
+ --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer-editing-services"
+}
+
+src_compile() {
+ # Prevent sandbox violations, bug #538888
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744135
+ # https://bugzilla.gnome.org/show_bug.cgi?id=744134
+ addpredict /dev
+ gnome2_src_compile
+}
diff --git a/media-libs/gstreamer/Manifest b/media-libs/gstreamer/Manifest
index 32f6114413c7..904c607738fc 100644
--- a/media-libs/gstreamer/Manifest
+++ b/media-libs/gstreamer/Manifest
@@ -2,3 +2,4 @@ DIST gstreamer-0.10.36.tar.xz 3025876 SHA256 9151aa108c177054387885763fa0e433e76
DIST gstreamer-1.2.4.tar.xz 3225208 SHA256 1e7ca67a7870a82c9ed51d51d0008cdbc550c41d64cc3ff3f9a1c2fc311b4929 SHA512 e1feaae567e5dba23270b87bc031b9ba061f664b83a3f18064b8abf802ce3ae6855c97df7a9cb8d861c3c6668e671144da859ae9cda663e88720602198f6f8fc WHIRLPOOL 8c8325ee24d2fe6bb218e6d2cc8e3a2870ac47fb2134914205490decf6593c54ca59f92c95a3da0c7f4eb656191ae9b70a40ae02df87ba64a9c39e9e82fd36c0
DIST gstreamer-1.4.5.tar.xz 3324052 SHA256 40801aa7f979024526258a0e94707ba42b8ab6f7d2206e56adbc4433155cb0ae SHA512 ed7b371f99b7da4ec462e34cd8e02062a0faaad7498a87cfc1ef39f8740db9bca0cc5bfe17ae5ff24abe0bd4a6771e732da193c01ca0e2d835b6c5d9f0d41403 WHIRLPOOL 3065b43a84d8d1d09ec9fb9bda5afc91550cd9f55e2db486c6aceec8fa41dd5ae7d3809c6b6249e86e658c94ffed6ec5a4a7a3cd25b2ab17c24c5a3488355bee
DIST gstreamer-1.6.0.tar.xz 3549712 SHA256 52ef885647afef11c8b7645a9afefe04aa09e8971c4b932e7717872ab8a30fcc SHA512 8e8b5b0ef4e2c74c1f518c11de19c66cd28faac8036321a5de364b774c7d519b6772c41896d61a67a1df76b256183b42b8496175ae03105bd7f506aa748efe5f WHIRLPOOL 2f8b3c4e6ec81d86bba2dd65db87a11ecd0393da78c863f42fed5282f69fa17fef61a0a913c1d125103f02475d428f918a71ac8f3b0ae5bcf41d1b56d50310bf
+DIST gstreamer-1.6.1.tar.xz 3552476 SHA256 973a3f213c8d41d6dd0e4e7e38fd6cccacd5ae1ac09e1179a8d5d869ef0a5c9c SHA512 30b776a7ed9e9129e98e937da3c662eab5735e13caf9bb44a290b164d462bd6ba6101650971047e8ba595cc11c99507517df3593456507b37c6c9038fbd6fd1e WHIRLPOOL cadc669d22ae3aea5a590ba057f26b5e304c9f52b9d612bce1b6081bdb98cfaba83bdd48d2893a3d37caa152f2c79d1edff6f70ae6026def8ec2d6dfde2d6d3e
diff --git a/media-libs/gstreamer/gstreamer-1.6.1.ebuild b/media-libs/gstreamer/gstreamer-1.6.1.ebuild
new file mode 100644
index 000000000000..3b7dce9213c5
--- /dev/null
+++ b/media-libs/gstreamer/gstreamer-1.6.1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit bash-completion-r1 eutils multilib multilib-minimal pax-utils
+
+DESCRIPTION="Open source multimedia framework"
+HOMEPAGE="http://gstreamer.freedesktop.org/"
+SRC_URI="http://${PN}.freedesktop.org/src/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="1.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="+caps +introspection nls +orc test"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ caps? ( sys-libs/libcap )
+ introspection? ( >=dev-libs/gobject-introspection-1.31.1 )
+"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/gtk-doc-am-1.12
+ sys-devel/bison
+ sys-devel/flex
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]
+ nls? ( sys-devel/gettext )
+"
+# gtk-doc-am to install API docs
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]] ; then
+ export ac_cv_lib_dl_dladdr=no
+ export ac_cv_func_poll=no
+ fi
+ if [[ ${CHOST} == powerpc-apple-darwin* ]] ; then
+ # GCC groks this, but then refers to an implementation (___multi3,
+ # ___udivti3) that don't exist (at least I can't find it), so force
+ # this one to be off, such that we use 2x64bit emulation code.
+ export gst_cv_uint128_t=no
+ fi
+
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # Set 'libexecdir' to ABI-specific location for the library spawns
+ # helpers from there.
+ # Disable static archives, dependency tracking and examples
+ # to speed up build time
+ # Disable debug, as it only affects -g passing (debugging symbols), this must done through make.conf in gentoo
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ --disable-debug
+ --disable-examples
+ --disable-static
+ --disable-valgrind
+ --enable-check
+ $(multilib_native_use_enable introspection)
+ $(use_enable nls)
+ $(use_enable test tests)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ --with-package-name="GStreamer ebuild for Gentoo"
+ --with-package-origin="https://packages.gentoo.org/package/media-libs/gstreamer"
+ )
+
+ if use caps ; then
+ myconf+=( --with-ptp-helper-permissions=capabilities )
+ else
+ myconf+=(
+ --with-ptp-helper-permissions=setuid-root
+ --with-ptp-helper-setuid-user=nobody
+ --with-ptp-helper-setuid-group=nobody
+ )
+ fi
+
+ ECONF_SOURCE="${S}" econf ${myconf[$@]}
+
+ if multilib_is_native_abi; then
+ local x
+ for x in gst libs plugins; do
+ ln -s "${S}"/docs/${x}/html docs/${x}/html || die
+ done
+ fi
+}
+
+multilib_src_install() {
+ # can't do "default", we want to install docs in multilib_src_install_all
+ emake DESTDIR="${D}" install
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/$(get_libdir)/gstreamer-${SLOT}/gst-plugin-scanner"
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS MAINTAINERS README RELEASE"
+ einstalldocs
+ prune_libtool_files --modules
+
+ # Needed for orc-using gst plugins on hardened/PaX systems, bug #421579
+ use orc && pax-mark -m "${ED}usr/bin/gst-launch-${SLOT}"
+}