summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-23 13:00:25 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-23 13:10:56 +0200
commit5c6115b56d06554cd991e71c081c656091825604 (patch)
treeb179600cc3b2187092ba97984b469035bddfdd2d /media-sound/amsynth
parentmedia-sound/yoshimi: Bump to 1.5.1.1 (diff)
downloadgentoo-5c6115b56d06554cd991e71c081c656091825604.tar.gz
gentoo-5c6115b56d06554cd991e71c081c656091825604.tar.bz2
gentoo-5c6115b56d06554cd991e71c081c656091825604.zip
media-sound/amsynth: bump to 1.7.1
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'media-sound/amsynth')
-rw-r--r--media-sound/amsynth/Manifest1
-rw-r--r--media-sound/amsynth/amsynth-1.7.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/media-sound/amsynth/Manifest b/media-sound/amsynth/Manifest
index 4c126c18ee83..f7145c978fe1 100644
--- a/media-sound/amsynth/Manifest
+++ b/media-sound/amsynth/Manifest
@@ -2,3 +2,4 @@ DIST amSynth-1.3.2.tar.gz 635901 SHA256 3ad50c20d690865ea0fdef6745cd04a9f758e9ae
DIST amsynth-1.5.1.tar.gz 1297131 SHA256 38e0764ae02ec38e689204581810adabedd9b4e0d306414c455f51c1dbf0bea4 SHA512 5f1551f9d1398a97738ac6f764f169d8cdd55e94464438adb226d1284fe8845e190fe5dd7a740b33972c1bbe76aa2d60467b7a663ec6717bb9fac75e5aac62d1 WHIRLPOOL 615ae1a55db42a0d6cb628ab84d9167894cb974594c45bf74aae6ad1e74b09f0303844fe54457b805ce4fd50af8ae99d9064531162106ef83c5c8103c24c8a73
DIST amsynth-1.6.4.tar.gz 1380770 SHA256 489f57d506ea3495412bdd759be290930ff5da9d5b6b39ad8c82e19b4fd219ed SHA512 63ecc54ff0b26d61aa11a6cd1f6854c6b1f87b723808293a09f1b86831c574c8f709dd7987571914d285c52d94fa794f858c299927918ffa1ddad743bc180abb WHIRLPOOL f5b92d69543c479def140703df11efc27407f4869d0eea5b28ee1e8914c241184e6eccb726cb2d628b629c00c01c944425ea1d82522744ef7d5cbb5c49952634
DIST amsynth-1.7.0.tar.gz 1399493 SHA256 176bfc8bc7eee60e6826572c8f9e9ce555c11687b063c5fb904836c44b4616b5 SHA512 4b9a56c7800a484b738985cf52f6956e8829c11b4fb10f72c1e3ede0aeb3fdcb424e72ac43995ea3dc988f9cb838a0f284719d274010dc52a115faa8a3beb8d9 WHIRLPOOL 7d631b697dfed88b5a8a4c28bb0b4158384676b472936b0dc735f484096d2a6b14fb555c0af83f74b3120f9a6baac0c4073bf22f194439beb903261d88d70bfa
+DIST amsynth-1.7.1.tar.gz 1409439 SHA256 cb2be6cfbf0c01cdacb3e7e0f717f70d093026811e5aefaa12337deaf62c0486 SHA512 ad5eff805f3ad30a7cc9f3933bbe82b99c670c669c0c405d5045a410afc75cdc0d692856e73ccf870d3ca66e0997a81a5c35baf57b33bb6012f19056cff725c9 WHIRLPOOL 583b426612e0b20515eaa8bd85847eac211f8cd463aa283499c3d585a7d45a7419c092acb0bdc92562997f57e01051fd783ed04321f97afaea4ebaec3dc74de8
diff --git a/media-sound/amsynth/amsynth-1.7.1.ebuild b/media-sound/amsynth/amsynth-1.7.1.ebuild
new file mode 100644
index 000000000000..61adafdc3c58
--- /dev/null
+++ b/media-sound/amsynth/amsynth-1.7.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Virtual analogue synthesizer"
+HOMEPAGE="https://github.com/nixxcode/amsynth/"
+SRC_URI="https://github.com/nixxcode/${PN}/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="alsa dssi jack lash oss sndfile"
+
+RDEPEND="dev-cpp/gtkmm:2.4
+ sndfile? ( >=media-libs/libsndfile-1:= )
+ alsa? (
+ media-libs/alsa-lib:=
+ media-sound/alsa-utils
+ )
+ dssi? (
+ media-libs/dssi:=
+ media-libs/liblo:=
+ >=x11-libs/gtk+-2.20:2
+ )
+ jack? ( media-sound/jack-audio-connection-kit )
+ lash? ( media-sound/lash )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ oss? ( virtual/os-headers )"
+
+S="${WORKDIR}/${PN}-release-${PV}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cxxflags -std=c++11
+ econf \
+ $(use_with oss) \
+ $(use_with alsa) \
+ $(use_with jack) \
+ $(use_with lash) \
+ $(use_with sndfile) \
+ $(use_with dssi)
+}