summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-30 19:15:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-12-31 15:34:21 +0100
commit8f8c6827621d0aa475f92a2c19b9f530db3db114 (patch)
treecbda2aced505450fa95656af2fe1d3b265688de0 /media-sound/csound
parent*/*: Switch sound proj packages to cmake.eclass (diff)
downloadgentoo-8f8c6827621d0aa475f92a2c19b9f530db3db114.tar.gz
gentoo-8f8c6827621d0aa475f92a2c19b9f530db3db114.tar.bz2
gentoo-8f8c6827621d0aa475f92a2c19b9f530db3db114.zip
*/*: Switch proaudio proj packages to cmake.eclass
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/csound')
-rw-r--r--media-sound/csound/csound-6.13.0.ebuild9
-rw-r--r--media-sound/csound/csound-9999.ebuild9
2 files changed, 8 insertions, 10 deletions
diff --git a/media-sound/csound/csound-6.13.0.ebuild b/media-sound/csound/csound-6.13.0.ebuild
index bee79ef48771..e7d1d96b3f99 100644
--- a/media-sound/csound/csound-6.13.0.ebuild
+++ b/media-sound/csound/csound-6.13.0.ebuild
@@ -8,7 +8,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils python-single-r1 toolchain-funcs
+inherit cmake python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -113,7 +113,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
@@ -153,7 +153,6 @@ src_configure() {
-DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
-DBUILD_SELECT_OPCODE=ON
-DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
-DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs)
-DBUILD_STATIC_LIBRARY=$(usex test)
@@ -225,11 +224,11 @@ src_configure() {
-DUSE_LIB64=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc -r Release_Notes/.
# generate env.d file
diff --git a/media-sound/csound/csound-9999.ebuild b/media-sound/csound/csound-9999.ebuild
index d6e3677445f6..f29357886e45 100644
--- a/media-sound/csound/csound-9999.ebuild
+++ b/media-sound/csound/csound-9999.ebuild
@@ -8,7 +8,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit cmake-utils python-single-r1 toolchain-funcs
+inherit cmake python-single-r1 toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/csound/csound.git"
@@ -113,7 +113,7 @@ pkg_setup() {
}
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
sed -e '/set(PLUGIN_INSTALL_DIR/s/-${APIVERSION}//' \
-e '/-O3/d' \
@@ -154,7 +154,6 @@ src_configure() {
-DBUILD_SCANSYN_OPCODES=OFF # this is not allowed to be redistributed: https://github.com/csound/csound/issues/1148
-DBUILD_SELECT_OPCODE=ON
-DBUILD_SERIAL_OPCODES=ON
- -DBUILD_SHARED_LIBS=ON
-DBUILD_STACK_OPCODES=ON
-DBUILD_STATIC_LIBRARY=$(usex static-libs)
-DBUILD_STATIC_LIBRARY=$(usex test)
@@ -226,11 +225,11 @@ src_configure() {
-DUSE_LIB64=ON
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc -r Release_Notes/.
# generate env.d file