summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/freewheeling
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/freewheeling')
-rw-r--r--media-sound/freewheeling/Manifest1
-rw-r--r--media-sound/freewheeling/freewheeling-0.6.ebuild59
-rw-r--r--media-sound/freewheeling/metadata.xml11
3 files changed, 71 insertions, 0 deletions
diff --git a/media-sound/freewheeling/Manifest b/media-sound/freewheeling/Manifest
new file mode 100644
index 000000000000..3bb3e764e76f
--- /dev/null
+++ b/media-sound/freewheeling/Manifest
@@ -0,0 +1 @@
+DIST fweelin-0.6-src.tar.bz2 474220 SHA256 6aead7b32866d174c5b49a2215a5f864f3e1d9042623670fae2b6ec9dfbcc6ab SHA512 2bcb4d75a772305d8993af550838082275d07735bbc9f7a8228ec51134525c1290af7c573e78f3bf3d6d992e619bbb1934298a820bd1fc5318385037260d477a WHIRLPOOL 54a77bff8de4269b6953e277adb8e6ee9cc621059ed9fdb06ba7c4d4f0186f9669e2d1a1b45fe4ccc5fc83e790f6297c899614ed0fb26b290b043d72544cec91
diff --git a/media-sound/freewheeling/freewheeling-0.6.ebuild b/media-sound/freewheeling/freewheeling-0.6.ebuild
new file mode 100644
index 000000000000..5287b1cce2f3
--- /dev/null
+++ b/media-sound/freewheeling/freewheeling-0.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools multilib
+
+MY_P=fweelin-${PV/_}
+
+DESCRIPTION="A live looping instrument using SDL and jack"
+HOMEPAGE="http://freewheeling.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="fluidsynth"
+
+RDEPEND="dev-libs/libxml2
+ media-libs/alsa-lib
+ media-libs/freetype:2
+ media-libs/libvorbis
+ media-libs/libsdl[sound,video,joystick]
+ media-libs/libsndfile
+ media-libs/sdl-gfx
+ media-libs/sdl-ttf
+ media-sound/jack-audio-connection-kit
+ net-libs/gnutls
+ x11-libs/libX11
+ fluidsynth? ( media-sound/fluidsynth )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e 's:-L/usr/X11R6/lib::' configure.ac || die
+
+ sed -i \
+ -e '/CFLAGS/s:-g::' \
+ -e '/CFLAGS/s:-funroll-loops.*::' \
+ -e "s:local/lib/jack:$(get_libdir)/jack:" \
+ src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable fluidsynth) \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TUNING
+
+ docinto examples
+ dodoc examples/*
+}
diff --git a/media-sound/freewheeling/metadata.xml b/media-sound/freewheeling/metadata.xml
new file mode 100644
index 000000000000..d0cb3eb7115f
--- /dev/null
+++ b/media-sound/freewheeling/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+ <use>
+ <flag name="fluidsynth">compile with support for fluidsynth</flag>
+ </use>
+ <upstream>
+ <remote-id type="sourceforge">freewheeling</remote-id>
+ </upstream>
+</pkgmetadata>