summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Tsoy <alexander@tsoy.me>2019-06-06 19:25:25 +0300
committerMichał Górny <mgorny@gentoo.org>2019-07-07 13:49:09 +0200
commit47b7b000c375d7be5c730486c40adf237d118095 (patch)
treee2687d71cba338bde8ef7039d4a6152c0ffc515c /media-sound/guitarix
parentmedia-sound/guitarix: use slot operator for zita-convolver dep (diff)
downloadgentoo-47b7b000c375d7be5c730486c40adf237d118095.tar.gz
gentoo-47b7b000c375d7be5c730486c40adf237d118095.tar.bz2
gentoo-47b7b000c375d7be5c730486c40adf237d118095.zip
media-sound/guitarix: use array to pass configure args
Package-Manager: Portage-2.3.66, Repoman-2.3.11 Signed-off-by: Alexander Tsoy <alexander@tsoy.me> Closes: https://github.com/gentoo/gentoo/pull/12212 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'media-sound/guitarix')
-rw-r--r--media-sound/guitarix/guitarix-0.38.1-r1.ebuild32
1 files changed, 17 insertions, 15 deletions
diff --git a/media-sound/guitarix/guitarix-0.38.1-r1.ebuild b/media-sound/guitarix/guitarix-0.38.1-r1.ebuild
index f087100afca3..ce38767c1e0c 100644
--- a/media-sound/guitarix/guitarix-0.38.1-r1.ebuild
+++ b/media-sound/guitarix/guitarix-0.38.1-r1.ebuild
@@ -54,20 +54,22 @@ DEPEND="${COMMON_DEPEND}
DOCS=( changelog README )
src_configure() {
- waf-utils_src_configure \
- --cxxflags-debug="" \
- --cxxflags-release="-DNDEBUG" \
- --ldflags="${LDFLAGS}" \
- --enable-lfs \
- --lib-dev \
- --no-desktop-update \
- --no-faust \
- --no-ldconfig \
- --shared-lib \
- $(use_enable nls) \
- $(usex bluetooth "" "--no-bluez") \
- $(usex debug "--debug" "") \
- $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui") \
- $(usex standalone "" "--no-standalone") \
+ local myconf=(
+ --cxxflags-debug=""
+ --cxxflags-release="-DNDEBUG"
+ --ldflags="${LDFLAGS}"
+ --enable-lfs
+ --lib-dev
+ --no-desktop-update
+ --no-faust
+ --no-ldconfig
+ --shared-lib
+ $(use_enable nls)
+ $(usex bluetooth "" "--no-bluez")
+ $(usex debug "--debug" "")
+ $(usex lv2 "--lv2dir=${EPREFIX}/usr/$(get_libdir)/lv2" "--no-lv2 --no-lv2-gui")
+ $(usex standalone "" "--no-standalone")
$(usex zeroconf "" "--no-avahi")
+ )
+ waf-utils_src_configure "${myconf[@]}"
}