summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-09-22 00:33:46 +0300
committerAndreas Sturmlechner <asturm@gentoo.org>2025-01-06 23:55:05 +0100
commit42d6480e0b07e802e8dcaaf1b4984399d037505a (patch)
treec1760353f808d76b501fb80bce6f34b712ad5c01 /media-sound/qmmp
parentnet-misc/seafile: drop 8.0.9-r2 (diff)
downloadgentoo-42d6480e0b07e802e8dcaaf1b4984399d037505a.tar.gz
gentoo-42d6480e0b07e802e8dcaaf1b4984399d037505a.tar.bz2
gentoo-42d6480e0b07e802e8dcaaf1b4984399d037505a.zip
media-sound/qmmp: rename USE 'xmp'->'libxmp'; update metadata
Bug: https://bugs.gentoo.org/933689 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'media-sound/qmmp')
-rw-r--r--media-sound/qmmp/metadata.xml3
-rw-r--r--media-sound/qmmp/qmmp-9999.ebuild14
2 files changed, 9 insertions, 8 deletions
diff --git a/media-sound/qmmp/metadata.xml b/media-sound/qmmp/metadata.xml
index 6f150fbd17d6..0694b3588d37 100644
--- a/media-sound/qmmp/metadata.xml
+++ b/media-sound/qmmp/metadata.xml
@@ -15,7 +15,8 @@
<flag name="dbus">Enable DBus notifiications and MPRIS support</flag>
<flag name="enca">Detects the character encoding automatically</flag>
<flag name="game">Enable Game music support</flag>
- <flag name="gnome">Enable Gnome hotkey support (requires Qt5DBus)</flag>
+ <flag name="gnome">Enable Gnome hotkey support (requires QtDBus)</flag>
+ <flag name="libxmp">Enable module files renderer (modplug replacement)</flag>
<flag name="lyrics">Fetch track lyrics from the web</flag>
<flag name="midi">Enable midi support using wildmidi library</flag>
<flag name="notifier">Enable qmmps' notifier system</flag>
diff --git a/media-sound/qmmp/qmmp-9999.ebuild b/media-sound/qmmp/qmmp-9999.ebuild
index 98bde86c0905..a8f1b4fc79ad 100644
--- a/media-sound/qmmp/qmmp-9999.ebuild
+++ b/media-sound/qmmp/qmmp-9999.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit cmake xdg
-DESCRIPTION="Qt5-based audio player with winamp/xmms skins support"
+DESCRIPTION="Qt-based audio player with winamp/xmms skins support"
HOMEPAGE="https://qmmp.ylsoftware.com"
if [[ ${PV} != *9999* ]]; then
- SRC_URI="https://qmmp.ylsoftware.com/files/${P}.tar.bz2
+ SRC_URI="https://qmmp.ylsoftware.com/files/${PN}/$(ver_cut 1-2)/${P}.tar.bz2
https://downloads.sourceforge.net/${PN}-dev/files/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
else
@@ -21,9 +21,9 @@ LICENSE="GPL-2"
SLOT="0"
# KEYWORDS further up
IUSE="aac +alsa analyzer archive bs2b cdda cover crossfade cue curl +dbus enca
-ffmpeg flac game gnome jack ladspa lyrics +mad midi mms mplayer musepack
+ffmpeg flac game gnome jack ladspa libxmp lyrics +mad midi mms mplayer musepack
notifier opus oss pipewire projectm pulseaudio qsui qtmedia scrobbler shout sid
-sndfile soxr stereo tray udisks +vorbis wavpack xmp"
+sndfile soxr stereo tray udisks +vorbis wavpack"
REQUIRED_USE="
gnome? ( dbus )
@@ -59,6 +59,7 @@ RDEPEND="
virtual/jack
)
ladspa? ( media-plugins/cmt-plugins )
+ libxmp? ( media-libs/libxmp )
mad? (
media-libs/libmad:=
media-sound/mpg123:=
@@ -87,7 +88,6 @@ RDEPEND="
media-libs/libvorbis
)
wavpack? ( media-sound/wavpack )
- xmp? ( media-libs/libxmp )
"
DEPEND="${RDEPEND}"
BDEPEND="dev-qt/linguist-tools:5"
@@ -154,7 +154,7 @@ src_configure() {
-DUSE_UDISKS="$(usex udisks)"
-DUSE_VORBIS="$(usex vorbis)"
-DUSE_WAVPACK="$(usex wavpack)"
- -DUSE_XMP="$(usex xmp)"
+ -DUSE_XMP="$(usex libxmp)"
)
cmake_src_configure