summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2023-06-02 08:59:15 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2023-06-02 08:59:15 +0200
commitaa59e1de6dcb942ac262cb9a0d61e3b11379e489 (patch)
tree355f02075f6948b20cca6cd3565712b674d96a7f /media-sound/qsynth
parentmedia-sound/qsynth: dropped obsolete 0.9.8 (diff)
downloadgentoo-aa59e1de6dcb942ac262cb9a0d61e3b11379e489.tar.gz
gentoo-aa59e1de6dcb942ac262cb9a0d61e3b11379e489.tar.bz2
gentoo-aa59e1de6dcb942ac262cb9a0d61e3b11379e489.zip
media-sound/qsynth: bump to 0.9.11
Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'media-sound/qsynth')
-rw-r--r--media-sound/qsynth/Manifest1
-rw-r--r--media-sound/qsynth/qsynth-0.9.11.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/media-sound/qsynth/Manifest b/media-sound/qsynth/Manifest
index 9037b3b07fd9..a2aeced3f50c 100644
--- a/media-sound/qsynth/Manifest
+++ b/media-sound/qsynth/Manifest
@@ -1 +1,2 @@
DIST qsynth-0.9.10.tar.gz 333389 BLAKE2B 87ca02e1f15a7b28f5af462d1ef52e9609fc0abc3d15d545493f448da61d85d8d264f5ab908816607de3291424b979348f330205fc6e727edb7287fd28e9067d SHA512 82e04ccfe3193d570e28c4e5da3e9ea8afbc2b1f2e43f54459449b31ee5448a6232a5fe13631eed80a5cf75f4176e5a419ec6467bf3d7d5e30d34083d4d8f7aa
+DIST qsynth-0.9.11.tar.gz 333402 BLAKE2B 72a57a978bad1c4b2abcb287ea27c1c1365c06efdeedcd9bb69ca01a20304f48b19065c5e5181e8d30a3d4137eee56ec69cfba32dd8d2fa29f3ea1140019e089 SHA512 3d6c40066db235fc39ca804de1a352ade9e03e162b5901d0e1170f1f0cb4ec3e1631d2fe2b1e50a9cbab9528bca54ebb0afb8e5d615fb8f0b06b9761ae472f2d
diff --git a/media-sound/qsynth/qsynth-0.9.11.ebuild b/media-sound/qsynth/qsynth-0.9.11.ebuild
new file mode 100644
index 000000000000..9304e1e44040
--- /dev/null
+++ b/media-sound/qsynth/qsynth-0.9.11.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake desktop xdg
+
+DESCRIPTION="Qt application to control FluidSynth"
+HOMEPAGE="https://qsynth.sourceforge.io/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/qsynth/code"
+ inherit git-r3
+else
+ SRC_URI="mirror://sourceforge/qsynth/${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+alsa debug jack pulseaudio"
+
+REQUIRED_USE="|| ( alsa jack pulseaudio )"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ media-sound/fluidsynth:=[jack?,alsa?,pulseaudio?]
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-0.9.1-cmake-no-git-version.patch" )
+
+src_prepare() {
+ cmake_src_prepare
+
+ sed -e "/^find_package.*QT/s/Qt6 //" -i CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCONFIG_DEBUG=$(usex debug 1 0)
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # The desktop file is invalid, and we also change the command
+ # depending on useflags
+ rm "${D}/usr/share/applications/org.rncbc.qsynth.desktop" || die
+
+ local cmd
+ if use jack; then
+ cmd="qsynth"
+ elif use pulseaudio; then
+ cmd="qsynth -a pulseaudio"
+ elif use alsa; then
+ cmd="qsynth -a alsa"
+ else
+ cmd="qsynth -a oss"
+ fi
+
+ make_desktop_entry "${cmd}" Qsynth qsynth
+}