summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/timemachine
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/timemachine')
-rw-r--r--media-sound/timemachine/Manifest2
-rw-r--r--media-sound/timemachine/metadata.xml9
-rw-r--r--media-sound/timemachine/timemachine-0.3.1.ebuild31
-rw-r--r--media-sound/timemachine/timemachine-0.3.3.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/media-sound/timemachine/Manifest b/media-sound/timemachine/Manifest
new file mode 100644
index 000000000000..339498a029f6
--- /dev/null
+++ b/media-sound/timemachine/Manifest
@@ -0,0 +1,2 @@
+DIST timemachine-0.3.1.tar.gz 158344 SHA256 670ce6e9eff6f7b48fdd08be3678c46b997647c9b4541e46c1db66801cf67a87
+DIST timemachine-0.3.3.tar.gz 169021 SHA256 3e798a952b83874e3d60642ca4a7e0c2e2990c4659561009087da95044b21f9d
diff --git a/media-sound/timemachine/metadata.xml b/media-sound/timemachine/metadata.xml
new file mode 100644
index 000000000000..d4dd2647026b
--- /dev/null
+++ b/media-sound/timemachine/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proaudio</herd>
+ <longdescription>
+ Timemachine is a simple jack client record button remembering the last
+ ten seconds of audio when pressed.
+ </longdescription>
+</pkgmetadata>
diff --git a/media-sound/timemachine/timemachine-0.3.1.ebuild b/media-sound/timemachine/timemachine-0.3.1.ebuild
new file mode 100644
index 000000000000..360164c5e4a5
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="http://plugin.org.uk/timemachine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="lash"
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80
+ x11-libs/gtk+:2
+ >=media-libs/libsndfile-1.0.5
+ lash? ( >=media-sound/lash-0.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog
+}
diff --git a/media-sound/timemachine/timemachine-0.3.3.ebuild b/media-sound/timemachine/timemachine-0.3.3.ebuild
new file mode 100644
index 000000000000..0ceb726769e2
--- /dev/null
+++ b/media-sound/timemachine/timemachine-0.3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+DESCRIPTION="JACK client record button remembering the last 10 seconds when pressed"
+HOMEPAGE="http://plugin.org.uk/timemachine/"
+SRC_URI="http://plugin.org.uk/timemachine/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="lash"
+
+RDEPEND=">=media-sound/jack-audio-connection-kit-0.80
+ x11-libs/gtk+:2
+ >=media-libs/libsndfile-1.0.5
+ media-libs/liblo
+ lash? ( >=media-sound/lash-0.5 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable lash)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog
+}