summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-sound/wavpack
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-sound/wavpack')
-rw-r--r--media-sound/wavpack/Manifest2
-rw-r--r--media-sound/wavpack/metadata.xml5
-rw-r--r--media-sound/wavpack/wavpack-4.60.1-r1.ebuild33
-rw-r--r--media-sound/wavpack/wavpack-4.60.1.ebuild35
-rw-r--r--media-sound/wavpack/wavpack-4.70.0.ebuild30
5 files changed, 105 insertions, 0 deletions
diff --git a/media-sound/wavpack/Manifest b/media-sound/wavpack/Manifest
new file mode 100644
index 000000000000..0059970f27a0
--- /dev/null
+++ b/media-sound/wavpack/Manifest
@@ -0,0 +1,2 @@
+DIST wavpack-4.60.1.tar.bz2 394434 SHA256 175ee4f2effd6f51e6ec487956f41177256bf892c2e8e07de5d27ed4ee6888c5 SHA512 fae00bba5c6f9c487d5dd4cd4c08ab4ce2a255c12ba3a47614a7b896d7706999b8ebe70c77e9083e943f0fe05b5ddcef206fad1801ce7a21698d5350514ee814 WHIRLPOOL fae37e8c5882a8cdabe81e72ac272ce128056f0101beaad16020c127f466707819542a2c9da7934d43da0fbabf13586747e99443e823682feebde5e170b76e5b
+DIST wavpack-4.70.0.tar.bz2 411878 SHA256 2cade379b0aba99fbc4e442ccc6dac6c609f6212e46516a083e24c8c364430a4 SHA512 6a93e36b3bea5b410142416b4b0329c5f65031418cdd303d395ca2aaad2a1ab02987b9a329dec6d14fe9387a3d5978caaf6345056eece24c5ad0ae9273349449 WHIRLPOOL e9b34aad74e183814f710d038c30946dcf43c6472e25778507494c4c40f9adf166e8cda81916f670150876adcf34979bd88e40fc81ee2a7c036db1b3a285e69b
diff --git a/media-sound/wavpack/metadata.xml b/media-sound/wavpack/metadata.xml
new file mode 100644
index 000000000000..ae573a60407f
--- /dev/null
+++ b/media-sound/wavpack/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sound</herd>
+</pkgmetadata>
diff --git a/media-sound/wavpack/wavpack-4.60.1-r1.ebuild b/media-sound/wavpack/wavpack-4.60.1-r1.ebuild
new file mode 100644
index 000000000000..a5481563c7f7
--- /dev/null
+++ b/media-sound/wavpack/wavpack-4.60.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="WavPack audio compression tools"
+HOMEPAGE="http://www.wavpack.com"
+SRC_URI="http://www.wavpack.com/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+RDEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r4
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_mmx mmx)
+ )
+
+ autotools-multilib_src_configure
+}
diff --git a/media-sound/wavpack/wavpack-4.60.1.ebuild b/media-sound/wavpack/wavpack-4.60.1.ebuild
new file mode 100644
index 000000000000..642af8229f48
--- /dev/null
+++ b/media-sound/wavpack/wavpack-4.60.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit libtool
+
+DESCRIPTION="WavPack audio compression tools"
+HOMEPAGE="http://www.wavpack.com"
+SRC_URI="http://www.wavpack.com/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="cpu_flags_x86_mmx"
+
+RDEPEND="virtual/libiconv"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-static \
+ $(use_enable cpu_flags_x86_mmx mmx)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
diff --git a/media-sound/wavpack/wavpack-4.70.0.ebuild b/media-sound/wavpack/wavpack-4.70.0.ebuild
new file mode 100644
index 000000000000..defeba30e298
--- /dev/null
+++ b/media-sound/wavpack/wavpack-4.70.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+inherit autotools-multilib
+
+DESCRIPTION="Hybrid lossless audio compression tools"
+HOMEPAGE="http://www.wavpack.com/"
+SRC_URI="http://www.wavpack.com/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="cpu_flags_x86_mmx static-libs"
+
+RDEPEND=">=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
+ abi_x86_32? ( !<=app-emulation/emul-linux-x86-soundlibs-20130224-r4
+ !app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] )"
+DEPEND="${RDEPEND}"
+
+DOCS=( ChangeLog README )
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable cpu_flags_x86_mmx mmx)
+ )
+ autotools-multilib_src_configure
+}