summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuan Liao <liaoyuan@gmail.com>2024-06-13 09:27:12 -0400
committerYixun Lan <dlan@gentoo.org>2024-06-13 23:22:30 +0000
commit35b14b701a2f08167c8fe3ff38be2566ce1fa40c (patch)
treec2d7271266f6a9d94318767726fa16a8bc7af10b /media-sound
parentmedia-sound/lollypop: Drop 1.4.37 (diff)
downloadgentoo-35b14b701a2f08167c8fe3ff38be2566ce1fa40c.tar.gz
gentoo-35b14b701a2f08167c8fe3ff38be2566ce1fa40c.tar.bz2
gentoo-35b14b701a2f08167c8fe3ff38be2566ce1fa40c.zip
media-sound/lollypop: Add 1.4.40
Closes: https://github.com/gentoo/gentoo/pull/37140 Signed-off-by: Yuan Liao <liaoyuan@gmail.com> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/lollypop/Manifest1
-rw-r--r--media-sound/lollypop/lollypop-1.4.40.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/media-sound/lollypop/Manifest b/media-sound/lollypop/Manifest
index dd189ec87f45..bdebfac49883 100644
--- a/media-sound/lollypop/Manifest
+++ b/media-sound/lollypop/Manifest
@@ -1 +1,2 @@
DIST lollypop-1.4.39.tar.xz 599984 BLAKE2B c985bda8f8ec979cc222f3860f17f2d2329bbd04f808462011f92dcca350c9b5a99af6e5aa3efc68e128946f932890d35602e1dcfbb4b86d46468dc188e5443d SHA512 5a7fe675fb70d7f4f8d4c15f8a6e4faad0f430689f3612dd72801da10174218feb444f40ee90bdcbcf39f63b0df5889c2244772f50b7389d27f3a9e969f7cdbf
+DIST lollypop-1.4.40.tar.xz 600140 BLAKE2B d74944a3f8d62e3d04a309717dc2f1f623376678000ed3e9ff53ca8be0ccf902b83e696f916308a4801fda283921680b592e5e1a05305e5d96624cffb0135915 SHA512 bde1e73dbeb7030a55446f5aed378639a9f6fb3bb2a7bf8253e180effa7a669083a76215ec9ebc153999a867b95d1957cdc14019d629a7f56fab9fcfea7ad822
diff --git a/media-sound/lollypop/lollypop-1.4.40.ebuild b/media-sound/lollypop/lollypop-1.4.40.ebuild
new file mode 100644
index 000000000000..7806e83ea85f
--- /dev/null
+++ b/media-sound/lollypop/lollypop-1.4.40.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="sqlite"
+inherit gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Modern music player for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Lollypop"
+# Tarballs on adishatz.org have files from Git submodule 'subprojects/po'
+SRC_URI="https://adishatz.org/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+IUSE="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+# Dependencies being checked by Meson
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ net-libs/libsoup:3.0[introspection]
+ x11-libs/gtk+:3[introspection]
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+"
+
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? (
+ dev-libs/appstream-glib
+ dev-util/desktop-file-utils
+ )
+"
+
+RDEPEND="
+ ${DEPEND}
+ app-crypt/libsecret[introspection]
+ dev-libs/totem-pl-parser[introspection]
+ gui-libs/libhandy:1[introspection]
+ media-plugins/gst-plugins-pulse
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}/usr/bin"
+ python_fix_shebang "${ED}/usr/libexec/lollypop-sp"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Remember to install the necessary gst-plugins packages for your audio files."
+ elog "You can also use the gst-plugins-meta package and its USE flags."
+ fi
+
+ local log_yt_dlp ver
+ for ver in ${REPLACING_VERSIONS}; do
+ ver_test "${ver}" -lt "1.4.36" && log_yt_dlp=1
+ done
+ [[ ${log_yt_dlp} ]] &&
+ elog "Since version 1.4.36, Lollypop relies on yt-dlp instead of youtube-dl."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}