summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2024-06-16 12:04:34 +0200
committerPacho Ramos <pacho@gentoo.org>2024-06-16 12:16:25 +0200
commit86ddbbd4a3a4ee5c7bc43f41466d0ecfef0d85e5 (patch)
tree0908a960833d4910a1eba08accf5a11bf803f6ba /media-sound
parentmedia-sound/soundconverter: enable py3.12 (diff)
downloadgentoo-86ddbbd4a3a4ee5c7bc43f41466d0ecfef0d85e5.tar.gz
gentoo-86ddbbd4a3a4ee5c7bc43f41466d0ecfef0d85e5.tar.bz2
gentoo-86ddbbd4a3a4ee5c7bc43f41466d0ecfef0d85e5.zip
media-sound/soundconverter: add 4.0.5
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/soundconverter/Manifest1
-rw-r--r--media-sound/soundconverter/soundconverter-4.0.5.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/media-sound/soundconverter/Manifest b/media-sound/soundconverter/Manifest
index a5fa1c2a5dc0..124f38415d12 100644
--- a/media-sound/soundconverter/Manifest
+++ b/media-sound/soundconverter/Manifest
@@ -1 +1,2 @@
DIST soundconverter-4.0.3.gh.tar.gz 632495 BLAKE2B 9a2847b5ebb998b9122ff4020e47dc5b84635a6e1ae0de9061bab18e813ab3918278e940df80bc370b071de77a82a3637c376d9ebdd84d2f7b00865dda94935a SHA512 0674eb430bb3cf267ceabee8e7dbdeb2ee81e537ca093fcf6e1adab21112690ed9e3eb349a994805ddfc51b3a4f875b87a5819a1f2cf020752eb8e742665a998
+DIST soundconverter-4.0.5.gh.tar.gz 638789 BLAKE2B e4cb89b9911d7f28e3db2b5e93858defc4ac12199805a61aa74264a89bc81037a6597ee404d84881ff83af33b59bc64a8267b682e3cba4109ddc1e4a3798f90d SHA512 efd96fcf1f75381c985cbc7cc849462fc424e7b54fcbbb5e63e49e32b195dfab43806fecbc4e7f9a7f70b0df4e9a6d511b07dcaaca5eaa5e29bc49e1e66acb4b
diff --git a/media-sound/soundconverter/soundconverter-4.0.5.ebuild b/media-sound/soundconverter/soundconverter-4.0.5.ebuild
new file mode 100644
index 000000000000..b4704cea2c49
--- /dev/null
+++ b/media-sound/soundconverter/soundconverter-4.0.5.ebuild
@@ -0,0 +1,100 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_REQ_USE="xml(+)"
+inherit gnome2-utils distutils-r1 virtualx xdg
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="A simple audiofile converter application for the GNOME environment"
+HOMEPAGE="https://soundconverter.org/"
+SRC_URI="https://github.com/kassoulet/${PN}/archive/${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="aac flac mp3 ogg opus vorbis"
+
+# gst-plugins-meta for any decoders, USE flags for specific encoders used by code
+# List in soundconverter/gstreamer.py
+# wavenc and mp4mux come from gst-plugins-good, which everyone having base should have, so unconditional
+RDEPEND="
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ ')
+ media-libs/gst-plugins-base:1.0[vorbis?,ogg?]
+ media-plugins/gst-plugins-meta:1.0
+ flac? ( media-plugins/gst-plugins-flac:1.0 )
+ media-libs/gst-plugins-good:1.0
+ mp3? (
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ )
+ aac? ( media-plugins/gst-plugins-faac:1.0 )
+ opus? ( media-plugins/gst-plugins-opus:1.0 )
+"
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ ')
+ dev-util/intltool
+ test? (
+ media-plugins/gst-plugins-flac:1.0
+ media-libs/gst-plugins-bad:1.0
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-lame:1.0
+ media-plugins/gst-plugins-faac:1.0
+ media-plugins/gst-plugins-opus:1.0
+ )
+"
+
+# Before PEP517: tests seem to hang and also fail to find fdkaacenc from gst?
+# After: need to trick it into finding the data (inc. glade files)
+RESTRICT="test"
+
+python_prepare_all() {
+ gnome2_environment_reset
+ distutils-r1_python_prepare_all
+
+ rm -v "${S}/CHANGELOG.old" || die
+
+ # workaround incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ ! [[ -v LINGUAS && -z ${LINGUAS} ]] || rm po/*.po || die
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ export GSETTINGS_SCHEMA_DIR="${S}/data"
+ "${BROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}"/data || die
+
+ "${EPYTHON}" tests/test.py || die
+}
+
+python_install_all() {
+ rm -v "${ED}"/usr/share/glib-2.0/schemas/gschemas.compiled || die
+ mv -v "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die
+ distutils-r1_python_install_all
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}