summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /media-video/aravis
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'media-video/aravis')
-rw-r--r--media-video/aravis/Manifest2
-rw-r--r--media-video/aravis/aravis-0.1.14.ebuild68
-rw-r--r--media-video/aravis/aravis-0.1.15.ebuild68
-rw-r--r--media-video/aravis/aravis-9999.ebuild68
-rw-r--r--media-video/aravis/metadata.xml20
5 files changed, 226 insertions, 0 deletions
diff --git a/media-video/aravis/Manifest b/media-video/aravis/Manifest
new file mode 100644
index 000000000000..a7eb29bc0bb0
--- /dev/null
+++ b/media-video/aravis/Manifest
@@ -0,0 +1,2 @@
+DIST aravis-0.1.14.tar.xz 414932 SHA256 4f7a5e8a965db2ac2428029f7e91933fcc40664f78d645041b8bb7b710e66bea SHA512 d84fe519074a69e679b08e0c0933bce191e50cfcdd1b46b743aa68ba33445a3a87cbd1701ba424666b638949f9faf531ec668acbe5d22017712f70cfa9620ea9 WHIRLPOOL 1e225a92c11341327452946cc35f18d76fe90626dca6b82631640443920675be270beeb053cc352c5c552b5a3edc2661fc96e2e00a1222630ed76fe5d35403c0
+DIST aravis-0.1.15.tar.xz 448348 SHA256 8181b9965abad9065607be0d28015ea56615b37e8297b9ec445a2c8fe58214df SHA512 f6a2e1f7fa4f712bea6a91f896bbc92afb3dcf3146109f3f7aee2ad6812a69f0b47a0f2116062cba6163dc058c7981a01a6eec395d4af633da666fe186291929 WHIRLPOOL 68b23fbb24fb78542db0f9b9ce9dbafc0a3b81971c5dc471313fbc2164bbae1b9317f00254ccaf457fb907b7ff8130cdf0612a66a6474c5effbbe601138ba04d
diff --git a/media-video/aravis/aravis-0.1.14.ebuild b/media-video/aravis/aravis-0.1.14.ebuild
new file mode 100644
index 000000000000..01c99dfe06b7
--- /dev/null
+++ b/media-video/aravis/aravis-0.1.14.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+KEYWORDS="~amd64"
+
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.gnome.org/aravis"
+ EGIT_COMMIT="${aravis_LIVE_COMMIT:-master}"
+ inherit git-2 autotools
+fi
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+HOMEPAGE="http://live.gnome.org/Aravis"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="X gstreamer"
+
+GST_DEPEND="media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+
+RDEPEND=">=dev-libs/glib-2.22
+ dev-libs/libxml2
+ X? (
+ >=x11-libs/gtk+-2.12:2
+ ${GST_DEPEND}
+ media-libs/gst-plugins-base:0.10
+ media-plugins/gst-plugins-xvideo:0.10
+ )
+ gstreamer? ( ${GST_DEPEND} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/gobject-introspection"
+
+if [[ -z ${EGIT_COMMIT} ]]; then
+ SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.xz"
+else
+ DEPEND+=" dev-util/gtk-doc dev-util/intltool"
+fi
+
+src_prepare() {
+ if [[ -n ${EGIT_COMMIT} ]]; then
+ intltoolize || die
+ gtkdocize || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ $(use_enable X viewer) \
+ $(use_enable gstreamer gst-plugin) \
+ --enable-introspection
+}
+
+src_install() {
+ emake install DESTDIR="${D}" aravisdocdir="/usr/share/doc/${PF}"
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-video/aravis/aravis-0.1.15.ebuild b/media-video/aravis/aravis-0.1.15.ebuild
new file mode 100644
index 000000000000..01c99dfe06b7
--- /dev/null
+++ b/media-video/aravis/aravis-0.1.15.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+KEYWORDS="~amd64"
+
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.gnome.org/aravis"
+ EGIT_COMMIT="${aravis_LIVE_COMMIT:-master}"
+ inherit git-2 autotools
+fi
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+HOMEPAGE="http://live.gnome.org/Aravis"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="X gstreamer"
+
+GST_DEPEND="media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+
+RDEPEND=">=dev-libs/glib-2.22
+ dev-libs/libxml2
+ X? (
+ >=x11-libs/gtk+-2.12:2
+ ${GST_DEPEND}
+ media-libs/gst-plugins-base:0.10
+ media-plugins/gst-plugins-xvideo:0.10
+ )
+ gstreamer? ( ${GST_DEPEND} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/gobject-introspection"
+
+if [[ -z ${EGIT_COMMIT} ]]; then
+ SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.xz"
+else
+ DEPEND+=" dev-util/gtk-doc dev-util/intltool"
+fi
+
+src_prepare() {
+ if [[ -n ${EGIT_COMMIT} ]]; then
+ intltoolize || die
+ gtkdocize || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ $(use_enable X viewer) \
+ $(use_enable gstreamer gst-plugin) \
+ --enable-introspection
+}
+
+src_install() {
+ emake install DESTDIR="${D}" aravisdocdir="/usr/share/doc/${PF}"
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-video/aravis/aravis-9999.ebuild b/media-video/aravis/aravis-9999.ebuild
new file mode 100644
index 000000000000..01c99dfe06b7
--- /dev/null
+++ b/media-video/aravis/aravis-9999.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit versionator
+
+KEYWORDS="~amd64"
+
+if [[ ${PV} == "9999" ]]; then
+ KEYWORDS=""
+ EGIT_REPO_URI="git://git.gnome.org/aravis"
+ EGIT_COMMIT="${aravis_LIVE_COMMIT:-master}"
+ inherit git-2 autotools
+fi
+
+DESCRIPTION="Library for video acquisition using Genicam cameras"
+HOMEPAGE="http://live.gnome.org/Aravis"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+IUSE="X gstreamer"
+
+GST_DEPEND="media-libs/gstreamer:0.10
+ media-libs/gst-plugins-base:0.10"
+
+RDEPEND=">=dev-libs/glib-2.22
+ dev-libs/libxml2
+ X? (
+ >=x11-libs/gtk+-2.12:2
+ ${GST_DEPEND}
+ media-libs/gst-plugins-base:0.10
+ media-plugins/gst-plugins-xvideo:0.10
+ )
+ gstreamer? ( ${GST_DEPEND} )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-libs/gobject-introspection"
+
+if [[ -z ${EGIT_COMMIT} ]]; then
+ SRC_URI="mirror://gnome/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.xz"
+else
+ DEPEND+=" dev-util/gtk-doc dev-util/intltool"
+fi
+
+src_prepare() {
+ if [[ -n ${EGIT_COMMIT} ]]; then
+ intltoolize || die
+ gtkdocize || die
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf \
+ --disable-silent-rules \
+ --disable-static \
+ $(use_enable X viewer) \
+ $(use_enable gstreamer gst-plugin) \
+ --enable-introspection
+}
+
+src_install() {
+ emake install DESTDIR="${D}" aravisdocdir="/usr/share/doc/${PF}"
+ find "${D}" -name '*.la' -delete
+}
diff --git a/media-video/aravis/metadata.xml b/media-video/aravis/metadata.xml
new file mode 100644
index 000000000000..32f225f9bd85
--- /dev/null
+++ b/media-video/aravis/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>video</herd>
+ <maintainer>
+ <email>lu_zero@gentoo.org</email>
+ </maintainer>
+
+ <use>
+ <flag name='X'>
+ Build the GTK+-based video viewer for aravis. This requires
+ GStreamer and a few plugins but technically not the GST plugin
+ for aravis.
+ </flag>
+
+ <flag name='gstreamer'>
+ Build the GStreamer plugin for aravis, but not the video viewer.
+ </flag>
+ </use>
+</pkgmetadata>