summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2018-08-15 19:03:52 -0400
committerMichael Orlitzky <mjo@gentoo.org>2018-08-16 07:42:53 -0400
commitcffe3bf5c60c0e0725b860ebea3179976aa04d1a (patch)
tree82635f8f1f22681d445cce951d4399f0fcd93ad8 /net-analyzer/nagios-icinga-openvpn
parentmedia-libs/libjpeg-turbo-1.5.3-r2: Fix CVE-2018-11813 (diff)
downloadgentoo-cffe3bf5c60c0e0725b860ebea3179976aa04d1a.tar.gz
gentoo-cffe3bf5c60c0e0725b860ebea3179976aa04d1a.tar.bz2
gentoo-cffe3bf5c60c0e0725b860ebea3179976aa04d1a.zip
net-analyzer/nagios-icinga-openvpn: new package to monitor OpenVPN.
This package is intended to be a full-featured replacement for the existing net-analyzer/nagios-check_openvpn-simple plugin. The "simple" version lacked several important features, the most important of which was the ability to use a TLS-auth key in the default UDP configuration. The new plugin is largely a drop-in replacement, but the executable name is different, so your configuration will need to be updated. Bug: https://bugs.gentoo.org/663774 Package-Manager: Portage-2.3.44, Repoman-2.3.9
Diffstat (limited to 'net-analyzer/nagios-icinga-openvpn')
-rw-r--r--net-analyzer/nagios-icinga-openvpn/Manifest1
-rw-r--r--net-analyzer/nagios-icinga-openvpn/metadata.xml8
-rw-r--r--net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/nagios-icinga-openvpn/Manifest b/net-analyzer/nagios-icinga-openvpn/Manifest
new file mode 100644
index 000000000000..6e9b6cd78f78
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/Manifest
@@ -0,0 +1 @@
+DIST nagios-icinga-openvpn-0.0.1.tar.gz 4637 BLAKE2B 365b6450cccd5f7f25348583eae45c0b15932ec1e858d375171911e4108dd2b7fc133559a35399ece8d2a349f05b2f51897cf9e271f498b6bbaa2c6bba3551a9 SHA512 0dae6c2df71a20e287720767aa4ba41d0568f3cd4bd2a6eb252f86d810d3de265ddc38397df15bb1b115ba35ac68aa6e18345dc4432d4d13b08b500483ffbb11
diff --git a/net-analyzer/nagios-icinga-openvpn/metadata.xml b/net-analyzer/nagios-icinga-openvpn/metadata.xml
new file mode 100644
index 000000000000..45125b9b6e99
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ <name>Michael Orlitzky</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1.ebuild b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1.ebuild
new file mode 100644
index 000000000000..e8e112ffe2f0
--- /dev/null
+++ b/net-analyzer/nagios-icinga-openvpn/nagios-icinga-openvpn-0.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+MY_PN="check_openvpn"
+DESCRIPTION="A Nagios plugin to check whether an OpenVPN server is alive"
+HOMEPAGE="https://github.com/liquidat/${PN}"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+src_install() {
+ distutils-r1_src_install
+
+ local nagiosplugindir="/usr/$(get_libdir)/nagios/plugins"
+ dodir "${nagiosplugindir}"
+
+ # Create a symlink from the nagios plugin directory to the /usr/bin
+ # location. The "binary" in /usr/bin should also be a symlink, since
+ # the python machinery allows the user to switch out the
+ # interpreter. We don't want to mess with any of that, so we just
+ # point to whatever the system would use if the user executed
+ # ${MY_PN}.
+ #
+ # The relative symlink is preferred so that if the package is
+ # installed e.g. while in a chroot, the symlink will never point
+ # outside of that chroot.
+ #
+ dosym "../../../bin/${MY_PN}" "${nagiosplugindir}/${MY_PN}"
+}