summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ospd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ospd')
-rw-r--r--net-analyzer/ospd/Manifest1
-rw-r--r--net-analyzer/ospd/files/ospd-1.0_beta3-description.patch18
-rw-r--r--net-analyzer/ospd/metadata.xml7
-rw-r--r--net-analyzer/ospd/ospd-1.0.0.ebuild34
4 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/ospd/Manifest b/net-analyzer/ospd/Manifest
new file mode 100644
index 000000000000..c9408be8b05c
--- /dev/null
+++ b/net-analyzer/ospd/Manifest
@@ -0,0 +1 @@
+DIST ospd-1.0.0.tar.gz 39656 SHA256 da4b8f636897544a4d4a6cc8c932762b356cc729c5e532f0ceb80f0339c5dcb8 SHA512 64b1b42c5292dc8cf8b1ffde9082f4d05ff62f4d0bf2ed7b2b5d2ba4d3c3611ae8af30b39c8becb9f6bdc36eb519a0b881cdeb50891e5a2273003f6181cbebfb WHIRLPOOL ee7f1b0b29f993d8913b4ba53f3089f13f216f6957d16ca74409e1eb75a70a0aba20472aaf433a27fc4aa9610a1dd38ad25b64c623ecbf576833aefed6272a98
diff --git a/net-analyzer/ospd/files/ospd-1.0_beta3-description.patch b/net-analyzer/ospd/files/ospd-1.0_beta3-description.patch
new file mode 100644
index 000000000000..a6f7061a5e10
--- /dev/null
+++ b/net-analyzer/ospd/files/ospd-1.0_beta3-description.patch
@@ -0,0 +1,18 @@
+ setup.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 5c17dd1..fffea59 100644
+--- a/setup.py
++++ b/setup.py
+@@ -40,8 +40,8 @@ setup(
+ # http://packaging.python.org/en/latest/tutorial.html#version
+ version='1.0+beta3',
+
+- description=('OSPD is a collection of scanner wrappers which share the, ',
+- 'same communication protocol: OSP (OpenVAS Scanner ',
++ description=('OSPD is a collection of scanner wrappers which share the, '
++ 'same communication protocol: OSP (OpenVAS Scanner '
+ 'Protocol)'),
+ long_description=long_description,
+
diff --git a/net-analyzer/ospd/metadata.xml b/net-analyzer/ospd/metadata.xml
new file mode 100644
index 000000000000..4a00a64b40ae
--- /dev/null
+++ b/net-analyzer/ospd/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/ospd/ospd-1.0.0.ebuild b/net-analyzer/ospd/ospd-1.0.0.ebuild
new file mode 100644
index 000000000000..a22ef50f4e1b
--- /dev/null
+++ b/net-analyzer/ospd/ospd-1.0.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DL_ID=1999
+
+DESCRIPTION="Collection of scanner wrappers for OpenVAS"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/${DL_ID}/${P/_beta/+beta}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2+"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${P/_beta/-beta}
+
+_DOCS=( ChangeLog CHANGES README )
+
+python_test() {
+ esetup.py test
+}