summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-02-05 16:29:31 +0100
committerMarek Szuba <marecki@gentoo.org>2020-02-05 16:30:35 +0100
commite079e3cc9126887c71f1cd7130157e17c1ea31ac (patch)
tree6450bf1444aa47ce5c8beaed14fb106a092a4ca8 /net-analyzer/suricata
parentdev-python/jwcrypto: Remove py2 (diff)
downloadgentoo-e079e3cc9126887c71f1cd7130157e17c1ea31ac.tar.gz
gentoo-e079e3cc9126887c71f1cd7130157e17c1ea31ac.tar.bz2
gentoo-e079e3cc9126887c71f1cd7130157e17c1ea31ac.zip
net-analyzer/suricata: build with -fno-common / gcc-10
Tried fixing the code but it turns out it would require a non-trivial amount of changes so let's just force -fcommon. Tested using gcc-9 with -fno-common included in CFLAGS. Closes: https://bugs.gentoo.org/707204 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-analyzer/suricata')
-rw-r--r--net-analyzer/suricata/suricata-5.0.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/net-analyzer/suricata/suricata-5.0.1.ebuild b/net-analyzer/suricata/suricata-5.0.1.ebuild
index 676947405976..d09d4b1a9847 100644
--- a/net-analyzer/suricata/suricata-5.0.1.ebuild
+++ b/net-analyzer/suricata/suricata-5.0.1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{6,7,8} )
-inherit autotools linux-info python-single-r1 systemd
+inherit autotools flag-o-matic linux-info python-single-r1 systemd
DESCRIPTION="High performance Network IDS, IPS and Network Security Monitoring engine"
HOMEPAGE="https://suricata-ids.org/"
@@ -71,6 +71,9 @@ pkg_pretend() {
}
src_prepare() {
+ # Bug #707204
+ append-cflags $(test-flags-CC -fcommon)
+
default
sed -ie 's/docdir =.*/docdir = ${datarootdir}\/doc\/'${PF}'\//' "${S}/doc/Makefile.am"
eautoreconf