summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-10 13:53:14 +0000
committerSam James <sam@gentoo.org>2023-03-10 13:55:12 +0000
commitd7f6f2d938cc48a64919dce4fa295d4751c71a51 (patch)
treed211f851e43eca06d57382e6e33e0bc27dfad619 /net-dialup/lrzsz
parentapp-misc/joymouse: fix configure w/ clang 16 (diff)
downloadgentoo-d7f6f2d938cc48a64919dce4fa295d4751c71a51.tar.gz
gentoo-d7f6f2d938cc48a64919dce4fa295d4751c71a51.tar.bz2
gentoo-d7f6f2d938cc48a64919dce4fa295d4751c71a51.zip
net-dialup/lrzsz: fix configure w/ clang 16
Closes: https://bugs.gentoo.org/898970 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-dialup/lrzsz')
-rw-r--r--net-dialup/lrzsz/files/lrzsz-0.12.20-configure-clang16.patch13
-rw-r--r--net-dialup/lrzsz/lrzsz-0.12.20-r5.ebuild (renamed from net-dialup/lrzsz/lrzsz-0.12.20-r4.ebuild)6
2 files changed, 16 insertions, 3 deletions
diff --git a/net-dialup/lrzsz/files/lrzsz-0.12.20-configure-clang16.patch b/net-dialup/lrzsz/files/lrzsz-0.12.20-configure-clang16.patch
new file mode 100644
index 000000000000..bda489d11dd4
--- /dev/null
+++ b/net-dialup/lrzsz/files/lrzsz-0.12.20-configure-clang16.patch
@@ -0,0 +1,13 @@
+https://bugs.gentoo.org/898970
+--- a/configure.in
++++ b/configure.in
+@@ -186,7 +186,8 @@ AC_CACHE_VAL(lrzsz_cv_sys_ftime_ok,
+ #include <sys/types.h>
+ #include <sys/timeb.h>
+ #include <stdio.h>
+-main ()
++#include <stdlib.h>
++int main (void)
+ {
+ struct timeb s, slast;
+ int c = 0;
diff --git a/net-dialup/lrzsz/lrzsz-0.12.20-r4.ebuild b/net-dialup/lrzsz/lrzsz-0.12.20-r5.ebuild
index 9134cf53053f..ba988723b913 100644
--- a/net-dialup/lrzsz/lrzsz-0.12.20-r4.ebuild
+++ b/net-dialup/lrzsz/lrzsz-0.12.20-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="Communication package providing the X, Y, and ZMODEM file transfer protocols"
HOMEPAGE="https://www.ohse.de/uwe/software/lrzsz.html"
@@ -23,6 +23,7 @@ PATCHES=(
"${FILESDIR}"/${P}-automake-1.13.patch
"${FILESDIR}"/${P}-gettext-0.20.patch
"${FILESDIR}"/${P}-AR.patch
+ "${FILESDIR}"/${P}-configure-clang16.patch
)
DOCS=( AUTHORS COMPATABILITY ChangeLog NEWS \
@@ -43,7 +44,6 @@ src_prepare() {
src_configure() {
tc-export CC
- append-flags -Wstrict-prototypes
econf $(use_enable nls)
}