summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-ftp/ftpbase
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-ftp/ftpbase')
-rw-r--r--net-ftp/ftpbase/files/ftp-pamd18
-rw-r--r--net-ftp/ftpbase/files/ftp-pamd-include18
-rw-r--r--net-ftp/ftpbase/files/ftpusers37
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01-r2.ebuild54
-rw-r--r--net-ftp/ftpbase/metadata.xml10
5 files changed, 137 insertions, 0 deletions
diff --git a/net-ftp/ftpbase/files/ftp-pamd b/net-ftp/ftpbase/files/ftp-pamd
new file mode 100644
index 000000000000..c32d2ba076f7
--- /dev/null
+++ b/net-ftp/ftpbase/files/ftp-pamd
@@ -0,0 +1,18 @@
+# Provided by ftpbase (dont remove this line!)
+# Standard pam.d file for ftp service packages.
+# $Id$
+
+auth required pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed
+auth required pam_stack.so service=system-auth
+
+# If this is enabled, anonymous logins will fail because the 'ftp' user does
+# not have a "valid" shell, as listed in /etc/shells.
+#
+# If you enable this, it is recommended that you do *not* give the 'ftp'
+# user a real shell. Instead, give the 'ftp' user /bin/false for a shell and
+# add /bin/false to /etc/shells.
+# auth required pam_shells.so
+
+account required pam_stack.so service=system-auth
+
+session required pam_stack.so service=system-auth
diff --git a/net-ftp/ftpbase/files/ftp-pamd-include b/net-ftp/ftpbase/files/ftp-pamd-include
new file mode 100644
index 000000000000..8f081537d822
--- /dev/null
+++ b/net-ftp/ftpbase/files/ftp-pamd-include
@@ -0,0 +1,18 @@
+# Provided by ftpbase (dont remove this line!)
+# Standard pam.d file for ftp service packages.
+# $Id$
+
+auth required pam_listfile.so item=user sense=deny file=/etc/ftpusers onerr=succeed
+auth include system-auth
+
+# If this is enabled, anonymous logins will fail because the 'ftp' user does
+# not have a "valid" shell, as listed in /etc/shells.
+#
+# If you enable this, it is recommended that you do *not* give the 'ftp'
+# user a real shell. Instead, give the 'ftp' user /bin/false for a shell and
+# add /bin/false to /etc/shells.
+# auth required pam_shells.so
+
+account include system-auth
+
+session include system-auth
diff --git a/net-ftp/ftpbase/files/ftpusers b/net-ftp/ftpbase/files/ftpusers
new file mode 100644
index 000000000000..3e26eda6dde1
--- /dev/null
+++ b/net-ftp/ftpbase/files/ftpusers
@@ -0,0 +1,37 @@
+# Provided by ftpbase (dont remove this line!)
+# /etc/ftpusers: list of users disallowed FTP access
+# $Id$
+
+halt
+operator
+root
+shutdown
+sync
+bin
+daemon
+adm
+lp
+mail
+postmaster
+news
+uucp
+man
+games
+at
+cron
+www
+named
+squid
+gdm
+mysql
+postgres
+guest
+nobody
+alias
+qmaild
+qmaill
+qmailp
+qmailq
+qmailr
+qmails
+postfix
diff --git a/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
new file mode 100644
index 000000000000..359abbc51619
--- /dev/null
+++ b/net-ftp/ftpbase/ftpbase-0.01-r2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils pam user
+
+DESCRIPTION="FTP layout package"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE="pam"
+
+DEPEND="pam? ( virtual/pam )
+ !<net-ftp/proftpd-1.2.10-r6
+ !<net-ftp/pure-ftpd-1.0.20-r2
+ !<net-ftp/vsftpd-2.0.3-r1"
+
+S=${WORKDIR}
+
+pkg_setup() {
+ # Check if home exists
+ local exists=false
+ [[ -d "${ROOT}home/ftp" ]] && exists=true
+
+ # Add our default ftp user
+ enewgroup ftp 21
+ enewuser ftp 21 -1 /home/ftp ftp
+
+ # If home did not exist and does now then we created it in the enewuser
+ # command. Now we have to change it's permissions to something sane.
+ if [[ ${exists} == "false" && -d "${ROOT}home/ftp" ]] ; then
+ chown root:ftp "${ROOT}"home/ftp
+ fi
+}
+
+src_install() {
+ # The ftpusers file is a list of people who are NOT allowed
+ # to use the ftp service.
+ insinto /etc
+ doins "${FILESDIR}/ftpusers" || die
+
+ # Ideally we would create the home directory here with a dodir.
+ # But we cannot until bug #9849 is solved - so we kludge in pkg_postinst()
+
+ cp "${FILESDIR}/ftp-pamd-include" "${T}" || die
+ if use elibc_FreeBSD; then
+ sed -i -e "/pam_listfile.so/s/^.*$/account required pam_ftpusers.so no_warn disallow/" \
+ "${T}"/ftp-pamd-include || die
+ fi
+ newpamd "${T}"/ftp-pamd-include ftp
+}
diff --git a/net-ftp/ftpbase/metadata.xml b/net-ftp/ftpbase/metadata.xml
new file mode 100644
index 000000000000..f417ba208b00
--- /dev/null
+++ b/net-ftp/ftpbase/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
+ FTP base package
+ </longdescription>
+</pkgmetadata>