summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2024-02-18 11:01:40 +0000
committerMarek Szuba <marecki@gentoo.org>2024-02-18 11:01:40 +0000
commit6c7d6517015a8cd1a0c23ae2cbebb10df3eda38c (patch)
tree073d5b1b9973d5a225860d39431c7f9d9c76b121 /net-libs/libhtp
parentmedia-radio/chirp: 20240217 no longer needs patching (diff)
downloadgentoo-6c7d6517015a8cd1a0c23ae2cbebb10df3eda38c.tar.gz
gentoo-6c7d6517015a8cd1a0c23ae2cbebb10df3eda38c.tar.bz2
gentoo-6c7d6517015a8cd1a0c23ae2cbebb10df3eda38c.zip
net-libs/libhtp: add 0.5.46
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'net-libs/libhtp')
-rw-r--r--net-libs/libhtp/Manifest1
-rw-r--r--net-libs/libhtp/libhtp-0.5.46.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/net-libs/libhtp/Manifest b/net-libs/libhtp/Manifest
index f72d301dc853..2ce38167969a 100644
--- a/net-libs/libhtp/Manifest
+++ b/net-libs/libhtp/Manifest
@@ -1 +1,2 @@
DIST libhtp-0.5.45.tar.gz 501108 BLAKE2B faa5a05844a959b00b1f53c26d8c9167d91998c2b4d71b9ce85f1822f431d40d46513a596d804dee3290bdfad5a27d93755bb6e39fb5c36fc90472637cc3caad SHA512 b4bc6cc209d8d8833082ade7d4257da3a449344ed29a3fd20b5100f3c983163cd3e537d154748a116ff22b9a79b245ba2e6d0f5960c37b4ca9867506b8ed13ed
+DIST libhtp-0.5.46.tar.gz 503286 BLAKE2B 326246433b3d8525cd211fec73bc0fdd9fb61a65001fc55d1fed4e966c53b16a1052ef0597990681d805c2c560e670b8b2d2558851971df6c31910dea571d0cc SHA512 8dac8ea13b550046d9f4463087b72ea1de019329bc94468b73923146271275a04b0dd971e5949913503e04247a19e145fb900e2f709c0f552efae177ebe10e78
diff --git a/net-libs/libhtp/libhtp-0.5.46.ebuild b/net-libs/libhtp/libhtp-0.5.46.ebuild
new file mode 100644
index 000000000000..59943c90f246
--- /dev/null
+++ b/net-libs/libhtp/libhtp-0.5.46.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="security-aware parser for the HTTP protocol and the related bits and pieces"
+HOMEPAGE="https://github.com/OISF/libhtp"
+SRC_URI="https://github.com/OISF/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~riscv ~x86"
+IUSE="debug"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.5.43-configure_fortify_source.patch
+)
+
+# false positive -- function specific to dev-libs/libiconv, which is only used
+# in Windows-based Prefix installations
+QA_CONFIG_IMPL_DECL_SKIP=( iconvctl )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # The debug configure logic is broken.
+ econf $(usev debug '--enable-debug')
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die "Failed to remove .la files"
+}