summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-02-21 17:50:45 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-03-16 13:13:25 +0100
commita94b2ee98ea33ff8bedaf80935211509729d116b (patch)
tree21cee103b39f0bba9705ce065c48738ac4faf2b1 /net-libs/libsrsirc/libsrsirc-0.0.14-r2.ebuild
parentsys-apps/udevil: EAPI8 bump, fix bug #832908 (diff)
downloadgentoo-a94b2ee98ea33ff8bedaf80935211509729d116b.tar.gz
gentoo-a94b2ee98ea33ff8bedaf80935211509729d116b.tar.bz2
gentoo-a94b2ee98ea33ff8bedaf80935211509729d116b.zip
net-libs/libsrsirc: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Closes: https://github.com/gentoo/gentoo/pull/35472 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'net-libs/libsrsirc/libsrsirc-0.0.14-r2.ebuild')
-rw-r--r--net-libs/libsrsirc/libsrsirc-0.0.14-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-libs/libsrsirc/libsrsirc-0.0.14-r2.ebuild b/net-libs/libsrsirc/libsrsirc-0.0.14-r2.ebuild
new file mode 100644
index 000000000000..f60c232b65ca
--- /dev/null
+++ b/net-libs/libsrsirc/libsrsirc-0.0.14-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Lightweight, cross-platform IRC library"
+HOMEPAGE="https://github.com/fstd/libsrsirc"
+SRC_URI="http://penenen.de/${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="static-libs ssl"
+
+DEPEND="ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_enable static-libs static) $(use_with ssl)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+ mv "${ED}/usr/bin/icat" "${ED}/usr/bin/icat-lsi" || die
+}