summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-02-26 00:19:48 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-02-26 00:29:42 +0100
commit15f5b932e915280dd97a24f266947446d7088af0 (patch)
tree00317ba7743c42767ef988915482df087d9eb1f1 /net-libs/ntirpc
parentsys-kernel/vanilla-sources: Linux patcn 4.4.118, 4.9.84, 4.14.22, 4.15.6 (diff)
downloadgentoo-15f5b932e915280dd97a24f266947446d7088af0.tar.gz
gentoo-15f5b932e915280dd97a24f266947446d7088af0.tar.bz2
gentoo-15f5b932e915280dd97a24f266947446d7088af0.zip
net-libs/ntirpc: Bump to v1.6.1
Ebuild changes: =============== - New upstream. - Added missing dependency on net-libs/libnsl. [Bug 647040] - Fixed "rdma" USE flag usage (USE_RPC_RDMA had a typo). Closes: https://bugs.gentoo.org/647040 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'net-libs/ntirpc')
-rw-r--r--net-libs/ntirpc/Manifest1
-rw-r--r--net-libs/ntirpc/ntirpc-1.6.1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/net-libs/ntirpc/Manifest b/net-libs/ntirpc/Manifest
index e09806e67063..737c2dc2546e 100644
--- a/net-libs/ntirpc/Manifest
+++ b/net-libs/ntirpc/Manifest
@@ -1,3 +1,4 @@
DIST ntirpc-1.4.1.tar.gz 446025 BLAKE2B 07966a9411b7919b14c318b5427c0f69b151a42c1e2137902bae9287be76dd681270b9e7baae415f4ce9acfda1007af490a6dabbd996dda0c6e7286278ea9418 SHA512 49a27dbd68b3e292437392acf2c010cc968b4d29b82b6e1a84e6c81a0c3979d3b38338212b391294b543ccd321073a33b16d7231ab68d797ead414d1b919137c
DIST ntirpc-1.5.2.tar.gz 433706 BLAKE2B ea531472f418d66fc1f530236eddef4c92ac1092150c68f19764af41e9b10e016b38073b98dc7b4a4991542977aa63b3b4330604ea5866f304fe41ac2fd85d12 SHA512 5bbc48ab5bf2aba7e4c473a6faf586c1aef27a2009bf92082495456c436c707dfdcfc5e16a56c3e31ba3fb68afc3d2d47e8d27ed03be5c0be44e22e24a0cb68e
DIST ntirpc-1.5.3.tar.gz 434096 BLAKE2B c39eaa48e4a9e648a8ce6c34e749f766bee0b9235747138a3d7535b9e07eb2dee5e85076b0dfc30907a931d8145c014938d40e65cb142ae3256eaf408b410bd2 SHA512 bc879e5cb9c16bf76b173f09fac50475ed7616837a625abd433175610cc16399abba2294a8657aadc71d4f45b4b53c97414a77bd52b1f81df3dd990407957363
+DIST ntirpc-1.6.1.tar.gz 397485 BLAKE2B 2dcc4c3a14eff55b4db52f297b65a48d5dff46ef4b1659912c65ca9104958cca02d542bb3b72f2ce63993414c5d53bb9716b1b1d4ce4b335735ee99da77f3770 SHA512 d176fbe71f1f66e5ee477c1ec2722b77742d36d67856eb4029f1b01474b08349171779a9943c0039d2a30e05debc9ab389d92ea137eabb4d7737fc91e47b0b24
diff --git a/net-libs/ntirpc/ntirpc-1.6.1.ebuild b/net-libs/ntirpc/ntirpc-1.6.1.ebuild
new file mode 100644
index 000000000000..c78565d83635
--- /dev/null
+++ b/net-libs/ntirpc/ntirpc-1.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-multilib
+
+DESCRIPTION="Transport Independent RPC library for nfs-ganesha"
+HOMEPAGE="https://github.com/nfs-ganesha/ntirpc"
+SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gssapi rdma"
+
+# Since the GSS option only controls some extra files to be enabled,
+# there's nothing to list in the depend string for it.
+RDEPEND="app-crypt/mit-krb5
+ net-libs/libnsl
+ rdma? ( sys-fabric/librdmacm )"
+DEPEND="${RDEPEND}"
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DUSE_GSS="$(usex gssapi)"
+ -DUSE_RPC_RDMA="$(usex rdma)"
+ )
+ cmake-utils_src_configure
+}