summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-03 23:57:15 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-03 23:57:15 +0100
commit6f8f4c6deead8dc832cb95a481439d7c4ac48078 (patch)
treec80f1df2c2839a716403fe7d495a1b117c381593 /net-libs/openpgm
parentapp-i18n/enca: remove old (diff)
downloadgentoo-6f8f4c6deead8dc832cb95a481439d7c4ac48078.tar.gz
gentoo-6f8f4c6deead8dc832cb95a481439d7c4ac48078.tar.bz2
gentoo-6f8f4c6deead8dc832cb95a481439d7c4ac48078.zip
Revert "net-libs/openpgm: Old."
This reverts commit e055a7b858f6963f255681c2956c1b331836b43a. net-libs/zeromq-3.2.3 depends on ~net-libs/openpgm-5.1.118 because reasons.
Diffstat (limited to 'net-libs/openpgm')
-rw-r--r--net-libs/openpgm/Manifest1
-rw-r--r--net-libs/openpgm/openpgm-5.1.118-r1.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/openpgm/Manifest b/net-libs/openpgm/Manifest
index 855abb391be9..a78137755aa4 100644
--- a/net-libs/openpgm/Manifest
+++ b/net-libs/openpgm/Manifest
@@ -1 +1,2 @@
+DIST openpgm-5.1.118.tar.gz 557816 SHA256 707cd52acaeb957f3b74044ea260fd03456612826d54cafb289a7400eb8032a9 SHA512 50acd102f03fb250cd027c8f4843749641c7b1a4c1dfc41b136627feb59209bc7a2bbd08b7edeac603fb820118c6683ae9377a692949608bad455fef91c97274 WHIRLPOOL b4b426879fd503d455afebc22d13310cf76a4a89ed314b2c102812b47398bcee7271f69ebd3de896fb0d38e49833d92fe9219eb8fbc868755188502ee6c45776
DIST openpgm-5.2.122.tar.gz 583469 SHA256 acc1545fd8060aa66b17327110e2859e451cfc685ebd3b2211619728e3471b66 SHA512 f8b29fb69acb548536179262665c0cdcc8bb1510d3e970d6abebaf33e301f87fbfa7e2c46e387973d8b65470350af66b3130482269b9fbb15fe7bf98b52f6404 WHIRLPOOL acc80b7a0093250f9046ffdbfd2c42c1a9fc8a4c00c6a0b687feadad9e907d9de843ed68dd1c183a9a768538d8840cd7b1a20af7687f0809ec7c34c5823e7791
diff --git a/net-libs/openpgm/openpgm-5.1.118-r1.ebuild b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
new file mode 100644
index 000000000000..61e8ce326ce5
--- /dev/null
+++ b/net-libs/openpgm/openpgm-5.1.118-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools-utils python-any-r1
+
+MY_PV="${PV//./-}"
+
+DESCRIPTION="Open source implementation of the Pragmatic General Multicast specification"
+HOMEPAGE="https://github.com/steve-o/openpgm"
+SRC_URI="https://github.com/steve-o/${PN}/archive/release-${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ppc ppc64 x86 ~x86-fbsd"
+IUSE="static-libs"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+
+S="${WORKDIR}/${PN}-release-${MY_PV}/${PN}/pgm"
+
+src_install() {
+ DOCS=( "${S}"/../doc/. "${S}"/README )
+
+ autotools-utils_src_install
+}