summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-07-12 17:19:10 -0700
committerMatt Turner <mattst88@gentoo.org>2022-07-12 18:02:03 -0700
commitfe4889c01028bcb838302b77827f666c56229d7a (patch)
tree37e1a139bdeefb60cc493ac779b5b0355fcaac7d /net-libs/uhttpmock
parentdev-libs/libgit2: Stabilize 1.4.4 amd64, #857798 (diff)
downloadgentoo-fe4889c01028bcb838302b77827f666c56229d7a.tar.gz
gentoo-fe4889c01028bcb838302b77827f666c56229d7a.tar.bz2
gentoo-fe4889c01028bcb838302b77827f666c56229d7a.zip
net-libs/uhttpmock: Version bump to 0.5.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/uhttpmock')
-rw-r--r--net-libs/uhttpmock/Manifest1
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.5.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/uhttpmock/Manifest b/net-libs/uhttpmock/Manifest
index 883e07b670ad..3c20f3a82cb3 100644
--- a/net-libs/uhttpmock/Manifest
+++ b/net-libs/uhttpmock/Manifest
@@ -1 +1,2 @@
DIST uhttpmock-0.5.3.tar.xz 318708 BLAKE2B 7bd257fbc8869ce2d55070bc1f84f0d34c999cd55ba5e09a54031ea391c3c65bb149d48f2ab1ab9de93acac98783ad0e7d5fca4d86dda055d4a5a3407f5ba4ee SHA512 9fccdb58ce04c1615d47bafac275c632f161a8148f0af82447286d0017d6b3946145b8a289f9abb55842bf4610ca3e5f2484bf322fb7a33dce42b3ebed45b2ee
+DIST uhttpmock-0.5.5.tar.bz2 47013 BLAKE2B 1b59801c13909525e05ec88f5ccfde1606cf427fc41896b14411344281046148bbe652162726aa643610bda447d04c64041a292b46838a3b98b849d670ce6909 SHA512 0fa6e03095c7b66ebd02736b95222b66e1232e5854839a352ee2ec59822ab027bdcf6c871b23433da46725a9807232b0b6bdd0c4cb8a59a23604787acd3d5f0f
diff --git a/net-libs/uhttpmock/uhttpmock-0.5.5.ebuild b/net-libs/uhttpmock/uhttpmock-0.5.5.ebuild
new file mode 100644
index 000000000000..5119b778510b
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.5.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.freedesktop.org/pwithnall/uhttpmock"
+SRC_URI="https://gitlab.freedesktop.org/pwithnall/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="gtk-doc +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=net-libs/libsoup-2.47.3:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+"
+BDEPEND="
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use introspection)
+ $(meson_feature vala vapi)
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}