summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-01-02 18:46:02 +0200
committerMart Raudsepp <leio@gentoo.org>2020-01-02 18:46:21 +0200
commitcd3384b4b67262108374e57cde3aee9dfe1203b3 (patch)
tree8b75c0688a9584d68f1e7ebb8c7b34ebd93e74bc /net-libs/webkit-gtk
parentgnome-base/gvfs: remove old (diff)
downloadgentoo-cd3384b4b67262108374e57cde3aee9dfe1203b3.tar.gz
gentoo-cd3384b4b67262108374e57cde3aee9dfe1203b3.tar.bz2
gentoo-cd3384b4b67262108374e57cde3aee9dfe1203b3.zip
net-libs/webkit-gtk-2.26: fix unsupported no-GL build
Closes: https://bugs.gentoo.org/704236 Package-Manager: Portage-2.3.79, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/files/2.26.2-fix-noGL-build.patch31
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild3
2 files changed, 33 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/files/2.26.2-fix-noGL-build.patch b/net-libs/webkit-gtk/files/2.26.2-fix-noGL-build.patch
new file mode 100644
index 000000000000..422c71a452f2
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.26.2-fix-noGL-build.patch
@@ -0,0 +1,31 @@
+From 0fb66b8787a857c5c51b7efdc950a6ecf930b6ee Mon Sep 17 00:00:00 2001
+From: "ross.kirsling@sony.com"
+ <ross.kirsling@sony.com@268f45cc-cd09-0410-ab3c-d52691b4dbfc>
+Date: Fri, 4 Oct 2019 20:25:56 +0000
+Subject: [PATCH] Unreviewed WinCairo build fix for r250717.
+
+* WebProcess/WebPage/CoordinatedGraphics/LayerTreeHost.h:
+(WebKit::LayerTreeHost::invalidate): Deleted.
+
+
+
+git-svn-id: https://svn.webkit.org/repository/webkit/trunk@250743 268f45cc-cd09-0410-ab3c-d52691b4dbfc
+---
+ .../WebProcess/WebPage/CoordinatedGraphics/LayerTreeHost.h | 1 -
+ 1 files changed, 0 insertions(+), 1 deletion(-)
+
+diff --git a/Source/WebKit/WebProcess/WebPage/CoordinatedGraphics/LayerTreeHost.h b/Source/WebKit/WebProcess/WebPage/CoordinatedGraphics/LayerTreeHost.h
+index 980513647ff..d214532d852 100644
+--- a/Source/WebKit/WebProcess/WebPage/CoordinatedGraphics/LayerTreeHost.h
++++ b/Source/WebKit/WebProcess/WebPage/CoordinatedGraphics/LayerTreeHost.h
+@@ -212,7 +212,6 @@ inline void LayerTreeHost::scheduleLayerFlush() { }
+ inline void LayerTreeHost::cancelPendingLayerFlush() { }
+ inline void LayerTreeHost::setRootCompositingLayer(WebCore::GraphicsLayer*) { }
+ inline void LayerTreeHost::setViewOverlayRootLayer(WebCore::GraphicsLayer*) { }
+-inline void LayerTreeHost::invalidate() { }
+ inline void LayerTreeHost::scrollNonCompositedContents(const WebCore::IntRect&) { }
+ inline void LayerTreeHost::forceRepaint() { }
+ inline bool LayerTreeHost::forceRepaintAsync(CallbackID) { return false; }
+--
+2.20.1
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
index 9cc790ed99ff..b743a3359c96 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.26.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -172,6 +172,7 @@ pkg_setup() {
src_prepare() {
eapply "${FILESDIR}/${PN}-2.24.4-icu-65.patch" # bug 698596
eapply "${FILESDIR}/${PN}-2.24.4-eglmesaext-include.patch" # bug 699054 # https://bugs.webkit.org/show_bug.cgi?id=204108
+ eapply "${FILESDIR}"/${PV}-fix-noGL-build.patch # bug 704236
cmake-utils_src_prepare
gnome2_src_prepare
}