summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-16 17:40:33 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-16 17:40:33 +0200
commit09b0d822a491acb702378ca44320bbc94a620ad2 (patch)
tree48e6cba8358a817c9d91b349f4c864f15126de42 /net-mail/fetchmail
parentnet-mail/fetchmail: drop old ~arch versions (diff)
downloadgentoo-09b0d822a491acb702378ca44320bbc94a620ad2.tar.gz
gentoo-09b0d822a491acb702378ca44320bbc94a620ad2.tar.bz2
gentoo-09b0d822a491acb702378ca44320bbc94a620ad2.zip
net-mail/fetchmail: 6.4.8 bump
Package-Manager: Portage-2.3.101, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'net-mail/fetchmail')
-rw-r--r--net-mail/fetchmail/Manifest1
-rw-r--r--net-mail/fetchmail/fetchmail-6.4.8.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/net-mail/fetchmail/Manifest b/net-mail/fetchmail/Manifest
index 5141434835e8..20dc89517c56 100644
--- a/net-mail/fetchmail/Manifest
+++ b/net-mail/fetchmail/Manifest
@@ -1,2 +1,3 @@
DIST fetchmail-6.4.1.tar.xz 1257488 BLAKE2B 101a7c2da7374eb180a4afd576bd436e074241b2071107676330e1773a33035a20f406e3dd1e0f1a280887b4556f68fc6c87be1eabf9b7e3003dff4cc740eebb SHA512 940b8df52f963f71537962ebe2b2cb88298fd2b54ca79932e5c974abe850f0b59cdc4919d606ee4f210e82d1e0a6f090ea87f1d3bdea18b531d4fbb36f7f9ea0
DIST fetchmail-6.4.6.tar.xz 1262256 BLAKE2B c5abb5b8b80f2cd61fd3c6c38956c753bb74597c585974d5529c8c7665ef13483b4292c1247df43f8702f8bd3b055b8f77bdfc2ae620bea170e8bd457fec9a49 SHA512 0101c79039c754b55e94181fb6c51f07782e581123e25ac72a99c2abe8f3ac4af3e97b12bab50813fb9300179b921c80d0bc60f528ad73c914ad266e29fb6513
+DIST fetchmail-6.4.8.tar.xz 1282300 BLAKE2B 31b7f9fa31edff534210a2a0764cc6dec461968071a8aa29b1d1e9915ff6b8d2949b128f97d72fafe6d431b06d4e5c6b38d4a3cdba06736bdf8ec1879a991798 SHA512 c1052389baafa3a48186733133130bf69b87c8dda8faa00e82f5947037845b95d3271c8183df729728a351888175174ca11eb18f9adb8b3515860cba95ab8987
diff --git a/net-mail/fetchmail/fetchmail-6.4.8.ebuild b/net-mail/fetchmail/fetchmail-6.4.8.ebuild
new file mode 100644
index 000000000000..0688fb62856d
--- /dev/null
+++ b/net-mail/fetchmail/fetchmail-6.4.8.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="tk"
+
+inherit python-single-r1 systemd toolchain-funcs autotools
+
+DESCRIPTION="the legendary remote-mail retrieval and forwarding utility"
+HOMEPAGE="http://www.fetchmail.info/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2 public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="ssl nls kerberos tk socks libressl"
+REQUIRED_USE="tk? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="acct-user/fetchmail
+ ssl? (
+ !libressl? ( >=dev-libs/openssl-1.1.1:= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ kerberos? (
+ virtual/krb5
+ !libressl? ( >=dev-libs/openssl-1.0.2:= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ nls? ( virtual/libintl )
+ !elibc_glibc? ( sys-libs/e2fsprogs-libs )
+ socks? ( net-proxy/dante )
+ tk? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/future[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ nls? ( sys-devel/gettext )"
+
+DOCS="FAQ FEATURES NEWS NOTES README README.NTLM README.SSL* TODO"
+HTML_DOCS="*.html"
+PATCHES=(
+ "${FILESDIR}"/${PN}-6.3.26-python-optional.patch
+)
+S=${WORKDIR}/${P/_/.}
+
+pkg_setup() {
+ use tk && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ # don't compile during src_install
+ use tk && : > "${S}"/py-compile
+ eautoreconf
+}
+
+src_configure() {
+ use tk || export PYTHON=:
+
+ econf \
+ --enable-RPA \
+ --enable-NTLM \
+ --enable-SDPS \
+ $(use_enable nls) \
+ $(use_with ssl ssl "${EPREFIX}/usr") \
+ $(use kerberos && echo "--with-ssl=${EPREFIX}/usr") \
+ $(use_with kerberos gssapi) \
+ $(use_with kerberos kerberos5) \
+ --without-hesiod \
+ $(use_with socks)
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)"
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/fetchmail.initd fetchmail
+ newconfd "${FILESDIR}"/fetchmail.confd fetchmail
+
+ systemd_dounit "${FILESDIR}"/${PN}.service
+ systemd_newunit "${FILESDIR}"/${PN}_at.service "${PN}@.service"
+ systemd_dotmpfilesd "${FILESDIR}"/${PN}.conf
+
+ docinto contrib
+ local f
+ for f in contrib/* ; do
+ [ -f "${f}" ] && dodoc "${f}"
+ done
+
+ use tk && python_optimize
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "Please see /etc/conf.d/fetchmail if you want to adjust"
+ elog "the polling delay used by the fetchmail init script."
+ fi
+}