summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Buchinger <cb-gentoo@guya.de>2018-12-22 10:00:40 +0100
committerThomas Deutschmann <whissi@gentoo.org>2018-12-23 00:01:52 +0100
commit4d75fcd7927ed2ec0bb23c1106c6b7d19cdac9b7 (patch)
tree10387c35ff7c34b341afd755fcb255c4f63f44de /net-misc/anydesk
parentsys-apps/grep: fix automagic dependency on dev-libs/libsigsegv (diff)
downloadgentoo-4d75fcd7927ed2ec0bb23c1106c6b7d19cdac9b7.tar.gz
gentoo-4d75fcd7927ed2ec0bb23c1106c6b7d19cdac9b7.tar.bz2
gentoo-4d75fcd7927ed2ec0bb23c1106c6b7d19cdac9b7.zip
net-misc/anydesk: Install to /opt, change desc.
* Install to /opt * Adjusted package description * Fixed elog Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Christian Buchinger <cb-gentoo@guya.de> Closes: https://github.com/gentoo/gentoo/pull/10678 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'net-misc/anydesk')
-rw-r--r--net-misc/anydesk/anydesk-4.0.1-r1.ebuild (renamed from net-misc/anydesk/anydesk-4.0.1.ebuild)16
-rw-r--r--net-misc/anydesk/files/anydesk-4.0.1.service16
-rw-r--r--net-misc/anydesk/files/anydesk.init2
3 files changed, 28 insertions, 6 deletions
diff --git a/net-misc/anydesk/anydesk-4.0.1.ebuild b/net-misc/anydesk/anydesk-4.0.1-r1.ebuild
index 45ede2ba5a90..0d1c769a03b3 100644
--- a/net-misc/anydesk/anydesk-4.0.1.ebuild
+++ b/net-misc/anydesk/anydesk-4.0.1-r1.ebuild
@@ -5,7 +5,7 @@ EAPI="6"
inherit desktop gnome2-utils systemd xdg-utils
-DESCRIPTION="The world's fastest remote desktop application"
+DESCRIPTION="Feature rich multi-platform remote desktop application"
HOMEPAGE="https://anydesk.com"
SRC_URI="amd64? ( https://download.anydesk.com/linux/${P}-amd64.tar.gz )
x86? ( https://download.anydesk.com/linux/${P}-i686.tar.gz )"
@@ -45,14 +45,20 @@ RDEPEND="
RESTRICT="bindist mirror"
-QA_PREBUILT="usr/bin/${PN}"
+QA_PREBUILT="opt/${PN}/*"
src_install() {
- exeinto /usr/bin
+ local dst="/opt/${PN}"
+
+ dodir ${dst}
+ exeinto ${dst}
doexe ${PN}
+ dodir /opt/bin
+ dosym ${dst}/${PN} /opt/bin/${PN}
+
newinitd "${FILESDIR}"/anydesk.init anydesk
- systemd_dounit systemd/anydesk.service
+ systemd_newunit "${FILESDIR}"/anydesk-4.0.1.service anydesk.service
insinto /usr/share/polkit-1/actions
doins polkit-1/com.philandro.anydesk.policy
@@ -71,7 +77,7 @@ pkg_postinst() {
xdg_desktop_database_update
gnome2_icon_cache_update
- if [[ -n ${REPLACING_VERSIONS} ]]; then
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
elog "To run AnyDesk as background service use:"
elog
elog "OpenRC:"
diff --git a/net-misc/anydesk/files/anydesk-4.0.1.service b/net-misc/anydesk/files/anydesk-4.0.1.service
new file mode 100644
index 000000000000..e7a3ef008374
--- /dev/null
+++ b/net-misc/anydesk/files/anydesk-4.0.1.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=AnyDesk
+Requires=network.target
+After=systemd-user-sessions.service
+
+[Service]
+Type=simple
+ExecStart=/opt/bin/anydesk --service
+PIDFile=/var/run/anydesk.pid
+KillMode=mixed
+TimeoutStopSec=30
+User=root
+LimitNOFILE=100000
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-misc/anydesk/files/anydesk.init b/net-misc/anydesk/files/anydesk.init
index 193f6a24721a..5b8986ed8d1b 100644
--- a/net-misc/anydesk/files/anydesk.init
+++ b/net-misc/anydesk/files/anydesk.init
@@ -4,7 +4,7 @@
name="AnyDesk service"
description="AnyDesk global service"
-command="/usr/bin/anydesk"
+command="/opt/bin/anydesk"
command_args="--service"
pidfile="/var/run/anydesk.pid"
command_background=true