summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-14 03:28:24 +0000
committerSam James <sam@gentoo.org>2022-11-14 03:48:10 +0000
commitae69f7e12c3210d3807f27dda413d7d48fe63865 (patch)
treeb952b8e87af35d36591e368184ba2a88897132f7 /net-misc/chrony/chrony-9999.ebuild
parentnet-misc/chrony: drop obsolete readline dep (diff)
downloadgentoo-ae69f7e12c3210d3807f27dda413d7d48fe63865.tar.gz
gentoo-ae69f7e12c3210d3807f27dda413d7d48fe63865.tar.bz2
gentoo-ae69f7e12c3210d3807f27dda413d7d48fe63865.zip
net-misc/chrony: simplify with usev
We're using EAPI 8, so let's take advantage of it. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/chrony/chrony-9999.ebuild')
-rw-r--r--net-misc/chrony/chrony-9999.ebuild40
1 files changed, 20 insertions, 20 deletions
diff --git a/net-misc/chrony/chrony-9999.ebuild b/net-misc/chrony/chrony-9999.ebuild
index dc5eee61c6d2..e89af76426c6 100644
--- a/net-misc/chrony/chrony-9999.ebuild
+++ b/net-misc/chrony/chrony-9999.ebuild
@@ -12,7 +12,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://git.tuxfamily.org/chrony/chrony.git"
inherit git-r3
else
- VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/mlichvar.asc
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/mlichvar.asc
inherit verify-sig
SRC_URI="https://download.tuxfamily.org/${PN}/${P/_/-}.tar.gz"
@@ -113,28 +113,28 @@ src_configure() {
local myconf=(
$(use_enable seccomp scfilter)
- $(usex caps '' '--disable-linuxcaps')
- $(usex cmdmon '' '--disable-cmdmon')
- $(usex debug '--enable-debug' '')
- $(usex ipv6 '' '--disable-ipv6')
+ $(usev !caps '--disable-linuxcaps')
+ $(usev !cmdmon '--disable-cmdmon')
+ $(usev debug '--enable-debug')
+ $(usev !ipv6 '--disable-ipv6')
# USE=readline here means "readline-like functionality"
# chrony only supports libedit in terms of the library providing
# it.
- $(usex readline '' '--without-editline --disable-readline')
-
- $(usex libtomcrypt '' '--without-tomcrypt')
- $(usex nettle '' '--without-nettle')
- $(usex nss '' '--without-nss')
- $(usex ntp '' '--disable-ntp')
- $(usex nts '' '--disable-nts')
- $(usex nts '' '--without-gnutls')
- $(usex phc '' '--disable-phc')
- $(usex pps '' '--disable-pps')
- $(usex refclock '' '--disable-refclock')
- $(usex rtc '' '--disable-rtc')
- $(usex samba '--enable-ntp-signd' '')
- $(usex sechash '' '--disable-sechash')
+ $(usev !readline '--without-editline --disable-readline')
+
+ $(usev !libtomcrypt '--without-tomcrypt')
+ $(usev !nettle '--without-nettle')
+ $(usev !nss '--without-nss')
+ $(usev !ntp '--disable-ntp')
+ $(usev !nts '--disable-nts')
+ $(usev !nts '--without-gnutls')
+ $(usev !phc '--disable-phc')
+ $(usev !pps '--disable-pps')
+ $(usev !refclock '--disable-refclock')
+ $(usev !rtc '--disable-rtc')
+ $(usev samba '--enable-ntp-signd')
+ $(usev !sechash '--disable-sechash')
--chronysockdir="${EPREFIX}/run/chrony"
--docdir="${EPREFIX}/usr/share/doc/${PF}"
@@ -157,7 +157,7 @@ src_compile() {
emake -C doc man txt
fi
- emake all docs $(usex html '' 'ADOC=true')
+ emake all docs $(usev !html 'ADOC=true')
}
src_install() {