summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 19:37:47 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-03 19:37:47 +0100
commit91a00775903ca1bb19aca687dc2234cd33a046f6 (patch)
tree88a6c357b09b5046818b1ad168d4242759c8c596 /net-misc/openr2/openr2-1.3.0.ebuild
parentnet-misc/netkit-bootpd: Port to EAPI 6 (diff)
downloadgentoo-91a00775903ca1bb19aca687dc2234cd33a046f6.tar.gz
gentoo-91a00775903ca1bb19aca687dc2234cd33a046f6.tar.bz2
gentoo-91a00775903ca1bb19aca687dc2234cd33a046f6.zip
net-misc/openr2: Port to EAPI 6
Closes: https://bugs.gentoo.org/543402 Closes: https://bugs.gentoo.org/581018 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-misc/openr2/openr2-1.3.0.ebuild')
-rw-r--r--net-misc/openr2/openr2-1.3.0.ebuild21
1 files changed, 15 insertions, 6 deletions
diff --git a/net-misc/openr2/openr2-1.3.0.ebuild b/net-misc/openr2/openr2-1.3.0.ebuild
index d00d14389463..3e45c4921241 100644
--- a/net-misc/openr2/openr2-1.3.0.ebuild
+++ b/net-misc/openr2/openr2-1.3.0.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=3
-inherit autotools base
+EAPI=6
+
+inherit autotools
DESCRIPTION="An open implementation of the MFC/R2 telephony signaling protocol"
HOMEPAGE="http://libopenr2.org/"
@@ -14,13 +15,21 @@ KEYWORDS="~amd64"
IUSE=""
RDEPEND="net-misc/dahdi"
-PATCHES=( "${FILESDIR}/${PV}-respect-user-cflags.patch" )
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-build-system.patch )
src_prepare() {
- base_src_prepare
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
+src_configure() {
+ econf --disable-static
+}
+
src_install() {
- emake DESTDIR="${D}" install || die
+ default
+ find "${D}" -name '*.la' -delete || die
}