summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-24 01:36:39 +0100
committerSam James <sam@gentoo.org>2022-07-24 01:36:39 +0100
commitf20c05d22271e90531a17a04ea279dcb126c7675 (patch)
treeaff8af1ff08d7ff1fb074516980eb357de1e7c26 /net-misc/openvswitch
parentmedia-gfx/sane-backends: add epsonds backend (diff)
downloadgentoo-f20c05d22271e90531a17a04ea279dcb126c7675.tar.gz
gentoo-f20c05d22271e90531a17a04ea279dcb126c7675.tar.bz2
gentoo-f20c05d22271e90531a17a04ea279dcb126c7675.zip
net-misc/openvswitch: fix installed script Python shebangs
Closes: https://bugs.gentoo.org/860240 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/openvswitch')
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild b/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
index 4f04cb37a9a8..0eacedda4239 100644
--- a/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
+++ b/net-misc/openvswitch/openvswitch-2.17.2-r1.ebuild
@@ -6,7 +6,7 @@ EAPI=8
MODULES_OPTIONAL_USE="modules"
PYTHON_COMPAT=( python3_{8..11} )
-inherit autotools linux-info linux-mod python-r1 systemd tmpfiles
+inherit autotools linux-info linux-mod python-single-r1 systemd tmpfiles
DESCRIPTION="Production quality, multilayer virtual switch"
HOMEPAGE="https://www.openvswitch.org"
@@ -20,9 +20,11 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
# Check python/ovs/version.py in tarball for dev-python/ovs dep
RDEPEND="${PYTHON_DEPS}
- ~dev-python/ovs-2.17.1_p1[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ ~dev-python/ovs-2.17.1_p1[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ ')
debug? ( dev-lang/perl )
ssl? ( dev-libs/openssl:= )"
DEPEND="${RDEPEND}
@@ -76,7 +78,8 @@ src_configure() {
local linux_config
use modules && linux_config="--with-linux=${KV_OUT_DIR}"
- CONFIG_SHELL="${BROOT}"/bin/bash SHELL="${BROOT}"/bin/bash econf ${linux_config} \
+ # Need PYTHON3 variable for bug #860240
+ PYTHON3="${PYTHON}" CONFIG_SHELL="${BROOT}"/bin/bash SHELL="${BROOT}"/bin/bash econf ${linux_config} \
--with-rundir=/var/run/openvswitch \
--with-logdir=/var/log/openvswitch \
--with-pkidir=/etc/ssl/openvswitch \
@@ -97,8 +100,7 @@ src_install() {
local SCRIPT
if use monitor; then
for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
- sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
- python_foreach_impl python_doscript utilities/"${SCRIPT}"
+ python_doscript utilities/"${SCRIPT}"
done
rm -r "${ED}"/usr/share/openvswitch/python || die
fi