summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-03 13:39:34 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-03 14:41:16 +0200
commit1e9bb242cd9565ab2b5ab1cb5d721c6566546f94 (patch)
treead839b1e9c55a6b99dbbbd0c1ce78d0f2659f971 /net-misc/rygel
parentnet-misc/rygel: Drop old (diff)
downloadgentoo-1e9bb242cd9565ab2b5ab1cb5d721c6566546f94.tar.gz
gentoo-1e9bb242cd9565ab2b5ab1cb5d721c6566546f94.tar.bz2
gentoo-1e9bb242cd9565ab2b5ab1cb5d721c6566546f94.zip
net-misc/rygel: Version bump
Package-Manager: portage-2.2.28
Diffstat (limited to 'net-misc/rygel')
-rw-r--r--net-misc/rygel/Manifest1
-rw-r--r--net-misc/rygel/rygel-0.28.3.ebuild84
2 files changed, 85 insertions, 0 deletions
diff --git a/net-misc/rygel/Manifest b/net-misc/rygel/Manifest
index eeef2bdd1d33..4133d2e1b066 100644
--- a/net-misc/rygel/Manifest
+++ b/net-misc/rygel/Manifest
@@ -1 +1,2 @@
DIST rygel-0.28.2.tar.xz 2244840 SHA256 9ea23df7186caac5f1aad3137edf6d507d339b9a469fc3133df4043fa66b61f5 SHA512 23d8ff2315c12e70f3c160f9047709bc3d491b3a4782a02d7c7c1a136700dcf55b880feb6a2a2ea08978377fe234a63fbb05d0dc79bfa05978886ec23da46300 WHIRLPOOL f21503dbcd2b1280501e6b16c4a55f3de436bcc91b7f77220111d60dbec942778df231c35c7d065a5ccd4ccd608ffa256258b36139340d2d2b7fa27a46295d1d
+DIST rygel-0.28.3.tar.xz 2214632 SHA256 bedb76ecb1f36b721914b5c65934f8cd01f281f9ab40c22c583902c22f169c77 SHA512 5597d21f7f227b370f3e714350d97b763a5192a7d645bd108b5a4c9cc69f5d0fd71e9e8e995c1ca112c91f62908081d16dfdddf32381c0f6107298f9c57ec0e4 WHIRLPOOL 20a1e2783f9b4ee9ffac96ba6e3d721f584a262b01e4e0b41969e7c58bf36b2560617287a71b943cd412a1589d854022204f45198a9ad46098d1a93d94a4e64d
diff --git a/net-misc/rygel/rygel-0.28.3.ebuild b/net-misc/rygel/rygel-0.28.3.ebuild
new file mode 100644
index 000000000000..54a4b2209581
--- /dev/null
+++ b/net-misc/rygel/rygel-0.28.3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 versionator virtualx
+
+DESCRIPTION="Rygel is an open source UPnP/DLNA MediaServer"
+HOMEPAGE="https://wiki.gnome.org/Projects/Rygel"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="X +introspection +sqlite tracker test transcode"
+
+# The deps for tracker? and transcode? are just the earliest available
+# version at the time of writing this ebuild
+RDEPEND="
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8:0.8
+ >=dev-libs/libxml2-2.7:2
+ >=media-libs/gupnp-dlna-0.9.4:2.0
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ >=media-libs/libmediaart-0.7:2.0
+ media-plugins/gst-plugins-soup:1.0
+ >=net-libs/gssdp-0.13
+ >=net-libs/gupnp-0.20.14
+ >=net-libs/gupnp-av-0.12.4
+ >=net-libs/libsoup-2.44:2.4
+ >=sys-apps/util-linux-2.20
+ x11-misc/shared-mime-info
+ introspection? ( >=dev-libs/gobject-introspection-1.33.4:= )
+ sqlite? (
+ >=dev-db/sqlite-3.5:3
+ dev-libs/libunistring:=
+ )
+ tracker? ( >=app-misc/tracker-0.16:= )
+ transcode? (
+ media-libs/gst-plugins-bad:1.0
+ media-plugins/gst-plugins-twolame:1.0
+ media-plugins/gst-plugins-libav:1.0
+ )
+ X? ( >=x11-libs/gtk+-3:3 )
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# Maintainer only
+# >=dev-lang/vala-0.22
+# dev-libs/libxslt
+
+src_configure() {
+ # We set xsltproc because man pages are provided by upstream
+ # and we do not want to regenerate them automagically.
+ gnome2_src_configure \
+ XSLTPROC=$(type -P false) \
+ --enable-gst-launch-plugin \
+ --enable-mediathek-plugin \
+ --with-media-engine=gstreamer \
+ --enable-nls \
+ $(use_enable introspection) \
+ $(use_enable sqlite media-export-plugin) \
+ $(use_enable test tests) \
+ $(use_enable tracker tracker-plugin) \
+ $(use_with X ui)
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ if ! version_is_at_least 0.28.2-r1 ${REPLACING_VERSIONS}; then
+ elog "This version stops forcing the automatical starting of"
+ elog "rygel as upstream pretends. This way, it will honor the"
+ elog "user settings at Sharing section in gnome-control-center."
+ elog "If you desire to keep getting rygel autostarting always"
+ elog "you will need to configure your desktop to do it."
+ fi
+}