summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-misc/ssvnc
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-misc/ssvnc')
-rw-r--r--net-misc/ssvnc/Manifest2
-rw-r--r--net-misc/ssvnc/files/Makefile.libvncauth7
-rw-r--r--net-misc/ssvnc/files/Makefile.vncviewer8
-rw-r--r--net-misc/ssvnc/files/ssvnc-1.0.27-build.patch56
-rw-r--r--net-misc/ssvnc/files/ssvnc-1.0.29-build.patch44
-rw-r--r--net-misc/ssvnc/metadata.xml10
-rw-r--r--net-misc/ssvnc/ssvnc-1.0.28.ebuild62
-rw-r--r--net-misc/ssvnc/ssvnc-1.0.29.ebuild62
8 files changed, 251 insertions, 0 deletions
diff --git a/net-misc/ssvnc/Manifest b/net-misc/ssvnc/Manifest
new file mode 100644
index 000000000000..917ea6853bc7
--- /dev/null
+++ b/net-misc/ssvnc/Manifest
@@ -0,0 +1,2 @@
+DIST ssvnc-1.0.28.src.tar.gz 542796 SHA256 a4244e81f3e3f2778af1e04d8953576133bb66607d6f3c1457a07594b94c1de1
+DIST ssvnc-1.0.29.src.tar.gz 552796 SHA256 74df32eb8eaa68b07c9693a232ebe42154617c7f3cbe1d4e68d3fe7c557d618d SHA512 ea94f8114ee7e44d788ae698dd85ee8633f0dc8e9b86e17062c733e70b4f7c7c45bf68d0ea8d3e6156395777a41e3fbf63cc9425f45db6f6fda940ae2abcd092 WHIRLPOOL 087a570c73dccc93e8c9c149c3be003b2859961518669bfb1cf9017f9c0e71d946d1a78257ea2ad2929197d7f19c3d0d8dbe81983bb667fcd1e4bfb3e6225e0e
diff --git a/net-misc/ssvnc/files/Makefile.libvncauth b/net-misc/ssvnc/files/Makefile.libvncauth
new file mode 100644
index 000000000000..c24ce4663d5d
--- /dev/null
+++ b/net-misc/ssvnc/files/Makefile.libvncauth
@@ -0,0 +1,7 @@
+AR ?= ar
+CPPFLAGS += -I. -I../include -D_GNU_SOURCE
+srcs = $(wildcard *.c)
+libvncauth.a: $(srcs:.c=.o)
+ $(AR) rc $@ $^
+clean:
+ rm -f *.[oa]
diff --git a/net-misc/ssvnc/files/Makefile.vncviewer b/net-misc/ssvnc/files/Makefile.vncviewer
new file mode 100644
index 000000000000..60879b9461a5
--- /dev/null
+++ b/net-misc/ssvnc/files/Makefile.vncviewer
@@ -0,0 +1,8 @@
+CFLAGS += -fno-strength-reduce -fno-strict-aliasing
+CPPFLAGS += -I. -I../include -D_GNU_SOURCE -DMITSHM
+LDLIBS += ../libvncauth/libvncauth.a -lz -ljpeg -lXaw -lXmu -lXt -lSM -lICE -lXpm -lXp -lXext -lX11
+include Makefile.in
+all: vncviewer
+vncviewer: $(SRCS:.c=.o)
+clean:
+ rm -f *.[oa] vncviewer
diff --git a/net-misc/ssvnc/files/ssvnc-1.0.27-build.patch b/net-misc/ssvnc/files/ssvnc-1.0.27-build.patch
new file mode 100644
index 000000000000..dc433ac2d145
--- /dev/null
+++ b/net-misc/ssvnc/files/ssvnc-1.0.27-build.patch
@@ -0,0 +1,56 @@
+https://sourceforge.net/tracker/?func=detail&aid=3031380&group_id=243486&atid=1122548
+
+--- a/vnc_unixsrc/vncviewer/sockets.c
++++ b/vnc_unixsrc/vncviewer/sockets.c
+@@ -32,6 +32,7 @@
+ #include <netdb.h>
+ #include <fcntl.h>
+ #include <assert.h>
++#include <ctype.h>
+ #include <vncviewer.h>
+
+ #ifndef SOL_IPV6
+--- a/Makefile
++++ b/Makefile
+@@ -21,11 +21,11 @@
+
+ # N.B. ?= is gnu make specific. Some of the subdir Makefiles are too.
+ #
+-PREFIX ?= /usr/local
+-ROOT ?=
++PREFIX = /usr
++ROOT = $(DESTDIR)
+ BIN = bin
+ LIB = lib/ssvnc
+ MAN = man
+-MANDIR ?= $(MAN)
++MANDIR = share/$(MAN)
+ APPS ?= share/applications
+ BINNAME ?= ssvncviewer
+@@ -66,7 +66,6 @@
+
+ install: all
+ mkdir -p $(ROOT)$(PREFIX)/$(BIN) $(ROOT)$(PREFIX)/$(LIB) $(ROOT)$(PREFIX)/$(MANDIR)/man1
+- strip $(VIEWER)
+ cp -p $(VIEWER) $(ROOT)$(PREFIX)/$(LIB)
+ cp -p $(VNCSPW) $(ROOT)$(PREFIX)/$(LIB)
+ cp -p $(UNWRAP) $(ROOT)$(PREFIX)/$(LIB)
+--- a/vncstorepw/Makefile
++++ b/vncstorepw/Makefile
+@@ -14,7 +14,6 @@
+
+ $(CMD): vncauth.o vncstorepw.o d3des.o
+ PATH=$$PATH:$(EPATH) $(CC) -o $(CMD) vncstorepw.o vncauth.o d3des.o
+- PATH=$$PATH:$(EPATH) strip $(CMD)
+ @ls -l $(CMD)
+
+ $(UNWRAP): unwrap.c
+@@ -41,7 +40,6 @@
+ else \
+ PATH=$$PATH:$(EPATH) $(CC) -o $(ULTDSM) $(CPP_SSL) ultravnc_dsm_helper.c $(LD_SSL) -lcrypto; \
+ fi
+- PATH=$$PATH:$(EPATH) strip $(ULTDSM)
+ @ls -l $(ULTDSM)
+
+ test: $(CMD)
+
diff --git a/net-misc/ssvnc/files/ssvnc-1.0.29-build.patch b/net-misc/ssvnc/files/ssvnc-1.0.29-build.patch
new file mode 100644
index 000000000000..8d2db6f5cc7f
--- /dev/null
+++ b/net-misc/ssvnc/files/ssvnc-1.0.29-build.patch
@@ -0,0 +1,44 @@
+--- a/Makefile
++++ b/Makefile
+@@ -21,11 +21,11 @@
+
+ # N.B. ?= is gnu make specific. Some of the subdir Makefiles are too.
+ #
+-PREFIX ?= /usr/local
+-ROOT ?=
++PREFIX = /usr
++ROOT = $(DESTDIR)
+ BIN = bin
+ LIB = lib/ssvnc
+ MAN = man
+-MANDIR ?= $(MAN)
++MANDIR = share/$(MAN)
+ APPS ?= share/applications
+ BINNAME ?= ssvncviewer
+@@ -66,7 +66,6 @@
+
+ install: all
+ mkdir -p $(ROOT)$(PREFIX)/$(BIN) $(ROOT)$(PREFIX)/$(LIB) $(ROOT)$(PREFIX)/$(MANDIR)/man1
+- strip $(VIEWER)
+ cp -p $(VIEWER) $(ROOT)$(PREFIX)/$(LIB)
+ cp -p $(VNCSPW) $(ROOT)$(PREFIX)/$(LIB)
+ cp -p $(UNWRAP) $(ROOT)$(PREFIX)/$(LIB)
+--- a/vncstorepw/Makefile
++++ b/vncstorepw/Makefile
+@@ -14,7 +14,6 @@
+
+ $(CMD): vncauth.o vncstorepw.o d3des.o
+ PATH=$$PATH:$(EPATH) $(CC) -o $(CMD) vncstorepw.o vncauth.o d3des.o
+- PATH=$$PATH:$(EPATH) strip $(CMD)
+ @ls -l $(CMD)
+
+ $(UNWRAP): unwrap.c
+@@ -41,7 +40,6 @@
+ else \
+ PATH=$$PATH:$(EPATH) $(CC) -o $(ULTDSM) $(CPP_SSL) ultravnc_dsm_helper.c $(LD_SSL) -lcrypto; \
+ fi
+- PATH=$$PATH:$(EPATH) strip $(ULTDSM)
+ @ls -l $(ULTDSM)
+
+ test: $(CMD)
+
diff --git a/net-misc/ssvnc/metadata.xml b/net-misc/ssvnc/metadata.xml
new file mode 100644
index 000000000000..5bd7c8a2a1ab
--- /dev/null
+++ b/net-misc/ssvnc/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>vapier@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">ssvnc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-misc/ssvnc/ssvnc-1.0.28.ebuild b/net-misc/ssvnc/ssvnc-1.0.28.ebuild
new file mode 100644
index 000000000000..2b7a1f9b321a
--- /dev/null
+++ b/net-misc/ssvnc/ssvnc-1.0.28.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="VNC viewer that adds encryption security to VNC connections"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/ssvnc.html"
+SRC_URI="mirror://sourceforge/ssvnc/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-linux"
+IUSE="java"
+
+RDEPEND="sys-libs/zlib
+ virtual/jpeg
+ dev-libs/openssl
+ dev-lang/tk
+ net-misc/stunnel
+ java? ( virtual/jre )
+ x11-terms/xterm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXpm
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.27-build.patch
+
+ sed -i \
+ -e "/^LIB/s:lib/:$(get_libdir)/:" \
+ -e "$(use java || echo '/^JSRC/s:=.*:=:')" \
+ Makefile
+ sed -i \
+ -e '/^CC/s:=.*:+= $(CFLAGS) $(CPPFLAGS) $(LDFLAGS):' \
+ vncstorepw/Makefile
+
+ cp "${FILESDIR}"/Makefile.libvncauth vnc_unixsrc/libvncauth/Makefile
+ cd "${S}"/vnc_unixsrc/vncviewer
+ sed -n '/^SRCS/,/^$/p' Imakefile > Makefile.in
+ cp "${FILESDIR}"/Makefile.vncviewer Makefile
+}
+
+src_compile() {
+ tc-export AR CC CXX RANLIB
+ emake all || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install || \
+ die "make install failed"
+ dodoc README
+}
diff --git a/net-misc/ssvnc/ssvnc-1.0.29.ebuild b/net-misc/ssvnc/ssvnc-1.0.29.ebuild
new file mode 100644
index 000000000000..211441e19117
--- /dev/null
+++ b/net-misc/ssvnc/ssvnc-1.0.29.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="VNC viewer that adds encryption security to VNC connections"
+HOMEPAGE="http://www.karlrunge.com/x11vnc/ssvnc.html"
+SRC_URI="mirror://sourceforge/ssvnc/${P}.src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~arm-linux ~x86-linux"
+IUSE="java"
+
+RDEPEND="sys-libs/zlib
+ virtual/jpeg
+ dev-libs/openssl
+ dev-lang/tk
+ net-misc/stunnel
+ java? ( virtual/jre )
+ x11-terms/xterm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXaw
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXp
+ x11-libs/libXpm
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ java? ( virtual/jdk )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.0.29-build.patch
+
+ sed -i \
+ -e "/^LIB/s:lib/:$(get_libdir)/:" \
+ -e "$(use java || echo '/^JSRC/s:=.*:=:')" \
+ Makefile
+ sed -i \
+ -e '/^CC/s:=.*:+= $(CFLAGS) $(CPPFLAGS) $(LDFLAGS):' \
+ vncstorepw/Makefile
+
+ cp "${FILESDIR}"/Makefile.libvncauth vnc_unixsrc/libvncauth/Makefile
+ cd "${S}"/vnc_unixsrc/vncviewer
+ sed -n '/^SRCS/,/^$/p' Imakefile > Makefile.in
+ cp "${FILESDIR}"/Makefile.vncviewer Makefile
+}
+
+src_compile() {
+ tc-export AR CC CXX RANLIB
+ emake all || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install || die
+ dodoc README
+}