summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony Ryan <anthonyryan1@gmail.com>2024-07-01 17:23:21 -0400
committerPacho Ramos <pacho@gentoo.org>2024-07-30 23:11:49 +0200
commit050fd509bea3bc7a6f2bd4620d87603509c0a13e (patch)
treeccae77f0153563ca4121b166b8a208385691419e /net-misc
parentnet-misc/omniORB: Support py3.12 (diff)
downloadgentoo-050fd509bea3bc7a6f2bd4620d87603509c0a13e.tar.gz
gentoo-050fd509bea3bc7a6f2bd4620d87603509c0a13e.tar.bz2
gentoo-050fd509bea3bc7a6f2bd4620d87603509c0a13e.zip
net-misc/pssh: Version bump 2.3.5, enable py3.12 & py3.13
Tested against Python 3.13 beta5, added early to satisfy pkgcheck Closes: https://bugs.gentoo.org/929728 Signed-off-by: Anthony Ryan <anthonyryan1@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37392 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pssh/Manifest1
-rw-r--r--net-misc/pssh/pssh-2.3.5.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/net-misc/pssh/Manifest b/net-misc/pssh/Manifest
index d05a4f517e35..9e3950227901 100644
--- a/net-misc/pssh/Manifest
+++ b/net-misc/pssh/Manifest
@@ -1 +1,2 @@
DIST pssh-2.3.4.tar.gz 51859 BLAKE2B 788f5239cd35e240cc1961e73b532c60e5221ede9de48878f9636339b18235dc67109948eeb4f64871985bb24e1a7f823b1718da3dbe2ea893af58fd45495c61 SHA512 7abf327ca53dda2402465254e447eb837babdd2b4d865abb5b52a1135bd234694b84c1148cb3e4ed0198271ed29333fc1b5d0d01dc653fcf6d3e5b9f170b9d4e
+DIST pssh-2.3.5.tar.gz 52364 BLAKE2B 1ab05fe39b4d510fa5dcd9cec52b4e7200bfce54445e0b345299af00be564dd20e7267f6aab3ad0c2517cfadbf6106393e8718c8ed680cfbf1ad7b6f48812d32 SHA512 47515b05c9ee2bb302e25d5404736184ad04e22afdeb77bea799d80adadd977af2744e124bd06b751bb06ad05baed6b577cc636b808f32db83edda669598e3ee
diff --git a/net-misc/pssh/pssh-2.3.5.ebuild b/net-misc/pssh/pssh-2.3.5.ebuild
new file mode 100644
index 000000000000..9ad8e6a3a95d
--- /dev/null
+++ b/net-misc/pssh/pssh-2.3.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..13} )
+inherit distutils-r1
+
+DESCRIPTION="PSSH provides parallel versions of OpenSSH and related tools"
+HOMEPAGE="https://github.com/lilydjwg/pssh"
+SRC_URI="https://github.com/lilydjwg/pssh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ !net-misc/putty
+ virtual/openssh
+"
+DEPEND="${RDEPEND}"
+
+# Requires ssh access to run.
+RESTRICT="test"