summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-04-06 21:20:44 +0100
committerSam James <sam@gentoo.org>2022-04-06 21:21:13 +0100
commitdb50f8ef891f5143f45cd548e17af125b537024b (patch)
tree1f73a0527d0c676afd6a11428a34ba808f9b592a /net-misc
parentsec-keys/openpgp-keys-dropbear: new package, add 20220406 (diff)
downloadgentoo-db50f8ef891f5143f45cd548e17af125b537024b.tar.gz
gentoo-db50f8ef891f5143f45cd548e17af125b537024b.tar.bz2
gentoo-db50f8ef891f5143f45cd548e17af125b537024b.zip
net-misc/dropbear: add 2022.82
Closes: https://bugs.gentoo.org/836900 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/dropbear/Manifest2
-rw-r--r--net-misc/dropbear/dropbear-2022.82.ebuild136
2 files changed, 138 insertions, 0 deletions
diff --git a/net-misc/dropbear/Manifest b/net-misc/dropbear/Manifest
index 9c19bcaada0f..796b3a343889 100644
--- a/net-misc/dropbear/Manifest
+++ b/net-misc/dropbear/Manifest
@@ -1 +1,3 @@
DIST dropbear-2020.81.tar.bz2 2289644 BLAKE2B eb80ff88d75ae97365570f8793aee855cc615f6a46c49c4efa026d14ba8507c41b87093ca5b86dd1fcd3602f5e24b7b9c4f83c7cf4f6dc7945ff628b09c98794 SHA512 2fa9d4d7dcb1c81281f5e47c8a99b7300eb46b3bb605daaec956404eae9124879a8bbbef521dea6da8b3643f3dc6f7f5005e265bfcaba97e89812f5642c294da
+DIST dropbear-2022.82.tar.bz2 2309514 BLAKE2B 56ff931de1e5681850a4c96b8f2c1d90db1680a08a8a741ae3034a433c2780715ede9754357477c9adfe35a310859641d7a03534e6a656e11cd7de8832fbc27d SHA512 94c664e0d56bce3750b04aff166bf073f778dc2aa08e093541b520db1f165d4173e1cf25eef69a59b0a5a0a63cfb3ce8bbf94d6c4010687a0233ba1ad8ea403b
+DIST dropbear-2022.82.tar.bz2.asc 833 BLAKE2B 7d152456f24a61add2935e7f2c9ae7a05e00137ae2c39638004cccc1fd0491311328b5e829443cbe727ae6ec9d58973270b917bae0f23ddcef0b5051b62ca60b SHA512 a45fa49857598195b8d7e51e02bf26498a74c6900245c114ce1fa19bc4eb0ef0518cbb68996c3584c0b98c22bb2078eb963e4a513f0dfb03baae6d04f5911105
diff --git a/net-misc/dropbear/dropbear-2022.82.ebuild b/net-misc/dropbear/dropbear-2022.82.ebuild
new file mode 100644
index 000000000000..27bbc8b51dd6
--- /dev/null
+++ b/net-misc/dropbear/dropbear-2022.82.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/dropbear.asc
+inherit savedconfig pam verify-sig
+
+DESCRIPTION="Small SSH 2 client/server designed for small memory environments"
+HOMEPAGE="https://matt.ucc.asn.au/dropbear/dropbear.html"
+SRC_URI="https://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2
+ https://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2"
+SRC_URI+=" verify-sig? (
+ https://matt.ucc.asn.au/dropbear/releases/${P}.tar.bz2.asc
+ https://matt.ucc.asn.au/dropbear/testing/${P}.tar.bz2.asc
+ )"
+
+LICENSE="MIT GPL-2" # (init script is GPL-2 #426056)
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="bsdpty minimal multicall pam +shadow static +syslog zlib"
+
+LIB_DEPEND="
+ virtual/libcrypt[static-libs(+)]
+ zlib? ( sys-libs/zlib[static-libs(+)] )
+"
+RDEPEND="
+ acct-group/sshd
+ acct-user/sshd
+ !static? (
+ >=dev-libs/libtomcrypt-1.18.2-r2[libtommath]
+ >=dev-libs/libtommath-1.2.0
+ ${LIB_DEPEND//\[static-libs(+)]}
+ )
+ pam? ( sys-libs/pam )
+"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
+RDEPEND+=" pam? ( >=sys-auth/pambase-20080219.1 )"
+BDEPEND="verify-sig? ( sec-keys/openpgp-keys-dropbear )"
+
+REQUIRED_USE="pam? ( !static )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.46-dbscp.patch
+)
+
+set_options() {
+ progs=(
+ dropbear dbclient dropbearkey
+ $(usex minimal "" "dropbearconvert scp")
+ )
+ makeopts=(
+ MULTI=$(usex multicall 1 0)
+ )
+}
+
+pkg_setup() {
+ if use static ; then
+ ewarn "Using bundled copies of libtommath and libtomcrypt"
+ fi
+}
+
+src_prepare() {
+ default
+ sed \
+ -e '/SFTPSERVER_PATH/s:".*":"/usr/lib/misc/sftp-server":' \
+ default_options.h > localoptions.h || die
+ sed \
+ -e '/pam_start/s:sshd:dropbear:' \
+ -i svr-authpam.c || die
+ restore_config localoptions.h
+}
+
+src_configure() {
+ # Notes:
+ # 1) We use bundled libtom* when static build is enabled because
+ # libtomcrypt lacks it and we don't particularly want to add it.
+ # 2) We disable the hardening flags as our compiler already enables them
+ # by default as is appropriate for the target.
+ local myeconfargs=(
+ --disable-harden
+
+ # bug #836900
+ $(use_enable !elibc_musl lastlog)
+ $(use_enable !elibc_musl wtmp)
+
+ $(use_enable static bundled-libtom)
+ $(use_enable zlib)
+ $(use_enable pam)
+ $(use_enable !bsdpty openpty)
+ $(use_enable shadow)
+ $(use_enable static)
+ $(use_enable syslog)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ set_options
+ emake "${makeopts[@]}" PROGRAMS="${progs[*]}"
+}
+
+src_install() {
+ set_options
+ emake "${makeopts[@]}" PROGRAMS="${progs[*]}" DESTDIR="${D}" install
+ doman *.8
+ newinitd "${FILESDIR}"/dropbear.init.d dropbear
+ newconfd "${FILESDIR}"/dropbear.conf.d dropbear
+ dodoc CHANGES README SMALL MULTI
+
+ # The multi install target does not install the links right.
+ if use multicall ; then
+ cd "${ED}"/usr/bin || die
+ local x
+ for x in "${progs[@]}" ; do
+ ln -sf dropbearmulti ${x} || die "ln -s dropbearmulti to ${x} failed"
+ done
+ rm -f dropbear
+ dodir /usr/sbin
+ dosym ../bin/dropbearmulti /usr/sbin/dropbear
+ cd "${S}" || die
+ fi
+ save_config localoptions.h
+
+ if ! use minimal ; then
+ mv "${ED}"/usr/bin/{,db}scp || die
+ fi
+
+ if use pam; then
+ pamd_mimic system-remote-login dropbear auth account password session
+ fi
+}