summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-p2p/transmission-remote-cli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-p2p/transmission-remote-cli')
-rw-r--r--net-p2p/transmission-remote-cli/Manifest2
-rw-r--r--net-p2p/transmission-remote-cli/metadata.xml16
-rw-r--r--net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.3.ebuild32
-rw-r--r--net-p2p/transmission-remote-cli/transmission-remote-cli-1.7.0.ebuild32
4 files changed, 82 insertions, 0 deletions
diff --git a/net-p2p/transmission-remote-cli/Manifest b/net-p2p/transmission-remote-cli/Manifest
new file mode 100644
index 000000000000..5319830405f7
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/Manifest
@@ -0,0 +1,2 @@
+DIST transmission-remote-cli-1.6.3.tar.gz 255899 SHA256 d24dbba397ffdfb3d2d1469644dc0cb2a5324f0bbfca8de577f76445ace9a283 SHA512 8d0b9ba7321dbcfdae358495ab819fd499845949e1ad1c03e2b3a5468d3c4b0a344a4c57de37b28b10bbf5750846c2729cbf27e9184b644139fa907d4fc4ac78 WHIRLPOOL e878cc61891fd240d84f513f9ce3d2147352a70e1e8fb3d0788f8efb4e4db268679e7329bf896c841e4b49b8c5e045346538a60ac3c5b045a62836a7d05abe23
+DIST transmission-remote-cli-1.7.0.tar.gz 256311 SHA256 d20ba26cd05bd5a5d55a5990b861bf9cd4286a54f720d22041838a51cf60db62 SHA512 86776384ac8618ccd58d3345b1a98e55ef5f0c6911fde61f6f54d9da15b1d8a244391bda4c7713e9b312132db30d732b444bebe9a753d0298e8838f779f149be WHIRLPOOL abc5daffe784df1b68d423400c2d0e94efa3e995fb1f8f53e8c571aea794d37cf714487b5b63a7a77e767b0d4668d376f675d9bbb0009b7b317b5ab058efb0a4
diff --git a/net-p2p/transmission-remote-cli/metadata.xml b/net-p2p/transmission-remote-cli/metadata.xml
new file mode 100644
index 000000000000..20f879319233
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>hendrik@consetetur.de</email>
+ <name>Hendrik v. Raven (lorem_ipsum)</name>
+ </maintainer>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">fagga/transmission-remote-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.3.ebuild b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.3.ebuild
new file mode 100644
index 000000000000..a42b4be061f7
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.6.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/fagga/transmission-remote-cli/"
+SRC_URI="https://github.com/fagga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ geoip? ( dev-python/geoip-python[$PYTHON_USEDEP] )
+"
+
+src_install() {
+ python_foreach_impl python_doscript transmission-remote-cli
+ newbashcomp completion/bash/transmission-remote-cli-bash-completion.sh \
+ transmission-remote-cli
+ doman transmission-remote-cli.1
+ dodoc NEWS README.md
+}
diff --git a/net-p2p/transmission-remote-cli/transmission-remote-cli-1.7.0.ebuild b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.7.0.ebuild
new file mode 100644
index 000000000000..a42b4be061f7
--- /dev/null
+++ b/net-p2p/transmission-remote-cli/transmission-remote-cli-1.7.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ncurses"
+inherit bash-completion-r1 python-r1
+
+DESCRIPTION="Ncurses interface for the Transmission BitTorrent client"
+HOMEPAGE="https://github.com/fagga/transmission-remote-cli/"
+SRC_URI="https://github.com/fagga/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="geoip"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ geoip? ( dev-python/geoip-python[$PYTHON_USEDEP] )
+"
+
+src_install() {
+ python_foreach_impl python_doscript transmission-remote-cli
+ newbashcomp completion/bash/transmission-remote-cli-bash-completion.sh \
+ transmission-remote-cli
+ doman transmission-remote-cli.1
+ dodoc NEWS README.md
+}