summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-proxy/c-icap/files/c-icap-0.1.4-crosscompile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-proxy/c-icap/files/c-icap-0.1.4-crosscompile.patch')
-rw-r--r--net-proxy/c-icap/files/c-icap-0.1.4-crosscompile.patch72
1 files changed, 72 insertions, 0 deletions
diff --git a/net-proxy/c-icap/files/c-icap-0.1.4-crosscompile.patch b/net-proxy/c-icap/files/c-icap-0.1.4-crosscompile.patch
new file mode 100644
index 000000000000..2e2a325989bb
--- /dev/null
+++ b/net-proxy/c-icap/files/c-icap-0.1.4-crosscompile.patch
@@ -0,0 +1,72 @@
+--- a/configure.in 2010-12-21 17:50:08.000000000 +0100
++++ b/configure.in 2011-06-10 00:24:06.000000000 +0200
+@@ -423,10 +423,8 @@
+ )
+
+ dnl Checking if interprocess posix semaphores works....
+-POSIX_SEMAPHORES="0"
+-AC_MSG_CHECKING(if posix 1003.1b interprocess semaphores works)
+-AC_TRY_RUN(
+-[
++AC_CACHE_CHECK([if posix 1003.1b interprocess semaphores works], ac_cv_10031b_ipc_sem,
++[AC_TRY_RUN([
+ #include <semaphore.h>
+ #include <sys/wait.h>
+
+@@ -452,18 +450,24 @@
+ exit(0);
+ }
+ ],
+-AC_DEFINE(HAVE_POSIX_SEMAPHORES,1,[Define HAVE_POSIX_SEMAPHORES if posix 1003.1b semaphores works])
+-POSIX_SEMAPHORES="1"
+-AC_MSG_RESULT(yes),
+-AC_MSG_RESULT(no)
++ac_cv_10031b_ipc_sem=yes,
++ac_cv_10031b_ipc_sem=no,
++[AC_MSG_ERROR([cross-compiling,
++ presetting ac_cv_10031b_ipc_sem=(yes|no) will help])]
+ )
++])
++AS_IF(
++ [test $ac_cv_10031b_ipc_sem = yes],
++ [AC_DEFINE(HAVE_POSIX_SEMAPHORES,1,[Define HAVE_POSIX_SEMAPHORES if posix 1003.1b semaphores works])
++ POSIX_SEMAPHORES="1"
++ ],[
++ POSIX_SEMAPHORES="0"
++ ])
+ AC_SUBST(POSIX_SEMAPHORES)
+
+ dnl Checking for file locking
+-POSIX_FILE_LOCK="0"
+-AC_MSG_CHECKING(if fcntl file locking works)
+-AC_TRY_RUN(
+-[
++AC_CACHE_CHECK([if fcntl file locking works], ac_cv_fcntl,
++[AC_TRY_RUN([
+ #include <unistd.h>
+ #include <fcntl.h>
+
+@@ -487,11 +491,19 @@
+ return 0;
+ }
+ ],
+-AC_DEFINE(HAVE_POSIX_FILE_LOCK,1,[Define HAVE_POSIX_FILE_LOCK if posix fcntl file locking works])
+-POSIX_FILE_LOCK="1"
+-AC_MSG_RESULT(yes),
+-AC_MSG_RESULT(no)
++ac_cv_fcntl=yes,
++ac_cv_fcntl=no,
++[AC_MSG_ERROR([cross-compiling,
++ presetting ac_cv_fcntl=(yes|no) will help])]
+ )
++])
++AS_IF(
++ [test $ac_cv_fcntl = yes],
++ [AC_DEFINE(HAVE_POSIX_FILE_LOCK,1,[Define HAVE_POSIX_FILE_LOCK if posix fcntl file locking works])
++ POSIX_FILE_LOCK="1"
++ ],[
++ POSIX_FILE_LOCK="0"
++ ])
+ AC_SUBST(POSIX_FILE_LOCK)
+
+ #pthread_rwlock