summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-voip/linphone/linphone-3.6.1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-voip/linphone/linphone-3.6.1.ebuild')
-rw-r--r--net-voip/linphone/linphone-3.6.1.ebuild117
1 files changed, 117 insertions, 0 deletions
diff --git a/net-voip/linphone/linphone-3.6.1.ebuild b/net-voip/linphone/linphone-3.6.1.ebuild
new file mode 100644
index 000000000000..59bfdb94edd7
--- /dev/null
+++ b/net-voip/linphone/linphone-3.6.1.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils multilib pax-utils versionator
+
+DESCRIPTION="Video softphone based on the SIP protocol"
+HOMEPAGE="http://www.linphone.org/"
+SRC_URI="mirror://nongnu/${PN}/$(get_version_component_range 1-2).x/sources/${P}.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${P}-exosip-4.patch"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# TODO: run-time test for ipv6: does it need mediastreamer[ipv6]?
+IUSE="assistant doc gsm-nonstandard gtk ipv6 libnotify ncurses nls sqlite ssl tools upnp video"
+
+RDEPEND="
+ >=media-libs/mediastreamer-2.9.0[ipv6?,upnp?,video?]
+ >=net-libs/libeXosip-4.0.0
+ >=net-libs/libosip-4.0.0
+ >=net-libs/ortp-0.22.0
+ virtual/udev
+ gtk? (
+ dev-libs/glib:2
+ >=gnome-base/libglade-2.4.0:2.0
+ >=x11-libs/gtk+-2.4.0:2
+ assistant? ( >=net-libs/libsoup-2.26 )
+ libnotify? ( x11-libs/libnotify )
+ )
+ gsm-nonstandard? ( >=media-libs/mediastreamer-2.9.0[gsm] )
+ ncurses? (
+ sys-libs/readline:0
+ sys-libs/ncurses
+ )
+ sqlite? ( dev-db/sqlite:3 )
+ ssl? ( dev-libs/openssl:0 )
+ tools? ( dev-libs/libxml2 )
+ upnp? ( net-libs/libupnp )
+ video? ( >=media-libs/mediastreamer-2.9.0[v4l] )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-text/sgmltools-lite )
+ nls? ( dev-util/intltool )
+"
+
+IUSE_LINGUAS=" fr it de he ja es pl cs nl sr sv pt_BR hu ru zh_CN"
+IUSE="${IUSE}${IUSE_LINGUAS// / linguas_}"
+
+pkg_setup() {
+ if ! use gtk && ! use ncurses ; then
+ ewarn "gtk and ncurses are disabled."
+ ewarn "At least one of these use flags are needed to get a front-end."
+ ewarn "Only liblinphone is going to be installed."
+ fi
+
+ strip-linguas ${IUSE_LINGUAS}
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-nls.patch \
+ "${DISTDIR}"/${P}-exosip-4.patch
+
+ # variable causes "command not found" warning and is not
+ # needed anyway
+ sed -i \
+ -e 's/$(ACLOCAL_MACOS_FLAGS)//' Makefile.am || die
+
+ # fix path to use lib64
+ sed -i \
+ -e "s:lib\(/liblinphone\):$(get_libdir)\1:" configure.ac \
+ || die "patching configure.ac failed"
+
+ # removing bundled libs dir prevent them to be reconf
+ rm -r mediastreamer2 oRTP || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable doc manual)
+ $(use_enable nls)
+ --disable-static
+ $(use_enable ncurses console_ui)
+ $(use_enable tools)
+ $(use_enable upnp)
+ $(use_enable gtk gtk_ui)
+ $(use_enable libnotify notify)
+ $(use_enable ipv6)
+ --disable-truespeech
+ $(use_enable gsm-nonstandard nonstandard-gsm)
+ $(use_enable ssl)
+ --disable-speex
+ # seems not used, TODO: ask in ml
+ $(use_enable video)
+ --disable-zrtp
+ $(usex gtk "$(use_enable assistant)" "--disable-assistant")
+ # we don't want -Werror
+ --disable-strict
+ # don't bundle libs
+ --enable-external-mediastreamer
+ $(use_enable sqlite msg-storage)
+ --enable-external-ortp
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdocdir="/usr/share/doc/${PF}" install # 415161
+ dodoc AUTHORS BUGS ChangeLog NEWS README README.arm TODO
+ pax-mark m "${ED%/}/usr/bin/linphone"
+}