summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThamognya Kodi <contact@thamognya.com>2022-06-23 07:43:41 +0700
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-08-23 14:22:34 +0200
commitf2d300e96b4075aee205b6d1a5f9158e61b242ea (patch)
tree6035d40125fa54f4784aa24290efb4e0bcf4a70b /sci-astronomy
parentsci-libs/med: filter lto flags (diff)
downloadgentoo-f2d300e96b4075aee205b6d1a5f9158e61b242ea.tar.gz
gentoo-f2d300e96b4075aee205b6d1a5f9158e61b242ea.tar.bz2
gentoo-f2d300e96b4075aee205b6d1a5f9158e61b242ea.zip
sci-astronomy/pal: Bump to 0.9.8 and EAPI 8
Signed-off-by: Thamognya Kodi <contact@thamognya.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'sci-astronomy')
-rw-r--r--sci-astronomy/pal/Manifest1
-rw-r--r--sci-astronomy/pal/pal-0.9.8.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sci-astronomy/pal/Manifest b/sci-astronomy/pal/Manifest
index eb41667654da..c64760cd991c 100644
--- a/sci-astronomy/pal/Manifest
+++ b/sci-astronomy/pal/Manifest
@@ -1 +1,2 @@
DIST pal-0.9.7.tar.gz 1220443 BLAKE2B 99ffccf0eff340f21ea99bfa219d651d0773957152bdc840b2cc7596f14c0389846128947fb63607856e76ba6a98bd113fd04eddf819f71eaa5f16b957ebc78c SHA512 d3f13e7ff321500acc71198240392fe9a3304c4142cf5b1f1c3950ddb1351dddac8565ef27b1c724d608cc1053d15647c777c4d0dc466a99a1b08b64e62ec37b
+DIST pal-0.9.8.tar.gz 1267834 BLAKE2B 0f1735b564881785ddcfab5c73480905b47c7e7a1d2b9183069f5a620584cf552df9ecccac111b33f46d59a696a40762a0c95698a153a293636071a219ca39fb SHA512 659ca2f97ac58558a638b400f83773af39002785ae3734a195ff8bfbc968af76a6c2ec5ab2dfcb7b81908391c55f31c7d4a4172705bd5fab306ef2233587e2d3
diff --git a/sci-astronomy/pal/pal-0.9.8.ebuild b/sci-astronomy/pal/pal-0.9.8.ebuild
new file mode 100644
index 000000000000..164a46ed2fe3
--- /dev/null
+++ b/sci-astronomy/pal/pal-0.9.8.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Positional Astronomy Library"
+HOMEPAGE="https://github.com/Starlink/pal"
+SRC_URI="https://github.com/Starlink/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+RDEPEND="sci-astronomy/erfa:="
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf --without-starlink \
+ --without-stardocs \
+ --with-erfa \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # remove cruft from non-fhs compliant
+ dodoc -r "${ED}"/usr/{docs,manifests,news}
+ rm -r "${ED}"/usr/{docs,manifests,news} || die
+
+ if ! use static-libs; then
+ find "${ED}" -name '*.la' -delete || die
+ fi
+}