summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-calculators/hcalc/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-calculators/hcalc/files')
-rw-r--r--sci-calculators/hcalc/files/1.0-gentoo.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/sci-calculators/hcalc/files/1.0-gentoo.patch b/sci-calculators/hcalc/files/1.0-gentoo.patch
new file mode 100644
index 000000000000..a2b24031fab8
--- /dev/null
+++ b/sci-calculators/hcalc/files/1.0-gentoo.patch
@@ -0,0 +1,57 @@
+diff --git a/Makefile b/Makefile
+index 5386821..eb5db3e 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,5 +1,5 @@
+-CC = gcc
+-CFLAGS = -g -O2 -MMD
++CC ?= gcc
++CFLAGS += -MMD
+
+ OBJS = \
+ hcalc.o \
+@@ -10,7 +10,7 @@ OBJS = \
+ $E
+
+ hcalc : $(OBJS)
+- gcc -o $@ $^ -L/usr/X11R6/lib -lXpm -lX11
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -lXpm -lX11
+
+ clean :
+ -rm -f *.o *.d *~ \#* hcalc core
+diff --git a/draw.c b/draw.c
+index 5bde83d..c3bdeb2 100644
+--- a/draw.c
++++ b/draw.c
+@@ -3,6 +3,7 @@
+ http://www.delorie.com/store/hcalc/
+ */
+ #include "hcalc.h"
++#include <string.h>
+
+ static char shown_offsets[15];
+ static int shown_bitmask;
+diff --git a/input.c b/input.c
+index d7de47c..f1d45f5 100644
+--- a/input.c
++++ b/input.c
+@@ -5,6 +5,7 @@
+ #include "hcalc.h"
+ #include <ctype.h>
+ #include <string.h>
++#include <stdlib.h>
+
+ char pending_op = 0;
+ int making_number = 0;
+diff --git a/setupx.c b/setupx.c
+index 238c1e2..74e574b 100644
+--- a/setupx.c
++++ b/setupx.c
+@@ -3,6 +3,7 @@
+ http://www.delorie.com/store/hcalc/
+ */
+ #include "hcalc.h"
++#include <stdlib.h>
+
+ Display *display=0;
+ int screen=0;