summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-07-16 16:05:58 +0200
committerDavid Seifert <soap@gentoo.org>2022-07-16 16:05:58 +0200
commitbf486b04b3c2f2513ba8fee0278e7395d4cdb63c (patch)
tree8ebe808f69d12e7a185ad401d11d4d002213c4af /sci-chemistry
parentsci-mathematics/singular: remove old "unused" ebuilds. (diff)
downloadgentoo-bf486b04b3c2f2513ba8fee0278e7395d4cdb63c.tar.gz
gentoo-bf486b04b3c2f2513ba8fee0278e7395d4cdb63c.tar.bz2
gentoo-bf486b04b3c2f2513ba8fee0278e7395d4cdb63c.zip
sci-chemistry/molden: install sci-chemistry/surf instead of bundled one
sci-chemistry/molden newly installs /bin/surf since 6.9, commit ec853626b72f ("sci-chemistry/molden: add version 6.9"), however, this is bundled version of sci-chemistry/surf which should be used instead. This change solves multiple issues: - unnecessary /bin/surf collision with sci-chemistry/surf and www-client/surf, #834033 #858209 - missing SURF license of bundled surf, which is no longer needed - ex: no python-exec wrapped executable found in /usr/lib/python-exec, #849371 issue, which is triggered by surf/surf target. x11-misc/gccmakedep and app-editors/vim dependencies are no longer needed because they were used in surf/surf target. Closes: https://github.com/gentoo/gentoo/pull/26439 Closes: https://bugs.gentoo.org/822510 Closes: https://bugs.gentoo.org/834033 Closes: https://bugs.gentoo.org/849371 Closes: https://bugs.gentoo.org/858209 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/molden/molden-6.9-r1.ebuild (renamed from sci-chemistry/molden/molden-6.9.ebuild)16
1 files changed, 6 insertions, 10 deletions
diff --git a/sci-chemistry/molden/molden-6.9.ebuild b/sci-chemistry/molden/molden-6.9-r1.ebuild
index df6e76dbfe75..e3ff6d0a079e 100644
--- a/sci-chemistry/molden/molden-6.9.ebuild
+++ b/sci-chemistry/molden/molden-6.9-r1.ebuild
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="opengl"
-RDEPEND="
+DEPEND="
x11-libs/libXmu
opengl? (
media-libs/freeglut
@@ -25,10 +25,9 @@ RDEPEND="
virtual/glu
)
"
-DEPEND="${RDEPEND}
- x11-misc/gccmakedep
- app-editors/vim"
- # vim provides ex, which the build system uses (surf/Makefile, at least)
+RDEPEND="${DEPEND}
+ sci-chemistry/surf
+"
PATCHES=(
"${FILESDIR}/${P}-ldflags.patch"
@@ -36,9 +35,6 @@ PATCHES=(
src_prepare() {
default
- sed \
- -e 's:makedepend:gccmakedep:g' \
- -i src/surf/Makefile || die
sed 's:shell g77:shell $(FC):g' -i makefile || die
}
@@ -60,7 +56,7 @@ src_compile() {
)
einfo "Building Molden..."
- emake -j1 molden ambfor/ambfor ambfor/ambmd surf/surf "${args[@]}"
+ emake -j1 molden ambfor/ambfor ambfor/ambmd "${args[@]}"
if use opengl ; then
einfo "Building Molden OpenGL helper..."
emake -j1 "${args[@]}" gmolden
@@ -68,7 +64,7 @@ src_compile() {
}
src_install() {
- dobin bin/molden bin/ambfor bin/ambmd bin/surf
+ dobin bin/molden bin/ambfor bin/ambmd
if use opengl; then
dobin bin/gmolden
doicon -s 64 haux/gmolden.png