summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZoltan Puskas <zoltan@sinustrom.info>2020-05-12 01:10:34 -0700
committerAlexey Shvetsov <alexxy@gentoo.org>2020-05-14 13:34:15 +0300
commit41cbc5c9a11f007e126063bc7b60e57b8ca24538 (patch)
tree2379795e3420a2ab835c966794e12d7bb49b771c /sci-electronics/kicad/files
parentsci-electronics/kicad-meta: Drop 5.0.1 (diff)
downloadgentoo-41cbc5c9a11f007e126063bc7b60e57b8ca24538.tar.gz
gentoo-41cbc5c9a11f007e126063bc7b60e57b8ca24538.tar.bz2
gentoo-41cbc5c9a11f007e126063bc7b60e57b8ca24538.zip
sci-electronics/kicad: Drop 5.0.1
Closes: https://bugs.gentoo.org/682480 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Zoltan Puskas <zoltan@sinustrom.info> Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'sci-electronics/kicad/files')
-rw-r--r--sci-electronics/kicad/files/kicad-5.0.0-curl.patch23
-rw-r--r--sci-electronics/kicad/files/kicad-5.0.0-help.patch117
2 files changed, 0 insertions, 140 deletions
diff --git a/sci-electronics/kicad/files/kicad-5.0.0-curl.patch b/sci-electronics/kicad/files/kicad-5.0.0-curl.patch
deleted file mode 100644
index c99071c0a548..000000000000
--- a/sci-electronics/kicad/files/kicad-5.0.0-curl.patch
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/common/CMakeLists.txt.old 2018-09-13 16:21:29.642915273 +0200
-+++ a/common/CMakeLists.txt 2018-09-13 16:23:25.146914833 +0200
-@@ -337,14 +337,17 @@
- list( APPEND COMMON_SRCS strtok_r.c )
- endif()
-
-+if( BUILD_GITHUB_PLUGIN )
-+ list( APPEND COMMON_SRCS
-+ kicad_curl/kicad_curl.cpp
-+ kicad_curl/kicad_curl_easy.cpp
-+ )
-+endif()
-
- set( COMMON_SRCS
- ${COMMON_SRCS}
- system/libcontext.cpp
-
-- kicad_curl/kicad_curl.cpp
-- kicad_curl/kicad_curl_easy.cpp
--
- view/view.cpp
- view/view_item.cpp
- view/view_group.cpp
diff --git a/sci-electronics/kicad/files/kicad-5.0.0-help.patch b/sci-electronics/kicad/files/kicad-5.0.0-help.patch
deleted file mode 100644
index 0fb43c3550ce..000000000000
--- a/sci-electronics/kicad/files/kicad-5.0.0-help.patch
+++ /dev/null
@@ -1,117 +0,0 @@
-diff -Naur kicad-5.0.1-orig/CMakeLists.txt kicad-5.0.1/CMakeLists.txt
---- kicad-5.0.1-orig/CMakeLists.txt 2018-10-08 14:14:38.000000000 -0700
-+++ kicad-5.0.1/CMakeLists.txt 2018-12-25 00:04:50.423849671 -0800
-@@ -418,6 +418,10 @@
- set( KIFACE_PREFIX "_" )
- #message( STATUS "KIFACE_SUFFIX:${KIFACE_SUFFIX} KIFACE_PREFIX:${KIFACE_PREFIX}" )
-
-+# KICAD_HELP is the location of the help files accessed from the UI
-+# (usually provided via kicad-doc package)
-+set ( KICAD_HELP share/doc/kicad
-+ CACHE PATH "Alternative location of KiCad help files.")
-
- #================================================
- # Locations for install targets.
-diff -Naur kicad-5.0.1-orig/CMakeModules/config.h.cmake kicad-5.0.1/CMakeModules/config.h.cmake
---- kicad-5.0.1-orig/CMakeModules/config.h.cmake 2018-10-08 14:14:38.000000000 -0700
-+++ kicad-5.0.1/CMakeModules/config.h.cmake 2018-12-25 00:04:39.215828924 -0800
-@@ -59,6 +59,10 @@
- /// The install prefix defined during CMake configuration or fall back to CMAKE_INSTALL_PREFIX.
- #define DEFAULT_INSTALL_PATH "@DEFAULT_INSTALL_PATH@"
-
-+/// KiCad help files path can be different on some systems allow adding alternative,
-+/// search path for them. Defaults to CMAKE_INSTALL_PREFIX/share/doc/kicad
-+#define KICAD_HELP "@KICAD_HELP@"
-+
- /// The wxPython version found during configuration.
- #if defined( KICAD_SCRIPTING_WXPYTHON )
- #define WXPYTHON_VERSION "@WXPYTHON_VERSION@"
-diff -Naur kicad-5.0.1-orig/common/searchhelpfilefullpath.cpp kicad-5.0.1/common/searchhelpfilefullpath.cpp
---- kicad-5.0.1-orig/common/searchhelpfilefullpath.cpp 2018-10-08 14:14:38.000000000 -0700
-+++ kicad-5.0.1/common/searchhelpfilefullpath.cpp 2018-12-25 00:04:05.576771741 -0800
-@@ -25,7 +25,7 @@
-
- #include <pgm_base.h>
- #include <common.h>
--#include <config.h> // to define DEFAULT_INSTALL_PATH
-+#include <config.h> // to define DEFAULT_INSTALL_PATH and KICAD_HELP
- #include <macros.h>
-
-
-@@ -68,6 +68,10 @@
- wxArrayString subdirs;
- wxArrayString altsubdirs;
- SEARCH_STACK ss = aSStack;
-+#if ! defined(__WXMAC__) // && defined(__linux__)
-+ SEARCH_STACK altss;
-+ wxArrayString moresubdirs;
-+#endif
-
- // It might already be in aSStack, but why depend on other code
- // far away when it's so easy to add it again (to our copy) as the first place to look.
-@@ -75,6 +79,7 @@
- // This is CMAKE_INSTALL_PREFIX unless DEFAULT_INSTALL_PATH was defined during
- // build configuration:
- ss.AddPaths( wxT( DEFAULT_INSTALL_PATH ), 0 );
-+ altss.AddPaths( wxT( KICAD_HELP ), 0 );
-
- #if defined(__WXMAC__)
- ss.AddPaths( GetOSXKicadMachineDataDir() );
-@@ -103,16 +108,17 @@
-
- // Based on kicad-doc.bzr/CMakeLists.txt, line 20, the help files are
- // installed into "<CMAKE_INSTALL_PREFIX>/share/doc/kicad/help" for linux.
-- // This is ${KICAD_HELP} var in that CMakeLists.txt file.
- // Below we account for an international subdirectory.
- subdirs.Add( wxT( "share" ) );
- subdirs.Add( wxT( "doc" ) );
- subdirs.Add( wxT( "kicad" ) );
- subdirs.Add( wxT( "help" ) );
-
-+ // For custom help path installations via ${KICAD_HELP}
-+ moresubdirs.Add( wxT( "help" ) );
-+
- // Based on kicad-doc.bzr/CMakeLists.txt, line 35, the help files are
- // installed into "<CMAKE_INSTALL_PREFIX>/doc/help" for Windows.
-- // This is ${KICAD_HELP} var in that CMakeLists.txt file.
- // Below we account for an international subdirectory.
- altsubdirs.Add( wxT( "doc" ) );
- altsubdirs.Add( wxT( "help" ) );
-@@ -158,6 +164,9 @@
- {
- subdirs.Add( locale_name_dirs[ii] );
- altsubdirs.Add( locale_name_dirs[ii] );
-+#if ! defined(__WXMAC__) // && defined(__linux__)
-+ moresubdirs.Add( locale_name_dirs[ii] );
-+#endif
-
- fn = FindFileInSearchPaths( ss, aBaseName + wxT( ".html" ), &altsubdirs );
-
-@@ -187,8 +196,27 @@
- if( !fn.IsEmpty() )
- break;
-
-+#if ! defined(__WXMAC__) // && defined(__linux__)
-+ fn = FindFileInSearchPaths( altss, aBaseName + wxT( ".html" ), &moresubdirs );
-+
-+ if( !fn.IsEmpty() )
-+ {
-+ // Prepend URI protocol since we will open in a browser
-+ fn = wxT( "file://" ) + fn;
-+ break;
-+ }
-+
-+ fn = FindFileInSearchPaths( altss, aBaseName + wxT( ".pdf" ), &moresubdirs );
-+
-+ if( !fn.IsEmpty() )
-+ break;
-+#endif
-+
- subdirs.RemoveAt( subdirs.GetCount() - 1 );
- altsubdirs.RemoveAt( altsubdirs.GetCount() - 1 );
-+#if ! defined(__WXMAC__) // && defined(__linux__)
-+ moresubdirs.RemoveAt( altsubdirs.GetCount() - 1 );
-+#endif
- }
-
- return fn;